aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tree-Simple-VisitorFactory
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2005-11-03 12:13:36 +0000
committerAaron Dalton <aaron@FreeBSD.org>2005-11-03 12:13:36 +0000
commit07ae353cbc193c5fddc87066637e39f11da5d37f (patch)
tree2f9e1f667f90144a9bf71e487626836081ef6e78 /devel/p5-Tree-Simple-VisitorFactory
parent872935a06db30b4cad059ecd5d2c14a66a1682e1 (diff)
downloadports-07ae353cbc193c5fddc87066637e39f11da5d37f.tar.gz
ports-07ae353cbc193c5fddc87066637e39f11da5d37f.zip
Notes
Diffstat (limited to 'devel/p5-Tree-Simple-VisitorFactory')
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/Makefile13
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/distinfo4
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/pkg-plist2
3 files changed, 12 insertions, 7 deletions
diff --git a/devel/p5-Tree-Simple-VisitorFactory/Makefile b/devel/p5-Tree-Simple-VisitorFactory/Makefile
index 529176a0f92b..1cfc87acaf9c 100644
--- a/devel/p5-Tree-Simple-VisitorFactory/Makefile
+++ b/devel/p5-Tree-Simple-VisitorFactory/Makefile
@@ -6,16 +6,18 @@
#
PORTNAME= Tree-Simple-VisitorFactory
-PORTVERSION= 0.05
+PORTVERSION= 0.08
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Tree
PKGNAMEPREFIX= p5-
-MAINTAINER= aaron@daltons.ca
+MAINTAINER= aaron@FreeBSD.org
COMMENT= A set of visitor objects for traversing Tree::Simple hierarchies
-BUILD_DEPENDS= ${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple
+BUILD_DEPENDS= ${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple \
+ ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
RUN_DEPENDS= ${BUILD_DEPENDS}
MAN3= Tree::Simple::Visitor::BreadthFirstTraversal.3 \
@@ -34,14 +36,15 @@ MAN3= Tree::Simple::Visitor::BreadthFirstTraversal.3 \
Tree::Simple::Visitor::PreOrderTraversal.3 \
Tree::Simple::Visitor::Sort.3 \
Tree::Simple::Visitor::ToNestedArray.3 \
- Tree::Simple::Visitor::ToNestedHash.3
+ Tree::Simple::Visitor::ToNestedHash.3 \
+ Tree::Simple::Visitor::VariableDepthClone.3
PERL_CONFIGURE= yes
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
-IGNORE= "This port requires perl 5.6 or above."
+IGNORE= requires perl 5.6 or above
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Tree-Simple-VisitorFactory/distinfo b/devel/p5-Tree-Simple-VisitorFactory/distinfo
index 130bcad468ce..521c6487a83b 100644
--- a/devel/p5-Tree-Simple-VisitorFactory/distinfo
+++ b/devel/p5-Tree-Simple-VisitorFactory/distinfo
@@ -1,2 +1,2 @@
-MD5 (Tree-Simple-VisitorFactory-0.05.tar.gz) = 851763393fd1bcbe5bd09a93b5b52ecc
-SIZE (Tree-Simple-VisitorFactory-0.05.tar.gz) = 26123
+MD5 (Tree-Simple-VisitorFactory-0.08.tar.gz) = da9da36dd4d34eced5c8c55c9d797cf6
+SIZE (Tree-Simple-VisitorFactory-0.08.tar.gz) = 28081
diff --git a/devel/p5-Tree-Simple-VisitorFactory/pkg-plist b/devel/p5-Tree-Simple-VisitorFactory/pkg-plist
index dc0ed3dfc243..ff8a51714274 100644
--- a/devel/p5-Tree-Simple-VisitorFactory/pkg-plist
+++ b/devel/p5-Tree-Simple-VisitorFactory/pkg-plist
@@ -1,3 +1,4 @@
+%%SITE_PERL%%/Tree/Simple/Visitor/._FindByPath.pm
%%SITE_PERL%%/Tree/Simple/Visitor/BreadthFirstTraversal.pm
%%SITE_PERL%%/Tree/Simple/Visitor/CreateDirectoryTree.pm
%%SITE_PERL%%/Tree/Simple/Visitor/FindByNodeValue.pm
@@ -14,6 +15,7 @@
%%SITE_PERL%%/Tree/Simple/Visitor/Sort.pm
%%SITE_PERL%%/Tree/Simple/Visitor/ToNestedArray.pm
%%SITE_PERL%%/Tree/Simple/Visitor/ToNestedHash.pm
+%%SITE_PERL%%/Tree/Simple/Visitor/VariableDepthClone.pm
%%SITE_PERL%%/Tree/Simple/VisitorFactory.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple/VisitorFactory/.packlist
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple/VisitorFactory