aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Tree-Simple-VisitorFactory
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-20 12:08:43 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-20 12:08:43 +0000
commit2f78a1fcc6fdcc6cfcc45b0706f6728033ec9484 (patch)
treecc7bb75b5bf8a56a9e234107baadf8c7da3b7ff8 /devel/p5-Tree-Simple-VisitorFactory
parent828195389b5ba06d7b930f4c301ddf7fa2fa04dd (diff)
downloadports-2f78a1fcc6fdcc6cfcc45b0706f6728033ec9484.tar.gz
ports-2f78a1fcc6fdcc6cfcc45b0706f6728033ec9484.zip
Notes
Diffstat (limited to 'devel/p5-Tree-Simple-VisitorFactory')
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/Makefile36
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/distinfo2
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/pkg-descr8
-rw-r--r--devel/p5-Tree-Simple-VisitorFactory/pkg-plist13
4 files changed, 59 insertions, 0 deletions
diff --git a/devel/p5-Tree-Simple-VisitorFactory/Makefile b/devel/p5-Tree-Simple-VisitorFactory/Makefile
new file mode 100644
index 000000000000..a01efd644875
--- /dev/null
+++ b/devel/p5-Tree-Simple-VisitorFactory/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Tree::Simple::VisitorFactory
+# Date created: 13 August 2004
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Tree-Simple-VisitorFactory
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Tree
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= A set of visitor objects for traversing Tree::Simple hierarchies
+
+BUILD_DEPENDS= ${SITE_PERL}/Tree/Simple.pm:${PORTSDIR}/devel/p5-Tree-Simple
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Tree::Simple::Visitor::BreadthFirstTraversal.3 \
+ Tree::Simple::Visitor::FindByPath.3 \
+ Tree::Simple::Visitor::GetAllDescendents.3 \
+ Tree::Simple::Visitor::PathToRoot.3 \
+ Tree::Simple::Visitor::PostOrderTraversal.3 \
+ Tree::Simple::VisitorFactory.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "This port requires perl 5.6 or above."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Tree-Simple-VisitorFactory/distinfo b/devel/p5-Tree-Simple-VisitorFactory/distinfo
new file mode 100644
index 000000000000..6391d9c9ba7a
--- /dev/null
+++ b/devel/p5-Tree-Simple-VisitorFactory/distinfo
@@ -0,0 +1,2 @@
+MD5 (Tree-Simple-VisitorFactory-0.01.tar.gz) = cc76e15ee4b5c8bf457f998b9033d6ed
+SIZE (Tree-Simple-VisitorFactory-0.01.tar.gz) = 9206
diff --git a/devel/p5-Tree-Simple-VisitorFactory/pkg-descr b/devel/p5-Tree-Simple-VisitorFactory/pkg-descr
new file mode 100644
index 000000000000..f769ce7f06ba
--- /dev/null
+++ b/devel/p5-Tree-Simple-VisitorFactory/pkg-descr
@@ -0,0 +1,8 @@
+Tree::Simple::VisitorFactory is a collection of visitor objects used to
+traverse Tree::Simple hierarchies.
+
+WWW: http://search.cpan.org/dist/Tree-Simple-VisitorFactory/
+Author: Stevan Little <stevan@iinteractive.com>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/devel/p5-Tree-Simple-VisitorFactory/pkg-plist b/devel/p5-Tree-Simple-VisitorFactory/pkg-plist
new file mode 100644
index 000000000000..271c056cfa71
--- /dev/null
+++ b/devel/p5-Tree-Simple-VisitorFactory/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Tree/Simple/Visitor/BreadthFirstTraversal.pm
+%%SITE_PERL%%/Tree/Simple/Visitor/FindByPath.pm
+%%SITE_PERL%%/Tree/Simple/Visitor/GetAllDescendents.pm
+%%SITE_PERL%%/Tree/Simple/Visitor/PathToRoot.pm
+%%SITE_PERL%%/Tree/Simple/Visitor/PostOrderTraversal.pm
+%%SITE_PERL%%/Tree/Simple/VisitorFactory.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple/VisitorFactory/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple/VisitorFactory
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Tree 2>/dev/null || true
+@dirrm %%SITE_PERL%%/Tree/Simple/Visitor
+@unexec rmdir %D/%%SITE_PERL%%/Tree/Simple 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Tree 2>/dev/null || true