aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-UNIVERSAL-can/Makefile
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-11-16 19:51:44 +0000
committerLars Thegler <lth@FreeBSD.org>2005-11-16 19:51:44 +0000
commitb91d140d64271f509b5aac8776987475914b822d (patch)
tree68e361f17b36067d4550807510e9a0bd5bc1de06 /devel/p5-UNIVERSAL-can/Makefile
parentbbcdbeabdb0404f86f59f8745af4a68b6b36db24 (diff)
Notes
Diffstat (limited to 'devel/p5-UNIVERSAL-can/Makefile')
-rw-r--r--devel/p5-UNIVERSAL-can/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/devel/p5-UNIVERSAL-can/Makefile b/devel/p5-UNIVERSAL-can/Makefile
new file mode 100644
index 000000000000..871af252ce50
--- /dev/null
+++ b/devel/p5-UNIVERSAL-can/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-UNIVERSAL-can
+# Date Created: 16 Nov, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= UNIVERSAL-can
+PORTVERSION= 1.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/C/CH/CHROMATIC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Hack around people calling UNIVERSAL::can() as a function
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-Test-Simple>=0.60:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Test-Warn>=0.08:${PORTSDIR}/devel/p5-Test-Warn
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= UNIVERSAL::can.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6 or later. Install lang/perl5 or lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>