aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-UNIVERSAL-isa
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-11-16 20:07:12 +0000
committerLars Thegler <lth@FreeBSD.org>2005-11-16 20:07:12 +0000
commit5c8afcbe010c74c12b4b421fe3a918535ac68fe8 (patch)
treef1885e5f989d6aa5f7b8d1a32303d21e97f9f204 /devel/p5-UNIVERSAL-isa
parent1dc06ef6c2b47a865c0aee22a529c3fec5e854e9 (diff)
downloadports-5c8afcbe010c74c12b4b421fe3a918535ac68fe8.tar.gz
ports-5c8afcbe010c74c12b4b421fe3a918535ac68fe8.zip
Notes
Diffstat (limited to 'devel/p5-UNIVERSAL-isa')
-rw-r--r--devel/p5-UNIVERSAL-isa/Makefile29
-rw-r--r--devel/p5-UNIVERSAL-isa/distinfo3
-rw-r--r--devel/p5-UNIVERSAL-isa/pkg-descr12
-rw-r--r--devel/p5-UNIVERSAL-isa/pkg-plist2
4 files changed, 46 insertions, 0 deletions
diff --git a/devel/p5-UNIVERSAL-isa/Makefile b/devel/p5-UNIVERSAL-isa/Makefile
new file mode 100644
index 000000000000..5fc40955d658
--- /dev/null
+++ b/devel/p5-UNIVERSAL-isa/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-UNIVERSAL-isa
+# Date Created: 16 Nov, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= UNIVERSAL-isa
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/N/NU/NUFFIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Hack around people calling UNIVERSAL::isa() as a function
+
+BUILD_DEPENDS= p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= UNIVERSAL::isa.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires Perl 5.8 or newer. Install lang/perl5.8 and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/devel/p5-UNIVERSAL-isa/distinfo b/devel/p5-UNIVERSAL-isa/distinfo
new file mode 100644
index 000000000000..662d83a73cd1
--- /dev/null
+++ b/devel/p5-UNIVERSAL-isa/distinfo
@@ -0,0 +1,3 @@
+MD5 (UNIVERSAL-isa-0.05.tar.gz) = 15df976064b0b3d21b2fb8808fe9c471
+SHA256 (UNIVERSAL-isa-0.05.tar.gz) = 8efb244576684f719278ea6c27b3f76abc0031bdc3e842a41092a0be2ff14449
+SIZE (UNIVERSAL-isa-0.05.tar.gz) = 3897
diff --git a/devel/p5-UNIVERSAL-isa/pkg-descr b/devel/p5-UNIVERSAL-isa/pkg-descr
new file mode 100644
index 000000000000..09cf84448165
--- /dev/null
+++ b/devel/p5-UNIVERSAL-isa/pkg-descr
@@ -0,0 +1,12 @@
+Whenever you use UNIVERSAL::isa as a function, a kitten using
+Test::MockObject dies. Normally, the kittens would be helpless, but if they
+use UNIVERSAL::isa (the module whose docs you are reading), the kittens can
+live long and prosper.
+
+This module replaces UNIVERSAL::isa with a version that makes sure that if
+it's called as a function on objects which override isa, isa will be
+called on those objects as a method.
+
+In all other cases the real UNIVERSAL::isa is just called directly.
+
+WWW: http://search.cpan.org/dist/UNIVERSAL-isa/
diff --git a/devel/p5-UNIVERSAL-isa/pkg-plist b/devel/p5-UNIVERSAL-isa/pkg-plist
new file mode 100644
index 000000000000..d2f8f1b425b2
--- /dev/null
+++ b/devel/p5-UNIVERSAL-isa/pkg-plist
@@ -0,0 +1,2 @@
+%%SITE_PERL%%/UNIVERSAL/isa.pm
+@unexec rmdir %D/%%SITE_PERL%%/UNIVERSAL 2>/dev/null || true