aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-UUID-Tiny
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-18 22:46:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-18 22:46:15 +0000
commit1e4e54bd09885200d99dd60af48144e294bde846 (patch)
tree44c61e92061812d2c2a2e860ad949d565ba529cb /devel/p5-UUID-Tiny
parent0c283ea09bf29c02c1b4023456c294901746da21 (diff)
Notes
Diffstat (limited to 'devel/p5-UUID-Tiny')
-rw-r--r--devel/p5-UUID-Tiny/Makefile27
-rw-r--r--devel/p5-UUID-Tiny/distinfo3
-rw-r--r--devel/p5-UUID-Tiny/pkg-descr3
-rw-r--r--devel/p5-UUID-Tiny/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/p5-UUID-Tiny/Makefile b/devel/p5-UUID-Tiny/Makefile
new file mode 100644
index 000000000000..2e1c32b54f04
--- /dev/null
+++ b/devel/p5-UUID-Tiny/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-UUID-Tiny
+# Date created: 2009-09-15
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= UUID-Tiny
+PORTVERSION= 1.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cjk32@cam.ac.uk
+COMMENT= Pure Perl UUID Support With Functional Interface
+
+BUILD_DEPENDS= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64 \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= UUID::Tiny.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-UUID-Tiny/distinfo b/devel/p5-UUID-Tiny/distinfo
new file mode 100644
index 000000000000..ff1927aee0e2
--- /dev/null
+++ b/devel/p5-UUID-Tiny/distinfo
@@ -0,0 +1,3 @@
+MD5 (UUID-Tiny-1.02.tar.gz) = 541cdfd56f2d953c4d7262a57a9f8d78
+SHA256 (UUID-Tiny-1.02.tar.gz) = 6cd829516bdf2edbda9daff0787ec348b3934fe86cbda0121a3f28e1a4733e72
+SIZE (UUID-Tiny-1.02.tar.gz) = 13326
diff --git a/devel/p5-UUID-Tiny/pkg-descr b/devel/p5-UUID-Tiny/pkg-descr
new file mode 100644
index 000000000000..b43a289b44f0
--- /dev/null
+++ b/devel/p5-UUID-Tiny/pkg-descr
@@ -0,0 +1,3 @@
+Pure Perl UUID Support With Functional Interface.
+
+WWW: http://search.cpan.org/dist/UUID-Tiny/
diff --git a/devel/p5-UUID-Tiny/pkg-plist b/devel/p5-UUID-Tiny/pkg-plist
new file mode 100644
index 000000000000..b3283b22d276
--- /dev/null
+++ b/devel/p5-UUID-Tiny/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/UUID/Tiny/.packlist
+%%SITE_PERL%%/UUID/Tiny.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/UUID/Tiny
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/UUID
+@dirrmtry %%SITE_PERL%%/UUID