aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-Unix-Statgrab
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-23 07:26:11 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-23 07:26:11 +0000
commit7a923897c787ff674f0267d9eaa18649c7483675 (patch)
tree470b1e45f169e17c8d0430b53a961281103ad666 /devel/p5-Unix-Statgrab
parent53a39ff770fa57ac54b61a3bde062babcdb0db64 (diff)
downloadports-7a923897c787ff674f0267d9eaa18649c7483675.tar.gz
ports-7a923897c787ff674f0267d9eaa18649c7483675.zip
Notes
Diffstat (limited to 'devel/p5-Unix-Statgrab')
-rw-r--r--devel/p5-Unix-Statgrab/Makefile35
-rw-r--r--devel/p5-Unix-Statgrab/distinfo2
-rw-r--r--devel/p5-Unix-Statgrab/files/patch-Makefile.PL11
-rw-r--r--devel/p5-Unix-Statgrab/pkg-descr7
-rw-r--r--devel/p5-Unix-Statgrab/pkg-plist8
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/p5-Unix-Statgrab/Makefile b/devel/p5-Unix-Statgrab/Makefile
new file mode 100644
index 000000000000..baf82bbd8b4f
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: p5-Unix-Statgrab
+# Date created: June 20th, 2004
+# Whom: Tim Bishop <tim@bishnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Unix-Statgrab
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Unix
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tim@bishnet.net
+COMMENT= Perl extension for collecting information about the machine
+
+LIB_DEPENDS= statgrab.5:${PORTSDIR}/devel/libstatgrab
+
+USE_GNOME= pkgconfig
+
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= INC="`pkg-config libstatgrab --cflags`" \
+ LIBS="`pkg-config libstatgrab --libs`"
+
+MAN3= Unix::Statgrab.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+post-patch:
+ ${PERL} -i -pe 's/}\(/}->(/' ${WRKSRC}/lib/Unix/Statgrab.pm
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Unix-Statgrab/distinfo b/devel/p5-Unix-Statgrab/distinfo
new file mode 100644
index 000000000000..e4fcb42b2f7d
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/distinfo
@@ -0,0 +1,2 @@
+MD5 (Unix-Statgrab-0.01.tar.gz) = a9af99129244c8bdc73ff447e6059969
+SIZE (Unix-Statgrab-0.01.tar.gz) = 20459
diff --git a/devel/p5-Unix-Statgrab/files/patch-Makefile.PL b/devel/p5-Unix-Statgrab/files/patch-Makefile.PL
new file mode 100644
index 000000000000..e9e029123c7d
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/files/patch-Makefile.PL
@@ -0,0 +1,11 @@
+--- Makefile.PL.bak Sun Jun 20 22:44:53 2004
++++ Makefile.PL Sun Jun 20 22:45:05 2004
+@@ -7,7 +7,7 @@
+ my %args = map { split /\s*=\s*/ } @ARGV;
+ my $LIBS = $args{ LIBS } || "-lstatgrab";
+ my $INC = $args{ INC };
+- return 1 if system("$CC check.c $INC $LIBS -o /dev/null 2>/dev/null") == 0;
++ return 1 if system("$CC check.c $INC $LIBS 2>/dev/null") == 0;
+ return 0;
+ }
+
diff --git a/devel/p5-Unix-Statgrab/pkg-descr b/devel/p5-Unix-Statgrab/pkg-descr
new file mode 100644
index 000000000000..6ed6cbaf8926
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/pkg-descr
@@ -0,0 +1,7 @@
+Unix::Statgrab is a wrapper for libstatgrab, as available from
+http://www.i-scream.org/libstatgrab/. It is a reasonably portable
+attempt to query interesting stats about your computer. It covers
+information on the operating system, CPU, memory usage, network
+interfaces, hard-disks etc.
+
+WWW: http://search.cpan.org/dist/Unix-Statgrab/
diff --git a/devel/p5-Unix-Statgrab/pkg-plist b/devel/p5-Unix-Statgrab/pkg-plist
new file mode 100644
index 000000000000..9c48d2083268
--- /dev/null
+++ b/devel/p5-Unix-Statgrab/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/Statgrab.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/Statgrab.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/autosplit.ix
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/Unix/Statgrab.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix/Statgrab
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Unix 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Unix 2>/dev/null || true