aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-User-Identity/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 20:01:59 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 20:01:59 +0000
commit43e51e96fcd13ea59432655400809ba4ce862ddf (patch)
tree4cb6b28dcdd13210100fd6803758aa3bae286e09 /devel/p5-User-Identity/Makefile
parent24d34901c997ba6491887730acc151241f3f4e8c (diff)
downloadports-43e51e96fcd13ea59432655400809ba4ce862ddf.tar.gz
ports-43e51e96fcd13ea59432655400809ba4ce862ddf.zip
Notes
Diffstat (limited to 'devel/p5-User-Identity/Makefile')
-rw-r--r--devel/p5-User-Identity/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/devel/p5-User-Identity/Makefile b/devel/p5-User-Identity/Makefile
new file mode 100644
index 000000000000..8bce751d4815
--- /dev/null
+++ b/devel/p5-User-Identity/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-User-Identity
+# Date created: 21 Jul 2005
+# Whom: Max Campos <mcampos@bpsw.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= User-Identity
+PORTVERSION= 0.90
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= User
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mcampos@bpsw.biz
+COMMENT= Perl module for abstracting information about a physical person
+
+RUN_DEPENDS= ${SITE_PERL}/Geography/Countries.pm:${PORTSDIR}/misc/p5-Geography-Countries
+
+PERL_CONFIGURE= yes
+
+MAN3= Mail::Identity.3 \
+ User::Identity.3 \
+ User::Identity::Archive.3 \
+ User::Identity::Archive::Plain.3 \
+ User::Identity::Collection.3 \
+ User::Identity::Collection::Emails.3 \
+ User::Identity::Collection::Locations.3 \
+ User::Identity::Collection::Systems.3 \
+ User::Identity::Collection::Users.3 \
+ User::Identity::Item.3 \
+ User::Identity::Location.3 \
+ User::Identity::System.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer
+.endif
+
+.include <bsd.port.post.mk>