aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-User-Identity
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 20:01:59 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-07-24 20:01:59 +0000
commit43e51e96fcd13ea59432655400809ba4ce862ddf (patch)
tree4cb6b28dcdd13210100fd6803758aa3bae286e09 /devel/p5-User-Identity
parent24d34901c997ba6491887730acc151241f3f4e8c (diff)
downloadports-43e51e96fcd13ea59432655400809ba4ce862ddf.tar.gz
ports-43e51e96fcd13ea59432655400809ba4ce862ddf.zip
Notes
Diffstat (limited to 'devel/p5-User-Identity')
-rw-r--r--devel/p5-User-Identity/Makefile41
-rw-r--r--devel/p5-User-Identity/distinfo2
-rw-r--r--devel/p5-User-Identity/pkg-descr7
-rw-r--r--devel/p5-User-Identity/pkg-plist32
4 files changed, 82 insertions, 0 deletions
diff --git a/devel/p5-User-Identity/Makefile b/devel/p5-User-Identity/Makefile
new file mode 100644
index 000000000000..8bce751d4815
--- /dev/null
+++ b/devel/p5-User-Identity/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: p5-User-Identity
+# Date created: 21 Jul 2005
+# Whom: Max Campos <mcampos@bpsw.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= User-Identity
+PORTVERSION= 0.90
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= User
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mcampos@bpsw.biz
+COMMENT= Perl module for abstracting information about a physical person
+
+RUN_DEPENDS= ${SITE_PERL}/Geography/Countries.pm:${PORTSDIR}/misc/p5-Geography-Countries
+
+PERL_CONFIGURE= yes
+
+MAN3= Mail::Identity.3 \
+ User::Identity.3 \
+ User::Identity::Archive.3 \
+ User::Identity::Archive::Plain.3 \
+ User::Identity::Collection.3 \
+ User::Identity::Collection::Emails.3 \
+ User::Identity::Collection::Locations.3 \
+ User::Identity::Collection::Systems.3 \
+ User::Identity::Collection::Users.3 \
+ User::Identity::Item.3 \
+ User::Identity::Location.3 \
+ User::Identity::System.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires Perl 5.6 or newer
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-User-Identity/distinfo b/devel/p5-User-Identity/distinfo
new file mode 100644
index 000000000000..8282d9583fcb
--- /dev/null
+++ b/devel/p5-User-Identity/distinfo
@@ -0,0 +1,2 @@
+MD5 (User-Identity-0.90.tar.gz) = d6683da60cb299ea11e63546f9e4e3b6
+SIZE (User-Identity-0.90.tar.gz) = 25502
diff --git a/devel/p5-User-Identity/pkg-descr b/devel/p5-User-Identity/pkg-descr
new file mode 100644
index 000000000000..d71afd793a1f
--- /dev/null
+++ b/devel/p5-User-Identity/pkg-descr
@@ -0,0 +1,7 @@
+User::Identity is a Perl module for abstracting information about a
+physical person.
+
+WWW: http://search.cpan.org/search?dist=User-Identity
+
+- Max Campos
+mcampos@bpsw.biz
diff --git a/devel/p5-User-Identity/pkg-plist b/devel/p5-User-Identity/pkg-plist
new file mode 100644
index 000000000000..1ee66026b4fe
--- /dev/null
+++ b/devel/p5-User-Identity/pkg-plist
@@ -0,0 +1,32 @@
+%%SITE_PERL%%/Mail/Identity.pm
+%%SITE_PERL%%/Mail/Identity.pod
+%%SITE_PERL%%/User/Identity.pm
+%%SITE_PERL%%/User/Identity.pod
+%%SITE_PERL%%/User/Identity/Archive.pm
+%%SITE_PERL%%/User/Identity/Archive.pod
+%%SITE_PERL%%/User/Identity/Archive/Plain.pm
+%%SITE_PERL%%/User/Identity/Archive/Plain.pod
+%%SITE_PERL%%/User/Identity/Collection.pm
+%%SITE_PERL%%/User/Identity/Collection.pod
+%%SITE_PERL%%/User/Identity/Collection/Emails.pm
+%%SITE_PERL%%/User/Identity/Collection/Emails.pod
+%%SITE_PERL%%/User/Identity/Collection/Locations.pm
+%%SITE_PERL%%/User/Identity/Collection/Locations.pod
+%%SITE_PERL%%/User/Identity/Collection/Systems.pm
+%%SITE_PERL%%/User/Identity/Collection/Systems.pod
+%%SITE_PERL%%/User/Identity/Collection/Users.pm
+%%SITE_PERL%%/User/Identity/Collection/Users.pod
+%%SITE_PERL%%/User/Identity/Item.pm
+%%SITE_PERL%%/User/Identity/Item.pod
+%%SITE_PERL%%/User/Identity/Location.pm
+%%SITE_PERL%%/User/Identity/Location.pod
+%%SITE_PERL%%/User/Identity/System.pm
+%%SITE_PERL%%/User/Identity/System.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/User/Identity/.packlist
+@dirrm %%SITE_PERL%%/User/Identity/Archive
+@dirrm %%SITE_PERL%%/User/Identity/Collection
+@dirrm %%SITE_PERL%%/User/Identity
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/User/Identity
+@unexec rmdir %D/%%SITE_PERL%%/Mail 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/User 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/User 2>/dev/null || true