aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-carton
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2014-01-19 15:46:51 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2014-01-19 15:46:51 +0000
commit8d74296ccb62267834c5d25f0f0f0f23e952b501 (patch)
tree636ec2f409d897be568aab654ea08263ed16a5c2 /devel/p5-carton
parentb96685434693136d8c64b4d0fb7d401830a6f3f6 (diff)
Notes
Diffstat (limited to 'devel/p5-carton')
-rw-r--r--devel/p5-carton/Makefile28
-rw-r--r--devel/p5-carton/distinfo4
-rw-r--r--devel/p5-carton/pkg-descr2
-rw-r--r--devel/p5-carton/pkg-plist31
4 files changed, 44 insertions, 21 deletions
diff --git a/devel/p5-carton/Makefile b/devel/p5-carton/Makefile
index bdd907297d2f..448a96a2e72a 100644
--- a/devel/p5-carton/Makefile
+++ b/devel/p5-carton/Makefile
@@ -1,41 +1,33 @@
# $FreeBSD$
PORTNAME= carton
-PORTVERSION= 0.9.15
+PORTVERSION= 1.0.12
CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MIYAGAWA
PKGNAMEPREFIX= p5-
-DISTNAME= ${PORTNAME}-v${PORTVERSION}
+DISTNAME= Carton-v${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Perl module dependency manager
RUN_DEPENDS= \
- p5-App-cpanminus>=1.6:${PORTSDIR}/devel/p5-App-cpanminus \
+ p5-App-FatPacker>=0.009018:${PORTSDIR}/devel/p5-App-FatPacker \
+ p5-App-cpanminus>=1.694:${PORTSDIR}/devel/p5-App-cpanminus \
p5-CPAN-Meta>=2.120921:${PORTSDIR}/devel/p5-CPAN-Meta \
p5-CPAN-Meta-Requirements>=2.121:${PORTSDIR}/devel/p5-CPAN-Meta-Requirements \
- p5-Capture-Tiny>0:${PORTSDIR}/devel/p5-Capture-Tiny \
p5-Exception-Class>=1.32:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-File-pushd>0:${PORTSDIR}/devel/p5-File-pushd \
p5-JSON>=2.53:${PORTSDIR}/converters/p5-JSON \
- p5-Module-CPANfile>=0.9004:${PORTSDIR}/devel/p5-Module-CPANfile \
+ p5-Module-CPANfile>=0.9031:${PORTSDIR}/devel/p5-Module-CPANfile \
p5-Module-Metadata>=1.000003:${PORTSDIR}/devel/p5-Module-Metadata \
- p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny \
- p5-local-lib>=1.008:${PORTSDIR}/devel/p5-local-lib
+ p5-Module-Reader>=0.002:${PORTSDIR}/devel/p5-Module-Reader \
+ p5-Moo>=1.002:${PORTSDIR}/devel/p5-Moo \
+ p5-Path-Tiny>=0.033:${PORTSDIR}/devel/p5-Path-Tiny \
+ p5-Try-Tiny>=0.09:${PORTSDIR}/lang/p5-Try-Tiny
BUILD_DEPENDS:= ${RUN_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-MAN3= Carton.3 \
- Carton::Doc::Check.3 \
- Carton::Doc::Exec.3 \
- Carton::Doc::FAQ.3 \
- Carton::Doc::Install.3 \
- Carton::Doc::List.3 \
- Carton::Doc::Show.3 \
- Carton::Doc::Tree.3 \
- Carton::Doc::Version.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/devel/p5-carton/distinfo b/devel/p5-carton/distinfo
index ba341fcb2185..e5ab914fb21b 100644
--- a/devel/p5-carton/distinfo
+++ b/devel/p5-carton/distinfo
@@ -1,2 +1,2 @@
-SHA256 (carton-v0.9.15.tar.gz) = 4407648c44729742c7170e98c6f5aa3f32f89ed0d7262f141703dbf981f906b8
-SIZE (carton-v0.9.15.tar.gz) = 77756
+SHA256 (Carton-v1.0.12.tar.gz) = 6ae0ae33bfa75e7cf23fd8d486fc6ed8b1dbb994472a8160e214498e95ddc3c3
+SIZE (Carton-v1.0.12.tar.gz) = 85683
diff --git a/devel/p5-carton/pkg-descr b/devel/p5-carton/pkg-descr
index 835d05fafabc..dc3db7c33a89 100644
--- a/devel/p5-carton/pkg-descr
+++ b/devel/p5-carton/pkg-descr
@@ -4,4 +4,4 @@ carton.lock file, which is meant to be version controlled, and the
lock file allows other developers of your application will have the
exact same versions of the modules.
-WWW: http://search.cpan.org/dist/carton/
+WWW: http://search.cpan.org/dist/Carton/
diff --git a/devel/p5-carton/pkg-plist b/devel/p5-carton/pkg-plist
index 5d05dfba963b..c21bfdb3108f 100644
--- a/devel/p5-carton/pkg-plist
+++ b/devel/p5-carton/pkg-plist
@@ -1,6 +1,25 @@
+man/man1/carton.1.gz
+%%PERL5_MAN3%%/Carton.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Bundle.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Check.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Exec.3.gz
+%%PERL5_MAN3%%/Carton::Doc::FAQ.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Install.3.gz
+%%PERL5_MAN3%%/Carton::Doc::List.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Show.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Tree.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Update.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Upgrading.3.gz
+%%PERL5_MAN3%%/Carton::Doc::Version.3.gz
bin/carton
%%SITE_PERL%%/Carton.pm
+%%SITE_PERL%%/Carton/Builder.pm
%%SITE_PERL%%/Carton/CLI.pm
+%%SITE_PERL%%/Carton/CPANfile.pm
+%%SITE_PERL%%/Carton/Dependency.pm
+%%SITE_PERL%%/Carton/Dist.pm
+%%SITE_PERL%%/Carton/Dist/Core.pm
+%%SITE_PERL%%/Carton/Doc/Bundle.pod
%%SITE_PERL%%/Carton/Doc/Check.pod
%%SITE_PERL%%/Carton/Doc/Exec.pod
%%SITE_PERL%%/Carton/Doc/FAQ.pod
@@ -8,9 +27,21 @@ bin/carton
%%SITE_PERL%%/Carton/Doc/List.pod
%%SITE_PERL%%/Carton/Doc/Show.pod
%%SITE_PERL%%/Carton/Doc/Tree.pod
+%%SITE_PERL%%/Carton/Doc/Update.pod
+%%SITE_PERL%%/Carton/Doc/Upgrading.pod
%%SITE_PERL%%/Carton/Doc/Version.pod
+%%SITE_PERL%%/Carton/Environment.pm
%%SITE_PERL%%/Carton/Error.pm
+%%SITE_PERL%%/Carton/Index.pm
+%%SITE_PERL%%/Carton/Mirror.pm
+%%SITE_PERL%%/Carton/Package.pm
+%%SITE_PERL%%/Carton/Packer.pm
+%%SITE_PERL%%/Carton/Snapshot.pm
+%%SITE_PERL%%/Carton/Snapshot/Emitter.pm
+%%SITE_PERL%%/Carton/Snapshot/Parser.pm
%%SITE_PERL%%/Carton/Tree.pm
%%SITE_PERL%%/Carton/Util.pm
+@dirrm %%SITE_PERL%%/Carton/Snapshot
@dirrm %%SITE_PERL%%/Carton/Doc
+@dirrm %%SITE_PERL%%/Carton/Dist
@dirrm %%SITE_PERL%%/Carton