aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-constant-lexical
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:45:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-11-21 20:45:41 +0000
commita4bb32a2aa0f4e8f0019f4b8c9bfbf368b3f3350 (patch)
tree3b7bdd862f420513d68e11765871103ca1d29653 /devel/p5-constant-lexical
parent4f9a4470e198218dbffdd01b99a37201ab7ecec4 (diff)
Notes
Diffstat (limited to 'devel/p5-constant-lexical')
-rw-r--r--devel/p5-constant-lexical/Makefile25
-rw-r--r--devel/p5-constant-lexical/distinfo3
-rw-r--r--devel/p5-constant-lexical/pkg-descr4
-rw-r--r--devel/p5-constant-lexical/pkg-plist6
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/p5-constant-lexical/Makefile b/devel/p5-constant-lexical/Makefile
new file mode 100644
index 000000000000..e3378721c0b6
--- /dev/null
+++ b/devel/p5-constant-lexical/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-constant-lexical
+# Date created: 2008-11-16
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= constant-lexical
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/S/SP/SPROUT
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl pragma to declare lexical compile-time constants
+
+RUN_DEPENDS= p5-Sub-Delete>0:${PORTSDIR}/devel/p5-Sub-Delete
+
+PERL_CONFIGURE= yes
+USE_PERL5= 5.8.0+
+
+MAN3= constant::lexical.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-constant-lexical/distinfo b/devel/p5-constant-lexical/distinfo
new file mode 100644
index 000000000000..de0b08438a92
--- /dev/null
+++ b/devel/p5-constant-lexical/distinfo
@@ -0,0 +1,3 @@
+MD5 (constant-lexical-0.01.tar.gz) = 0a46f9aa30b596ee5ef0f50925094960
+SHA256 (constant-lexical-0.01.tar.gz) = 4663a9916e88c592e1d4e31145def8f0b20bd557fb0993126168fabb88f70d34
+SIZE (constant-lexical-0.01.tar.gz) = 3280
diff --git a/devel/p5-constant-lexical/pkg-descr b/devel/p5-constant-lexical/pkg-descr
new file mode 100644
index 000000000000..cf7979f31141
--- /dev/null
+++ b/devel/p5-constant-lexical/pkg-descr
@@ -0,0 +1,4 @@
+This module creates compile-time constants in the manner of
+constant.pm, but makes them local to the enclosing scope.
+
+WWW: http://search.cpan.org/dist/constant-lexical/
diff --git a/devel/p5-constant-lexical/pkg-plist b/devel/p5-constant-lexical/pkg-plist
new file mode 100644
index 000000000000..3914ee331efc
--- /dev/null
+++ b/devel/p5-constant-lexical/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/constant/lexical/.packlist
+%%SITE_PERL%%/constant/lexical.pm
+@dirrmtry %%SITE_PERL%%/constant
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/constant/lexical
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/constant