aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-threads/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-30 01:44:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-30 01:44:26 +0000
commit30938ff588f1136ca1111e40bc835c6a2123c022 (patch)
treece254f8e7f2066de16c5ae442e537667ae1d2e86 /devel/p5-threads/Makefile
parent6129d2229dd1ebb508fb2ba265844b0b911701f0 (diff)
downloadports-30938ff588f1136ca1111e40bc835c6a2123c022.tar.gz
ports-30938ff588f1136ca1111e40bc835c6a2123c022.zip
Notes
Diffstat (limited to 'devel/p5-threads/Makefile')
-rw-r--r--devel/p5-threads/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/p5-threads/Makefile b/devel/p5-threads/Makefile
new file mode 100644
index 000000000000..ea2ad5b70a99
--- /dev/null
+++ b/devel/p5-threads/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-threads
+# Date created: 2006-07-22
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= threads
+PORTVERSION= 1.37
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/J/JD/JDHEDDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interpreter-based threads
+
+PERL_CONFIGURE= yes
+
+MAN3= threads.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>