aboutsummaryrefslogtreecommitdiff
path: root/devel/p5-threads
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-08-30 01:44:26 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-08-30 01:44:26 +0000
commit30938ff588f1136ca1111e40bc835c6a2123c022 (patch)
treece254f8e7f2066de16c5ae442e537667ae1d2e86 /devel/p5-threads
parent6129d2229dd1ebb508fb2ba265844b0b911701f0 (diff)
downloadports-30938ff588f1136ca1111e40bc835c6a2123c022.tar.gz
ports-30938ff588f1136ca1111e40bc835c6a2123c022.zip
Notes
Diffstat (limited to 'devel/p5-threads')
-rw-r--r--devel/p5-threads/Makefile28
-rw-r--r--devel/p5-threads/distinfo3
-rw-r--r--devel/p5-threads/pkg-descr21
-rw-r--r--devel/p5-threads/pkg-plist6
4 files changed, 58 insertions, 0 deletions
diff --git a/devel/p5-threads/Makefile b/devel/p5-threads/Makefile
new file mode 100644
index 000000000000..ea2ad5b70a99
--- /dev/null
+++ b/devel/p5-threads/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-threads
+# Date created: 2006-07-22
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= threads
+PORTVERSION= 1.37
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/J/JD/JDHEDDEN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl interpreter-based threads
+
+PERL_CONFIGURE= yes
+
+MAN3= threads.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-threads/distinfo b/devel/p5-threads/distinfo
new file mode 100644
index 000000000000..155f95ccc3f5
--- /dev/null
+++ b/devel/p5-threads/distinfo
@@ -0,0 +1,3 @@
+MD5 (threads-1.37.tar.gz) = 0263111f57779bfbcaa554233d53d222
+SHA256 (threads-1.37.tar.gz) = 0a6c7d204ef19dc22cd8ef9e97cbb669fbf93beba0c325c00ea395c7259f4c62
+SIZE (threads-1.37.tar.gz) = 74001
diff --git a/devel/p5-threads/pkg-descr b/devel/p5-threads/pkg-descr
new file mode 100644
index 000000000000..08b207665696
--- /dev/null
+++ b/devel/p5-threads/pkg-descr
@@ -0,0 +1,21 @@
+Perl 5.6 introduced something called interpreter threads. Interpreter
+threads are different from 5005threads (the thread model of Perl 5.005)
+by creating a new Perl interpreter per thread, and not sharing any
+data or state between threads by default.
+
+Prior to Perl 5.8, this has only been available to people embedding
+Perl, and for emulating fork() on Windows.
+
+The threads API is loosely based on the old Thread.pm API. It is very
+important to note that variables are not shared between threads, all
+variables are by default thread local. To use shared variables one
+must use threads::shared.
+
+It is also important to note that you must enable threads by doing use
+threads as early as possible in the script itself, and that it is not
+possible to enable threading inside an eval "", do, require, or use.
+In particular, if you are intending to share variables with
+threads::shared, you must use threads before you use threads::shared.
+(threads will emit a warning if you do it the other way around.)
+
+WWW: http://search.cpan.org/dist/threads/
diff --git a/devel/p5-threads/pkg-plist b/devel/p5-threads/pkg-plist
new file mode 100644
index 000000000000..7183620bccf0
--- /dev/null
+++ b/devel/p5-threads/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/threads/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/threads/threads.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/threads/threads.so
+%%SITE_PERL%%/%%PERL_ARCH%%/threads.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/threads