aboutsummaryrefslogtreecommitdiff
path: root/devel/parrot/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-25 07:42:41 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-07-25 07:42:41 +0000
commit17ef2ad67a04207f29add8fc7e705e58809b616f (patch)
tree5b03133e8598123574f1c66f9369b1179bdd79a1 /devel/parrot/Makefile
parent609f4b0f42f8f6642c8fd3f50bc097e33a67ad61 (diff)
Notes
Diffstat (limited to 'devel/parrot/Makefile')
-rw-r--r--devel/parrot/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/parrot/Makefile b/devel/parrot/Makefile
new file mode 100644
index 000000000000..61feaf3e6d56
--- /dev/null
+++ b/devel/parrot/Makefile
@@ -0,0 +1,36 @@
+# ex:ts=8
+# Ports collection makefile for: parrot
+# Date created: Jul 25, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= parrot
+PORTVERSION= 0.2.6
+CATEGORIES= devel
+MASTER_SITES= http://www.comuno.freeserve.co.uk/oss/parrot/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+FILE= HtmlBackend.py PaxoBackend.py PytkBackend.py backend.py \
+ generic.py inrep.py makbacl.py parrot.py pparser.py test.py \
+ tokpos.py util.py
+DOC= INTRO README SPEC
+
+do-install:
+.for f in ${FILE}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${PYTHON_SITELIBDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOC}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>