aboutsummaryrefslogtreecommitdiff
path: root/devel/pccts
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-11-21 20:04:34 +0000
committerSteve Price <steve@FreeBSD.org>1998-11-21 20:04:34 +0000
commit85c60a8725259946430e0846d9c3c535937d1949 (patch)
tree45a10e1153cbd66e587b8ed577936d75c75b9175 /devel/pccts
parent4045bded6952799c8c3404ef8ccd9f3ec5955f37 (diff)
downloadports-85c60a8725259946430e0846d9c3c535937d1949.tar.gz
ports-85c60a8725259946430e0846d9c3c535937d1949.zip
Notes
Diffstat (limited to 'devel/pccts')
-rw-r--r--devel/pccts/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/pccts/Makefile b/devel/pccts/Makefile
index 78416aee37ff..7dbdcc5b3f05 100644
--- a/devel/pccts/Makefile
+++ b/devel/pccts/Makefile
@@ -3,13 +3,13 @@
# Date created: 22 June 1997
# Whom: Andrey Zakhvatov
#
-# $Id$
+# $Id: Makefile,v 1.1.1.1 1997/07/01 07:48:25 tg Exp $
#
DISTNAME= pccts
PKGNAME= pccts-1.33
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.parr-research.com/pub/pccts/1.33/
+MASTER_SITES= http://www.antlr.org/1.33/
MAINTAINER= andy@icc.surw.chel.su
@@ -33,10 +33,6 @@ do-install:
.for file in AParser ASTBase ATokPtr AToken ATokenBuffer ATokenStream DLexerBase PBlackBox PCCTSAST SList antlr ast charbuf charptr config dlgauto dlgdef err int
@ ${INSTALL_DATA} ${WRKSRC}/h/${file}.h ${PREFIX}/include/pccts/${file}.h
.endfor
- @ ${MKDIR} ${PREFIX}/share/doc/pccts
-.for file in BOOK README RIGHTS SERVICES history.ps history.txt
- @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/pccts/${file}
-.endfor
@ ${MKDIR} ${PREFIX}/share/examples/pccts
.for dir in 1 2 3 4 5 6 6/A 6/B 7 8 9 10 11 12 13
@ ${MKDIR} ${PREFIX}/share/examples/pccts/${dir}
@@ -44,5 +40,11 @@ do-install:
.for file in makefile 1/makefile 1/test.g 2/MyLexer.cpp 2/MyLexer.h 2/makefile 2/test.g 3/MyLexer.cpp 3/MyLexer.h 3/makefile 3/mytokens.h 3/test.g 4/makefile 4/mytokens.h 4/test.g 5/input.h 5/makefile 5/test.g 6/file1 6/file2 6/main.cpp 6/makefile 6/makefile2 6/test.g 6/test2.g 7/makefile 7/test.g 8/main.cpp 8/makefile 8/test.g 9/makefile 9/test.g 10/makefile 10/test.g 11/input.h 11/makefile 11/test.g 12/makefile 12/test.g 13/makefile 13/test.g
@ ${INSTALL_DATA} ${WRKSRC}/testcpp/${file} ${PREFIX}/share/examples/pccts/${file}
.endfor
+.if !defined(NOPORTDOCS)
+ @ ${MKDIR} ${PREFIX}/share/doc/pccts
+.for file in BOOK README RIGHTS SERVICES history.ps history.txt
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/pccts/${file}
+.endfor
+.endif
.include <bsd.port.mk>