aboutsummaryrefslogtreecommitdiff
path: root/devel/pcre++
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2003-07-02 08:45:59 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2003-07-02 08:45:59 +0000
commit1c8a109e3a14e6e70809552767110885206ab726 (patch)
tree1b33f0fee68f6be55c4b8e1a35d140ca93ffc043 /devel/pcre++
parent266b49f99f06d731adb7bac5c76d7fb247fab5d2 (diff)
downloadports-1c8a109e3a14e6e70809552767110885206ab726.tar.gz
ports-1c8a109e3a14e6e70809552767110885206ab726.zip
Notes
Diffstat (limited to 'devel/pcre++')
-rw-r--r--devel/pcre++/Makefile13
-rw-r--r--devel/pcre++/distinfo2
-rw-r--r--devel/pcre++/files/patch-doc::Makefile.in13
-rw-r--r--devel/pcre++/files/patch-ltmain.sh15
-rw-r--r--devel/pcre++/pkg-descr2
-rw-r--r--devel/pcre++/pkg-plist56
6 files changed, 72 insertions, 29 deletions
diff --git a/devel/pcre++/Makefile b/devel/pcre++/Makefile
index bc5c9f7735d2..aaf0a27a152e 100644
--- a/devel/pcre++/Makefile
+++ b/devel/pcre++/Makefile
@@ -7,11 +7,11 @@
#
PORTNAME= pcre++
-PORTVERSION= 0.6
+PORTVERSION= 0.9.2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.daemon.de/scip/Apps/pcre++/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ponomarew@oberon.net
COMMENT= A wrapper class around the pcre library
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
@@ -26,16 +26,9 @@ CONFIGURE_ENV= CPPFLAGS="`${PCRE_CONFIG} --cflags`" \
INSTALLS_SHLIB= yes
MAN3= Pcre.3
+PLIST_SUB= VERSION=0.9.2
post-patch:
- @${REINPLACE_CMD} -e 's|-I/usr/local/include||g ; \
- s|-L/usr/local/lib||g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|-O -g|\@CXXFLAGS\@|g' ${WRKSRC}/Makefile.in
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/html/*.* ${DOCSDIR}
-.endif
-
.include <bsd.port.mk>
diff --git a/devel/pcre++/distinfo b/devel/pcre++/distinfo
index c9ad20505a66..4257f30f450e 100644
--- a/devel/pcre++/distinfo
+++ b/devel/pcre++/distinfo
@@ -1 +1 @@
-MD5 (pcre++-0.6.tar.gz) = c27a27fe1dc078950810a4dfe019612b
+MD5 (pcre++-0.9.2.tar.gz) = d7e1f0fba5e4a8fa2bdce42a9356eeba
diff --git a/devel/pcre++/files/patch-doc::Makefile.in b/devel/pcre++/files/patch-doc::Makefile.in
new file mode 100644
index 000000000000..a6a6ef604c85
--- /dev/null
+++ b/devel/pcre++/files/patch-doc::Makefile.in
@@ -0,0 +1,13 @@
+--- doc/Makefile.in.orig Wed Jun 25 11:56:02 2003
++++ doc/Makefile.in Wed Jun 25 11:56:17 2003
+@@ -232,8 +232,8 @@
+
+
+ install-data-local:
+- $(INSTALL) -m 755 -d $(prefix)/doc/libpcre++-$(VERSION)
+- $(INSTALL) -m 644 $(DOC_FILES) $(prefix)/doc/libpcre++-$(VERSION)/
++ $(INSTALL) -m 755 -d $(prefix)/share/doc/libpcre++-$(VERSION)
++ $(INSTALL) -m 644 $(DOC_FILES) $(prefix)/share/doc/libpcre++-$(VERSION)/
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/devel/pcre++/files/patch-ltmain.sh b/devel/pcre++/files/patch-ltmain.sh
new file mode 100644
index 000000000000..8ee142716dc6
--- /dev/null
+++ b/devel/pcre++/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Wed Jun 25 11:24:31 2003
++++ ltmain.sh Wed Jun 25 11:25:27 2003
+@@ -4325,10 +4325,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/pcre++/pkg-descr b/devel/pcre++/pkg-descr
index 20382be194ea..702c0f71728e 100644
--- a/devel/pcre++/pkg-descr
+++ b/devel/pcre++/pkg-descr
@@ -1,2 +1,4 @@
pcre++ is a wrapper class around the pcre library (Perl Compatible Regular
Expressions)
+
+WWW: http://www.daemon.de/pcre++
diff --git a/devel/pcre++/pkg-plist b/devel/pcre++/pkg-plist
index 9ef275f9bd42..113f69ee3c2c 100644
--- a/devel/pcre++/pkg-plist
+++ b/devel/pcre++/pkg-plist
@@ -1,22 +1,42 @@
+bin/pcre++-config
include/pcre++.h
lib/libpcre++.a
lib/libpcre++.so
lib/libpcre++.so.0
-%%PORTDOCS%%share/doc/pcre++/annotated.html
-%%PORTDOCS%%share/doc/pcre++/classPcre-members.html
-%%PORTDOCS%%share/doc/pcre++/classPcre.html
-%%PORTDOCS%%share/doc/pcre++/classPcre_1_1exception-members.html
-%%PORTDOCS%%share/doc/pcre++/classPcre_1_1exception.html
-%%PORTDOCS%%share/doc/pcre++/doxygen.css
-%%PORTDOCS%%share/doc/pcre++/doxygen.gif
-%%PORTDOCS%%share/doc/pcre++/files.html
-%%PORTDOCS%%share/doc/pcre++/functions.html
-%%PORTDOCS%%share/doc/pcre++/globals.html
-%%PORTDOCS%%share/doc/pcre++/index.html
-%%PORTDOCS%%share/doc/pcre++/namespaces.html
-%%PORTDOCS%%share/doc/pcre++/namespacestd.html
-%%PORTDOCS%%share/doc/pcre++/pcre++_8cc-source.html
-%%PORTDOCS%%share/doc/pcre++/pcre++_8cc.html
-%%PORTDOCS%%share/doc/pcre++/pcre++_8h-source.html
-%%PORTDOCS%%share/doc/pcre++/pcre++_8h.html
-%%PORTDOCS%%@dirrm share/doc/pcre++
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/AUTHORS
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/COPYING
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/ChangeLog
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/INSTALL
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/README
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/annotated.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classPcre-members.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classPcre.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classPcre_1_1exception-members.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classPcre_1_1exception.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classpcrepp_1_1Pcre-members.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classpcrepp_1_1Pcre.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classpcrepp_1_1Pcre_1_1exception-members.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/classpcrepp_1_1Pcre_1_1exception.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/config.log
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/doxygen.css
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/doxygen.png
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/files.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/functions.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/get_8cc-source.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/get_8cc.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/globals.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/index.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/namespacepcrepp.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/namespaces.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/namespacestd.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/pcre++_8cc-source.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/pcre++_8cc.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/pcre++_8h-source.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/pcre++_8h.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/replace_8cc-source.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/replace_8cc.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/search_8cc-source.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/search_8cc.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/split_8cc-source.html
+%%PORTDOCS%%share/doc/libpcre++-%%VERSION%%/split_8cc.html
+%%PORTDOCS%%@dirrm share/doc/libpcre++-%%VERSION%%