aboutsummaryrefslogtreecommitdiff
path: root/devel/pdcurses/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-12 09:17:03 +0000
commit36aec2ee4d4789c8cc6ad940264e1a101d8a7977 (patch)
treefadc33ad2f29c6931b7a10a46ca3d20a561a3331 /devel/pdcurses/Makefile
parent59642d1219c0fc9ff42830b664320824c78e3a3f (diff)
Notes
Diffstat (limited to 'devel/pdcurses/Makefile')
-rw-r--r--devel/pdcurses/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/devel/pdcurses/Makefile b/devel/pdcurses/Makefile
index 2db6f99239ef..7468ef83d594 100644
--- a/devel/pdcurses/Makefile
+++ b/devel/pdcurses/Makefile
@@ -21,25 +21,25 @@ USE_XORG= x11 xext sm ice xt xaw
GNU_CONFIGURE= yes
MAKE_JOBS_UNSAFE=yes
-OPTIONS= DEBUG "Enable debugging support" off \
- LATIN1 "Enable support for Latin1 keys" off \
- NEXTAW "Link with NeXtaw" off \
- XAW3D "Link with Xaw3d" off
+OPTONS_DEFINE= DEBUG LATIN1 NEXTAW XAW3D
+LATIN1_DESC= Enable support for Latin1 keys
+NEXTAW_DESC= Link with NeXtaw
+XAW3D_DESC= Link with Xaw3d
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.for opt in DEBUG LATIN1
-. if defined(WITH_${opt})
+. if ${PORT_OPTIONS:M${opt}}
CONFIGURE_ARGS+=--enable-${opt:L}
. endif
.endfor
-.if defined(WITH_NEXTAW)
+.if ${PORT_OPTIONS:MNEXTAW}
LIB_DEPENDS+= neXtaw.${XAWVER}:${PORTSDIR}/x11-toolkits/neXtaw
CONFIGURE_ARGS+=--with-nextaw
.endif
-.if defined(WITH_XAW3D)
+.if ${PORT_OPTIONS:MXAW3D}
LIB_DEPENDS+= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
CONFIGURE_ARGS+=--with-xaw3d
.endif
@@ -52,4 +52,4 @@ post-patch:
post-install:
@cd ${PREFIX}/lib && ${LN} -sf libXCurses.so.2 libXCurses.so
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>