aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Config/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 07:55:47 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-28 07:55:47 +0000
commit93b7ed7f504a49dd67ffe3ac687750a2cf3de9af (patch)
tree8da4bd11526f4a4c8953d4db2c3e091588172722 /devel/pear-Config/Makefile
parent8f2582a5696b97b61eaf3829d827c8b0ba5bc289 (diff)
downloadports-93b7ed7f504a49dd67ffe3ac687750a2cf3de9af.tar.gz
ports-93b7ed7f504a49dd67ffe3ac687750a2cf3de9af.zip
Notes
Diffstat (limited to 'devel/pear-Config/Makefile')
-rw-r--r--devel/pear-Config/Makefile30
1 files changed, 9 insertions, 21 deletions
diff --git a/devel/pear-Config/Makefile b/devel/pear-Config/Makefile
index 95b9f08f9289..446552cdd4ac 100644
--- a/devel/pear-Config/Makefile
+++ b/devel/pear-Config/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Config
PORTVERSION= 1.8
+PORTREVISION= 1
CATEGORIES= devel www pear
MAINTAINER= ports@FreeBSD.org
@@ -17,26 +18,13 @@ RUN_DEPENDS= ${BUILD_DEPENDS} \
${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/Util.php:${PORTSDIR}/devel/pear-XML_Util
-.include <bsd.port.pre.mk>
-.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-
-MANIFEST= Apache.php IniCommented.php PHPArray.php GenericConf.php IniFile.php XML.php
-
-do-install:
- @${CP} -p ${WRKSRC}/Config.php ${PEARDIR}
- @${MKDIR} ${PEARDIR}/Config/Container
- @${CP} -p ${WRKSRC}/Config/Container.php ${PEARDIR}/Config
-.for FILE in ${MANIFEST}
- @${CP} -p ${WRKSRC}/Config/Container/${FILE} ${PEARDIR}/Config/Container
-.endfor
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Config.php
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Config
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/Apache.php ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/IniCommented.php ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/IniFromScratch.php ${DOCSDIR}
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
-.endif
+FILES= Config.php Config/Container.php Config/Container/Apache.php \
+ Config/Container/IniCommented.php Config/Container/PHPArray.php \
+ Config/Container/GenericConf.php Config/Container/IniFile.php \
+ Config/Container/XML.php
+EXAMPLES= Apache.php IniCommented.php IniFromScratch.php
+_EXAMPLESDIR= docs
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>