aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Console_Getopt
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
commit077b4b53b0d0814df73a850dfa8625101c7b8404 (patch)
tree1635d75a5b1ebd11d644c2d01607580c9063de35 /devel/pear-Console_Getopt
parent95cfdcc8b6a9c07b40477662aa446e3bdd99525b (diff)
downloadports-077b4b53b0d0814df73a850dfa8625101c7b8404.tar.gz
ports-077b4b53b0d0814df73a850dfa8625101c7b8404.zip
Notes
Diffstat (limited to 'devel/pear-Console_Getopt')
-rw-r--r--devel/pear-Console_Getopt/Makefile24
-rw-r--r--devel/pear-Console_Getopt/pkg-plist7
2 files changed, 11 insertions, 20 deletions
diff --git a/devel/pear-Console_Getopt/Makefile b/devel/pear-Console_Getopt/Makefile
index cefd3d77e75a..2e75eb8fdd61 100644
--- a/devel/pear-Console_Getopt/Makefile
+++ b/devel/pear-Console_Getopt/Makefile
@@ -7,33 +7,21 @@
PORTNAME= Console_Getopt
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= devel www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR command-line option parser
-BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install \
- ${LOCALBASE}/bin/php:${PORTSDIR}/www/mod_php4
-
-NO_BUILD= yes
+BUILD_DEPENDS= pear:${PORTSDIR}/lang/php4
+RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.endif
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
- @${MV} ${PEARDIR}/Console/Getopt.php ${PEARDIR}/Console/Getopt.php.dist
+ @${MKDIR} ${PEARDIR}/Console
@${CP} -Rp ${WRKSRC}/Console/Getopt.php ${PEARDIR}/Console
- @${CHOWN} -R root:wheel ${PEARDIR}/Console/Getopt.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Console
.include <bsd.port.post.mk>
diff --git a/devel/pear-Console_Getopt/pkg-plist b/devel/pear-Console_Getopt/pkg-plist
index 3887db705822..c6259b2b2c8b 100644
--- a/devel/pear-Console_Getopt/pkg-plist
+++ b/devel/pear-Console_Getopt/pkg-plist
@@ -1,3 +1,6 @@
-@exec mv %D/lib/php/Console/Getopt.php %D/lib/php/Console/Getopt.php.dist
%%PEARDIR%%/Console/Getopt.php
-@unexec mv %D/lib/php/Console/Getopt.php.dist %D/lib/php/Console/Getopt.php || true
+%%PKGREGDIR%%/package.xml
+@dirrm %%PEARDIR%%/Console
+@dirrm %%PKGREGDIR%%
+@unexec rmdir %D/share/pear/.registry 2> /dev/null || true
+@unexec rmdir %D/share/pear/packages 2> /dev/null || true