aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Date/Makefile
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2003-01-30 09:39:28 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2003-01-30 09:39:28 +0000
commit87f13114997ddbf5e1a19b191db082f53fe0a3b7 (patch)
tree00fe618f32d8abf69016dbaddc86d9e34ecb1812 /devel/pear-Date/Makefile
parent193bea503044a6a8ff871516d4105b58b5a5d5ff (diff)
downloadports-87f13114997ddbf5e1a19b191db082f53fe0a3b7.tar.gz
ports-87f13114997ddbf5e1a19b191db082f53fe0a3b7.zip
Notes
Diffstat (limited to 'devel/pear-Date/Makefile')
-rw-r--r--devel/pear-Date/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/pear-Date/Makefile b/devel/pear-Date/Makefile
new file mode 100644
index 000000000000..cf01dd2b7eed
--- /dev/null
+++ b/devel/pear-Date/Makefile
@@ -0,0 +1,34 @@
+# Ports collection makefile for: pear-Date
+# Date created: 28 November 2002
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date
+PORTVERSION= 1.3
+CATEGORIES= devel www
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+
+LPHP_LIB= lib/php
+PEARDIR= ${LOCALBASE}/${LPHP_LIB}
+PLIST_SUB= PEARDIR=${LPHP_LIB}
+MANIFEST= Date Date.php
+
+do-install:
+ @${CP} -Rp ${WRKSRC}/* ${PEARDIR}
+.for FILE in ${MANIFEST}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${FILE}
+.endfor
+
+.include <bsd.port.mk>