aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Date_Holidays
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-06-27 09:11:05 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-06-27 09:11:05 +0000
commitba3efa256a03e728e9d53c72e117d64838d77754 (patch)
tree85abb2471f8a7646bc0f2dc58e1253ffc05775c2 /devel/pear-Date_Holidays
parenta7f75af423bf7f763bc9fd4196286c054243dbc2 (diff)
downloadports-ba3efa256a03e728e9d53c72e117d64838d77754.tar.gz
ports-ba3efa256a03e728e9d53c72e117d64838d77754.zip
Notes
Diffstat (limited to 'devel/pear-Date_Holidays')
-rw-r--r--devel/pear-Date_Holidays/Makefile78
-rw-r--r--devel/pear-Date_Holidays/distinfo3
-rw-r--r--devel/pear-Date_Holidays/pkg-descr7
3 files changed, 88 insertions, 0 deletions
diff --git a/devel/pear-Date_Holidays/Makefile b/devel/pear-Date_Holidays/Makefile
new file mode 100644
index 000000000000..cc537ba47434
--- /dev/null
+++ b/devel/pear-Date_Holidays/Makefile
@@ -0,0 +1,78 @@
+# New ports collection makefile for: pear-Date_Holidays
+# Date created: 2006-06-16
+# Whom: Thomas Abthorpe <thomas@goodking.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Date_Holidays
+PORTVERSION= 0.16.0
+CATEGORIES= devel www pear
+
+MAINTAINER= thomas@goodking.ca
+COMMENT= PEAR driver based class to calculate holidays
+
+BUILD_DEPENDS= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date \
+ ${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer \
+ ${PEARDIR}/Console/Getargs.php:${PORTSDIR}/devel/pear-Console_Getargs
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= Date
+FILES= Holidays.php \
+ Holidays/Driver/Christian.php \
+ Holidays/Driver/Composite.php \
+ Holidays/Driver/Germany.php \
+ Holidays/Driver/Jewish.php \
+ Holidays/Driver/PHPdotNet.php \
+ Holidays/Driver/Sweden.php \
+ Holidays/Driver/UNO.php \
+ Holidays/Driver/USA.php \
+ Holidays/Filter/Germany/BadenWuerttemberg.php \
+ Holidays/Filter/Germany/Bavaria.php \
+ Holidays/Filter/Germany/Berlin.php \
+ Holidays/Filter/Germany/Brandenburg.php \
+ Holidays/Filter/Germany/Bremen.php \
+ Holidays/Filter/Germany/Hamburg.php \
+ Holidays/Filter/Germany/Hesse.php \
+ Holidays/Filter/Germany/LowerSaxony.php \
+ Holidays/Filter/Germany/MecklenburgWesternPomerania.php \
+ Holidays/Filter/Germany/NorthRhineWestphalia.php \
+ Holidays/Filter/Germany/Official.php \
+ Holidays/Filter/Germany/RhinelandPalatinate.php \
+ Holidays/Filter/Germany/Saarland.php \
+ Holidays/Filter/Germany/Saxony.php \
+ Holidays/Filter/Germany/SaxonyAnhalt.php \
+ Holidays/Filter/Germany/SchleswigHolstein.php \
+ Holidays/Filter/Germany/Thuringia.php \
+ Holidays/Filter/Blacklist.php \
+ Holidays/Filter/Composite.php \
+ Holidays/Filter/Whitelist.php \
+ Holidays/Driver.php \
+ Holidays/Filter.php \
+ Holidays/Holiday.php
+EXAMPLES= addingTranslations.php languagefile-with-properties.xml \
+ creating_drivers.php usingCompositeDriver.php \
+ fetchingInstalledDrivers.php usingStandaloneDriver.php
+TESTS= AllTests.php \
+ Date_Holidays_Driver_Christian_TestSuite.php \
+ Date_Holidays_Driver_Germany_TestSuite.php \
+ Date_Holidays_Driver_Jewish_TestSuite.php \
+ Date_Holidays_Driver_PHPdotNet_TestSuite.php \
+ Date_Holidays_Driver_Sweden_TestSuite.php \
+ Date_Holidays_Driver_TestSuite.php \
+ Date_Holidays_Driver_UNO_TestSuite.php \
+ Date_Holidays_Driver_USA_TestSuite.php \
+ Date_Holidays_TestSuite.php \
+ Example.php
+
+LATEST_LINK= pear-Date_Holidays
+OPTIONS= PEAR_CONSOLE_GETARGS "devel/pear-Console_Getargs" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(PEAR_CONSOLE_GETARGS) || defined(WITH_PEAR_CONSOLE_GETARGS)
+BUILD_DEPENDS+=${PEARDIR}/Console/Getargs.php:${PORTSDIR}/devel/pear-Console_Getargs
+.endif
+
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Date_Holidays/distinfo b/devel/pear-Date_Holidays/distinfo
new file mode 100644
index 000000000000..40cbf1ec2b19
--- /dev/null
+++ b/devel/pear-Date_Holidays/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Date_Holidays-0.16.0.tgz) = 6c7ea772a822ab00a1243769238798d0
+SHA256 (PEAR/Date_Holidays-0.16.0.tgz) = db39a19237373ad56d285d6e8e754f75851af2379b5de20eb09667df47813093
+SIZE (PEAR/Date_Holidays-0.16.0.tgz) = 54864
diff --git a/devel/pear-Date_Holidays/pkg-descr b/devel/pear-Date_Holidays/pkg-descr
new file mode 100644
index 000000000000..59bcf383010b
--- /dev/null
+++ b/devel/pear-Date_Holidays/pkg-descr
@@ -0,0 +1,7 @@
+Date_Holidays helps you calculating the dates and titles of holidays
+and other special celebrations. The calculation is driver-based so
+it is easy to add new drivers that calculate a country's holidays.
+The methods of the class can be used to get a holiday's date and
+title in various languages.
+
+WWW: http://pear.php.net/package/Date_Holidays