aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-HTML_Page2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-21 11:34:59 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-21 11:34:59 +0000
commitf11d3635dcb5d80b77c6e1bdbfebb87e2a798bb6 (patch)
treecc297bfea64ec428a1ae7126e952722838347ba0 /devel/pear-HTML_Page2
parentd06fe204dbc74659e52a515f0c0871a6b539a123 (diff)
downloadports-f11d3635dcb5d80b77c6e1bdbfebb87e2a798bb6.tar.gz
ports-f11d3635dcb5d80b77c6e1bdbfebb87e2a798bb6.zip
Notes
Diffstat (limited to 'devel/pear-HTML_Page2')
-rw-r--r--devel/pear-HTML_Page2/Makefile25
-rw-r--r--devel/pear-HTML_Page2/distinfo2
-rw-r--r--devel/pear-HTML_Page2/pkg-descr20
3 files changed, 47 insertions, 0 deletions
diff --git a/devel/pear-HTML_Page2/Makefile b/devel/pear-HTML_Page2/Makefile
new file mode 100644
index 000000000000..aa1cc10e24d4
--- /dev/null
+++ b/devel/pear-HTML_Page2/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: pear-HTML_Page2
+# Date created: 21 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_Page2
+PORTVERSION= 0.5.0
+CATEGORIES= devel www pear
+DISTNAME= ${PORTNAME}-${PORTVERSION}beta
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR base class for XHTML page generation
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML
+FILES= Page2.php Page2/Doctypes.php Page2/Namespaces.php
+EXAMPLES= Page2_NoDoctype.php Page2_Simple.php Page2_Complex.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_Page2/distinfo b/devel/pear-HTML_Page2/distinfo
new file mode 100644
index 000000000000..cea9ed685950
--- /dev/null
+++ b/devel/pear-HTML_Page2/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_Page2-0.5.0beta.tgz) = a10646c904fafb3a39ecaf6920f0d174
+SIZE (PEAR/HTML_Page2-0.5.0beta.tgz) = 15467
diff --git a/devel/pear-HTML_Page2/pkg-descr b/devel/pear-HTML_Page2/pkg-descr
new file mode 100644
index 000000000000..b010dc2aec94
--- /dev/null
+++ b/devel/pear-HTML_Page2/pkg-descr
@@ -0,0 +1,20 @@
+The PEAR::HTML_Page2 package provides a simple interface for generating an
+XHTML compliant page:
+ * supports virtually all HTML doctypes, from HTML 2.0 through XHTML 1.1 and
+ XHTML Basic 1.0 plus preliminary support for XHTML 2.0
+ * namespace support
+ * global language declaration for the document
+ * line ending styles
+ * full META tag support
+ * support for stylesheet declaration in the head section
+ * support for script declaration in the head section
+ * support for linked stylesheets and scripts
+ * full support for header link tags
+ * body can be a string, object with toHtml or toString methods or an array
+ (can be combined)
+
+Ideas for use:
+ * Use to validate the output of a class for XHTML compliance
+ * Quick prototyping using PEAR packages is now a breeze.
+
+WWW: http://pear.php.net/package/HTML_Page2/