aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-HTML_Template_Flexy
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-29 18:25:11 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-29 18:25:11 +0000
commitdf6b6e4fb9fd50ff2eb15f61267635cc2adb3897 (patch)
tree93f07ace71f741f65c214648bcde35ba462edb9e /devel/pear-HTML_Template_Flexy
parent90411b76b1956455519442dc34547d7e926fe118 (diff)
downloadports-df6b6e4fb9fd50ff2eb15f61267635cc2adb3897.tar.gz
ports-df6b6e4fb9fd50ff2eb15f61267635cc2adb3897.zip
Notes
Diffstat (limited to 'devel/pear-HTML_Template_Flexy')
-rw-r--r--devel/pear-HTML_Template_Flexy/Makefile64
-rw-r--r--devel/pear-HTML_Template_Flexy/distinfo4
2 files changed, 34 insertions, 34 deletions
diff --git a/devel/pear-HTML_Template_Flexy/Makefile b/devel/pear-HTML_Template_Flexy/Makefile
index 033a20b64269..245e0938f666 100644
--- a/devel/pear-HTML_Template_Flexy/Makefile
+++ b/devel/pear-HTML_Template_Flexy/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= HTML_Template_Flexy
-PORTVERSION= 1.1.2
+PORTVERSION= 1.2.0
CATEGORIES= devel www pear
MAINTAINER= antonio@php.net
@@ -23,51 +23,51 @@ OPTIONS= PEAR_HTML_JAVASCRIPT "PEAR::HTML_Javascript support" off \
USE_PHP= yes
CATEGORY= HTML/Template
-FILES= Flexy.php Flexy/example.ini Flexy/Element.php \
- Flexy/Element/Xul.php Flexy/Factory.php Flexy/Assign.php \
- Flexy/Plugin.php Flexy/Plugin/Savant.php Flexy/SmartyAPI.php \
- Flexy/Translator.php Flexy/templates/translator.html \
- Flexy/compileAll.php Flexy/Tree.php Flexy/Tokenizer.php \
- Flexy/Token.php Flexy/Token/Tag.php Flexy/Token/EndTag.php \
- Flexy/Token/If.php Flexy/Token/Else.php Flexy/Token/End.php \
- Flexy/Token/Foreach.php Flexy/Token/Var.php Flexy/Token/Method.php \
- Flexy/Token/Processing.php Flexy/Token/Text.php Flexy/Test.php \
- Flexy/Compiler.php Flexy/Compiler/Flexy.php \
+FILES= Flexy.php Flexy/example.ini Flexy/Element.php Flexy/Element/Xul.php \
+ Flexy/Factory.php Flexy/Assign.php Flexy/Plugin.php \
+ Flexy/Plugin/Savant.php Flexy/SmartyAPI.php Flexy/Translator.php \
+ Flexy/templates/translator.html Flexy/compileAll.php Flexy/Tree.php \
+ Flexy/Tokenizer.php Flexy/Token.php Flexy/Token/Tag.php \
+ Flexy/Token/EndTag.php Flexy/Token/If.php Flexy/Token/Else.php \
+ Flexy/Token/End.php Flexy/Token/Foreach.php Flexy/Token/Var.php \
+ Flexy/Token/Method.php Flexy/Token/Processing.php Flexy/Token/Text.php \
+ Flexy/Test.php Flexy/Compiler.php Flexy/Compiler/Flexy.php \
Flexy/Compiler/Flexy/Tag.php Flexy/Compiler/Flexy/Flexy.php \
Flexy/Compiler/Standard.php Flexy/Compiler/Standard/Tag.php \
Flexy/Compiler/Standard/Flexy.php Flexy/Compiler/Regex.php \
Flexy/Compiler/Regex/BodyOnly.php Flexy/Compiler/Regex/Php.php \
- Flexy/Compiler/Regex/RtfSimpleTags.php \
- Flexy/Compiler/Regex/SimpleTags.php Flexy/Compiler/Regex/Mail.php \
- Flexy/Compiler/Regex/Xml.php Flexy/Compiler/Regex/Math.php \
- Flexy/Compiler/SmartyConvertor.php
-TESTS= test.php treeTest.php templates/blocks.html templates/conditions.html \
+ Flexy/Compiler/Regex/RtfSimpleTags.php Flexy/Compiler/Regex/SimpleTags.php \
+ Flexy/Compiler/Regex/Mail.php Flexy/Compiler/Regex/Xml.php \
+ Flexy/Compiler/Regex/Math.php Flexy/Compiler/SmartyConvertor.php
+TESTS= testsuite.php test_blocks.html.phpt test_bug_2959.html.phpt \
+ test_conditions.html.phpt test_error_foreach.html.phpt \
+ test_flexy_tojavascript.html.phpt test_forms.html.phpt \
+ test_function.html.phpt test_globals.html.phpt test_image_view.html.phpt \
+ test_include.html.phpt test_javascript.html.phpt test_looping.html.phpt \
+ test_methods.html.phpt test_namespaces.html.phpt \
+ test_plugin_modifiers.html.phpt test_raw_php.html.phpt \
+ test_raw_text.html.phpt test_style.html.phpt test_variables.html.phpt \
+ templates/blocks.html templates/bug_2959.html templates/conditions.html \
templates/error_foreach.html templates/flexy_tojavascript.html \
templates/forms.html templates/function.html templates/globals.html \
- templates/image_view.html templates/includes.html \
- templates/javascript.html templates/looping.html templates/methods.html \
- templates/namespaces.html templates/raw_php.html \
- templates/raw_text.html templates/variables.html smarty/smartytest.php
+ templates/image_view.html templates/include.html templates/javascript.html \
+ templates/looping.html templates/methods.html templates/namespaces.html \
+ templates/plugin_modifiers.html templates/raw_php.html \
+ templates/raw_text.html templates/style.html templates/variables.html \
+ smarty/smartytest.php
-.include <bsd.port.pre.mk>
-
-PHP_VERS= ${PHP_VERSION:S/.//g}
-
-.if defined(PHP_VERS) && ${PHP_VERS} < 430
-IGNORE= "You need PHP 4.3.0 or later to install PEAR::HTML_Template_Flexy"
-.endif
-
-.if !defined(WITH_PEAR_HTML_JAVASCRIPT)
-BUILD_DEPENDS+= ${PEARDIR}/HTML/Javascript.php:${PORTSDIR}/devel/pear-HTML_Javascript
+.if defined(WITH_PEAR_HTML_JAVASCRIPT)
+RUN_DEPENDS+= ${PEARDIR}/HTML/Javascript.php:${PORTSDIR}/devel/pear-HTML_Javascript
.endif
.if defined(WITH_PEAR_FILE_GETTEXT)
-BUILD_DEPENDS+= ${PEARDIR}/File/Gettext.php:${PORTSDIR}/sysutils/pear-File_Gettext
+RUN_DEPENDS+= ${PEARDIR}/File/Gettext.php:${PORTSDIR}/sysutils/pear-File_Gettext
.endif
.if defined(WITH_PEAR_TRANSLATION2)
-BUILD_DEPENDS+= ${PEARDIR}/Translation2.php:${PORTSDIR}/sysutils/pear-Translation2
+RUN_DEPENDS+= ${PEARDIR}/Translation2.php:${PORTSDIR}/sysutils/pear-Translation2
.endif
+.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_Template_Flexy/distinfo b/devel/pear-HTML_Template_Flexy/distinfo
index 27e744a64ad3..3eaffb70e5d5 100644
--- a/devel/pear-HTML_Template_Flexy/distinfo
+++ b/devel/pear-HTML_Template_Flexy/distinfo
@@ -1,2 +1,2 @@
-MD5 (PEAR/HTML_Template_Flexy-1.1.2.tgz) = 581ad6c8edb898b11f5da172728377f4
-SIZE (PEAR/HTML_Template_Flexy-1.1.2.tgz) = 104884
+MD5 (PEAR/HTML_Template_Flexy-1.2.0.tgz) = a5c9fa1852055502b9dccb676747c094
+SIZE (PEAR/HTML_Template_Flexy-1.2.0.tgz) = 117845