aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PHPUnit2
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-10-18 15:13:18 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-10-18 15:13:18 +0000
commit8cc266361765d4e51763b0299597b547d92a0851 (patch)
tree098fdabfeb8309dfcf2be80b5c2ed66c272c4186 /devel/pear-PHPUnit2
parentfa2b68c8c25ed17c112e5a888336dd385e6cee77 (diff)
downloadports-8cc266361765d4e51763b0299597b547d92a0851.tar.gz
ports-8cc266361765d4e51763b0299597b547d92a0851.zip
Notes
Diffstat (limited to 'devel/pear-PHPUnit2')
-rw-r--r--devel/pear-PHPUnit2/Makefile68
-rw-r--r--devel/pear-PHPUnit2/distinfo2
-rw-r--r--devel/pear-PHPUnit2/pkg-descr5
3 files changed, 75 insertions, 0 deletions
diff --git a/devel/pear-PHPUnit2/Makefile b/devel/pear-PHPUnit2/Makefile
new file mode 100644
index 000000000000..975685fe104a
--- /dev/null
+++ b/devel/pear-PHPUnit2/Makefile
@@ -0,0 +1,68 @@
+# Ports collection makefile for: pear-PHPUnit2
+# Date created: 09 September 2004
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHPUnit2
+PORTVERSION= 2.0.2
+CATEGORIES= devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= Regression testing framework for unit tests
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.if !defined(WITHOUT_BENCHMARK)
+BUILD_DEPENDS+= ${PEARDIR}/Benchmark/Timer.php:${PORTSDIR}/benchmarks/pear-Benchmark
+.endif
+
+NO_PACKAGE= Conflicting dependences between PHP4 and PHP5
+
+USE_PHP= yes
+DEFAULT_PHP_VER=5
+BROKEN_WITH_PHP=4
+
+USE_REINPLACE= yes
+
+CATEGORY= PHPUnit2
+FILES= Extensions/RepeatedTest.php Extensions/TestDecorator.php \
+ Extensions/TestSetup.php Extensions/ExceptionTestCase.php \
+ Framework/ComparisonFailure.php Framework/IncompleteTest.php \
+ Framework/IncompleteTestError.php Framework/Test.php \
+ Framework/TestCase.php Framework/TestFailure.php \
+ Framework/TestListener.php Framework/TestResult.php \
+ Framework/TestSuite.php Framework/Warning.php Framework/Assert.php \
+ Framework/AssertionFailedError.php Runner/TestCollector.php \
+ Runner/TestRunListener.php Runner/TestSuiteLoader.php \
+ Runner/Version.php Runner/BaseTestRunner.php \
+ Runner/StandardTestSuiteLoader.php Tests/Framework/AssertTest.php \
+ Tests/Framework/SuiteTest.php Tests/Framework/TestCaseTest.php \
+ Tests/Framework/TestImplementorTest.php \
+ Tests/Framework/TestListenerTest.php Tests/Framework/AllTests.php \
+ Tests/Framework/ComparisonFailureTest.php \
+ Tests/Extensions/ExtensionTest.php \
+ Tests/Extensions/RepeatedTestTest.php Tests/Extensions/AllTests.php \
+ Tests/Extensions/ExceptionTestCaseTest.php Tests/Runner/AllTests.php \
+ Tests/Runner/BaseTestRunnerTest.php Tests/DoubleTestCase.php \
+ Tests/Error.php Tests/Failure.php Tests/InheritedTestCase.php \
+ Tests/MockRunner.php Tests/NoArgTestCaseTest.php Tests/NonStatic.php \
+ Tests/NoTestCaseClass.php Tests/NoTestCases.php \
+ Tests/NotPublicTestCase.php Tests/NotVoidTestCase.php \
+ Tests/OneTestCase.php Tests/OverrideTestCase.php Tests/SetupFailure.php \
+ Tests/Success.php Tests/TearDownFailure.php \
+ Tests/ThrowExceptionTestCase.php Tests/ThrowNoExceptionTestCase.php \
+ Tests/TornDown.php Tests/TornDown2.php Tests/TornDown3.php \
+ Tests/TornDown4.php Tests/TornDown5.php Tests/WasRun.php \
+ Tests/AllTests.php TextUI/TestRunner.php TextUI/ResultPrinter.php \
+ Util/Printer.php Util/Filter.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|@version@|${PORTVERSION}|" ${WRKSRC}/Runner/Version.php
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PHPUnit2/distinfo b/devel/pear-PHPUnit2/distinfo
new file mode 100644
index 000000000000..cabdbee4bcf0
--- /dev/null
+++ b/devel/pear-PHPUnit2/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/PHPUnit2-2.0.2.tgz) = 17755636fb94908eac364f643b4479ab
+SIZE (PEAR/PHPUnit2-2.0.2.tgz) = 22187
diff --git a/devel/pear-PHPUnit2/pkg-descr b/devel/pear-PHPUnit2/pkg-descr
new file mode 100644
index 000000000000..2cd6120a72d6
--- /dev/null
+++ b/devel/pear-PHPUnit2/pkg-descr
@@ -0,0 +1,5 @@
+PHPUnit is a regression testing framework used by the developer
+who implements unit tests in PHP. It is based upon JUnit, which
+can be found at http://www.junit.org/.
+
+WWW: http://pear.php.net/package/PHPUnit2/