aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PHPUnit3
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-10 11:16:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-10 11:16:29 +0000
commitba2750c21e4244bd1db04243a74cd9ff0dd8df93 (patch)
tree9ec27cc7fa072069e4affac3f3ec32a99aac2bcb /devel/pear-PHPUnit3
parent6fe12ee091bac9fefdba48fdf9351cf455b40904 (diff)
downloadports-ba2750c21e4244bd1db04243a74cd9ff0dd8df93.tar.gz
ports-ba2750c21e4244bd1db04243a74cd9ff0dd8df93.zip
Notes
Diffstat (limited to 'devel/pear-PHPUnit3')
-rw-r--r--devel/pear-PHPUnit3/Makefile309
-rw-r--r--devel/pear-PHPUnit3/distinfo6
-rw-r--r--devel/pear-PHPUnit3/pkg-descr2
3 files changed, 245 insertions, 72 deletions
diff --git a/devel/pear-PHPUnit3/Makefile b/devel/pear-PHPUnit3/Makefile
index b0ce2817d82c..a777a7380449 100644
--- a/devel/pear-PHPUnit3/Makefile
+++ b/devel/pear-PHPUnit3/Makefile
@@ -1,91 +1,260 @@
-# Ports collection makefile for: pear-PHPUnit2
-# Date created: 09 September 2004
-# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+# Ports collection makefile for: pear-PHPUnit3
+# Date created: 17 May 2007
+# Whom: Gerrit Beine (<gerrit.beine@gmx.de>)
#
# $FreeBSD$
#
-PORTNAME= PHPUnit2
-PORTVERSION= 2.3.4
+PORTNAME= PHPUnit
+PORTVERSION= 3.0.6
CATEGORIES= devel www pear
+MASTER_SITES= http://pear.phpunit.de/get/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gerrit.beine@gmx.de
COMMENT= PEAR regression testing framework for unit tests
-BUILD_DEPENDS= ${PEARDIR}/Benchmark/Timer.php:${PORTSDIR}/benchmarks/pear-Benchmark
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${BUILD_DEPENDS}
+CONFLICTS= *PHPUnit*
+
LATEST_LINK= pear-${PORTNAME}
-OPTIONS= PEAR_LOG "PEAR::Log support" off
+OPTIONS= PEAR_LOG "PEAR::Log support" off \
+ JSON "Enable JSON support" off \
-USE_PHP= dom pcre
+CHANNEL= pear.phpunit.de
DEFAULT_PHP_VER=5
IGNORE_WITH_PHP=4
-CATEGORY= PHPUnit2
-FILES= Extensions/ExceptionTestCase.php \
- Extensions/PerformanceTestCase.php Extensions/RepeatedTest.php \
- Extensions/TestDecorator.php Extensions/TestSetup.php \
- Framework/Assert.php Framework/AssertionFailedError.php \
- Framework/Error.php Framework/ComparisonFailure.php \
- Framework/IncompleteTest.php Framework/IncompleteTestError.php \
- Framework/Test.php Framework/TestCase.php \
- Framework/TestFailure.php Framework/TestListener.php \
- Framework/TestResult.php Framework/TestSuite.php \
- Framework/Warning.php Runner/BaseTestRunner.php \
- Runner/IncludePathTestCollector.php \
- Runner/StandardTestSuiteLoader.php Runner/TestCollector.php \
- Runner/TestSuiteLoader.php Runner/Version.php \
- TextUI/ResultPrinter.php TextUI/TestRunner.php \
- Util/CodeCoverage/Renderer/HTML.php \
- Util/CodeCoverage/Renderer/Text.php \
- Util/CodeCoverage/Renderer.php Util/Log/PEAR.php \
- Util/Log/XML.php Util/TestDox/ResultPrinter/HTML.php \
- Util/TestDox/ResultPrinter/Text.php \
- Util/TestDox/NamePrettifier.php Util/TestDox/ResultPrinter.php \
- Util/ErrorHandler.php Util/Fileloader.php Util/Filter.php \
- Util/Printer.php Util/Skeleton.php
-EXAMPLES= BankAccount/BankAccount.php BankAccount/BankAccountTest.php \
- Money/IMoney.php Money/Money.php Money/MoneyBag.php \
- Money/MoneyTest.php
-TESTS= Framework/AllTests.php Framework/AssertTest.php \
- Framework/ComparisonFailureTest.php Framework/SuiteTest.php \
- Framework/TestCaseTest.php Framework/TestImplementorTest.php \
- Framework/TestListenerTest.php Extensions/AllTests.php \
+USE_PHP= dom spl
+
+FILES= PHPUnit2/Extensions/ExceptionTestCase.php \
+ PHPUnit2/Extensions/PerformanceTestCase.php \
+ PHPUnit2/Extensions/RepeatedTest.php \
+ PHPUnit2/Extensions/TestDecorator.php \
+ PHPUnit2/Extensions/TestSetup.php \
+ PHPUnit2/Framework/Assert.php \
+ PHPUnit2/Framework/AssertionFailedError.php \
+ PHPUnit2/Framework/ComparisonFailure.php \
+ PHPUnit2/Framework/Error.php \
+ PHPUnit2/Framework/IncompleteTest.php \
+ PHPUnit2/Framework/IncompleteTestError.php \
+ PHPUnit2/Framework/Test.php \
+ PHPUnit2/Framework/TestCase.php \
+ PHPUnit2/Framework/TestListener.php \
+ PHPUnit2/Framework/TestResult.php \
+ PHPUnit2/Framework/TestSuite.php \
+ PHPUnit2/Framework/Warning.php \
+ PHPUnit2/Runner/BaseTestRunner.php \
+ PHPUnit2/Runner/IncludePathTestCollector.php \
+ PHPUnit2/Runner/StandardTestSuiteLoader.php \
+ PHPUnit2/Runner/TestCollector.php \
+ PHPUnit2/Runner/TestSuiteLoader.php \
+ PHPUnit2/Runner/Version.php \
+ PHPUnit2/TextUI/ResultPrinter.php \
+ PHPUnit2/TextUI/TestRunner.php \
+ PHPUnit2/Util/Log/PEAR.php \
+ PHPUnit2/Util/Log/XML.php \
+ PHPUnit2/Util/Filter.php \
+ PHPUnit/Extensions/ExceptionTestCase.php \
+ PHPUnit/Extensions/OutputTestCase.php \
+ PHPUnit/Extensions/PerformanceTestCase.php \
+ PHPUnit/Extensions/RepeatedTest.php \
+ PHPUnit/Extensions/SeleniumTestCase.php \
+ PHPUnit/Extensions/TestDecorator.php \
+ PHPUnit/Extensions/TestSetup.php \
+ PHPUnit/Framework/ComparisonFailure/Array.php \
+ PHPUnit/Framework/ComparisonFailure/Object.php \
+ PHPUnit/Framework/ComparisonFailure/Scalar.php \
+ PHPUnit/Framework/ComparisonFailure/String.php \
+ PHPUnit/Framework/ComparisonFailure/Type.php \
+ PHPUnit/Framework/Constraint/And.php \
+ PHPUnit/Framework/Constraint/ArrayHasKey.php \
+ PHPUnit/Framework/Constraint/FileExists.php \
+ PHPUnit/Framework/Constraint/GreaterThan.php \
+ PHPUnit/Framework/Constraint/IsAnything.php \
+ PHPUnit/Framework/Constraint/IsEqual.php \
+ PHPUnit/Framework/Constraint/IsIdentical.php \
+ PHPUnit/Framework/Constraint/IsInstanceOf.php \
+ PHPUnit/Framework/Constraint/IsType.php \
+ PHPUnit/Framework/Constraint/LessThan.php \
+ PHPUnit/Framework/Constraint/Not.php \
+ PHPUnit/Framework/Constraint/ObjectHasAttribute.php \
+ PHPUnit/Framework/Constraint/Or.php \
+ PHPUnit/Framework/Constraint/PCREMatch.php \
+ PHPUnit/Framework/Constraint/StringContains.php \
+ PHPUnit/Framework/Constraint/TraversableContains.php \
+ PHPUnit/Framework/Constraint/Xor.php \
+ PHPUnit/Framework/MockObject/Builder/Identity.php \
+ PHPUnit/Framework/MockObject/Builder/InvocationMocker.php \
+ PHPUnit/Framework/MockObject/Builder/Match.php \
+ PHPUnit/Framework/MockObject/Builder/MethodNameMatch.php \
+ PHPUnit/Framework/MockObject/Builder/Namespace.php \
+ PHPUnit/Framework/MockObject/Builder/ParametersMatch.php \
+ PHPUnit/Framework/MockObject/Builder/Stub.php \
+ PHPUnit/Framework/MockObject/Matcher/AnyInvokedCount.php \
+ PHPUnit/Framework/MockObject/Matcher/AnyParameters.php \
+ PHPUnit/Framework/MockObject/Matcher/Invocation.php \
+ PHPUnit/Framework/MockObject/Matcher/InvokedAtIndex.php \
+ PHPUnit/Framework/MockObject/Matcher/InvokedAtLeastOnce.php \
+ PHPUnit/Framework/MockObject/Matcher/InvokedCount.php \
+ PHPUnit/Framework/MockObject/Matcher/InvokedRecorder.php \
+ PHPUnit/Framework/MockObject/Matcher/MethodName.php \
+ PHPUnit/Framework/MockObject/Matcher/Parameters.php \
+ PHPUnit/Framework/MockObject/Matcher/StatelessInvocation.php \
+ PHPUnit/Framework/MockObject/Stub/ConsecutiveCalls.php \
+ PHPUnit/Framework/MockObject/Stub/MatcherCollection.php \
+ PHPUnit/Framework/MockObject/Stub/Return.php \
+ PHPUnit/Framework/MockObject/Invocation.php \
+ PHPUnit/Framework/MockObject/InvocationMocker.php \
+ PHPUnit/Framework/MockObject/Invokable.php \
+ PHPUnit/Framework/MockObject/Matcher.php \
+ PHPUnit/Framework/MockObject/Mock.php \
+ PHPUnit/Framework/MockObject/MockObject.php \
+ PHPUnit/Framework/MockObject/Stub.php \
+ PHPUnit/Framework/MockObject/Verifiable.php \
+ PHPUnit/Framework/Assert.php \
+ PHPUnit/Framework/AssertionFailedError.php \
+ PHPUnit/Framework/ComparisonFailure.php \
+ PHPUnit/Framework/Constraint.php \
+ PHPUnit/Framework/Error.php \
+ PHPUnit/Framework/ExpectationFailedException.php \
+ PHPUnit/Framework/IncompleteTest.php \
+ PHPUnit/Framework/IncompleteTestError.php \
+ PHPUnit/Framework/SelfDescribing.php \
+ PHPUnit/Framework/SkippedTest.php \
+ PHPUnit/Framework/SkippedTestError.php \
+ PHPUnit/Framework/Test.php \
+ PHPUnit/Framework/TestCase.php \
+ PHPUnit/Framework/TestFailure.php \
+ PHPUnit/Framework/TestListener.php \
+ PHPUnit/Framework/TestResult.php \
+ PHPUnit/Framework/TestSuite.php \
+ PHPUnit/Framework/Warning.php \
+ PHPUnit/Runner/BaseTestRunner.php \
+ PHPUnit/Runner/IncludePathTestCollector.php \
+ PHPUnit/Runner/StandardTestSuiteLoader.php \
+ PHPUnit/Runner/TestCollector.php \
+ PHPUnit/Runner/TestSuiteLoader.php \
+ PHPUnit/Runner/Version.php \
+ PHPUnit/TextUI/Command.php \
+ PHPUnit/TextUI/ResultPrinter.php \
+ PHPUnit/TextUI/TestRunner.php \
+ PHPUnit/Util/Log/GraphViz.php \
+ PHPUnit/Util/Log/JSON.php \
+ PHPUnit/Util/Log/PEAR.php \
+ PHPUnit/Util/Log/TAP.php \
+ PHPUnit/Util/Log/XML.php \
+ PHPUnit/Util/Report/Coverage/Node/Directory.php \
+ PHPUnit/Util/Report/Coverage/Node/File.php \
+ PHPUnit/Util/Report/Coverage/Factory.php \
+ PHPUnit/Util/Report/Coverage/Node.php \
+ PHPUnit/Util/Report/Template/butter.png \
+ PHPUnit/Util/Report/Template/chameleon.png \
+ PHPUnit/Util/Report/Template/coverage_directory.html \
+ PHPUnit/Util/Report/Template/coverage_file.html \
+ PHPUnit/Util/Report/Template/coverage_item.html \
+ PHPUnit/Util/Report/Template/coverage_item_details.html \
+ PHPUnit/Util/Report/Template/coverage_item_details_header.html \
+ PHPUnit/Util/Report/Template/glass.png \
+ PHPUnit/Util/Report/Template/scarlet_red.png \
+ PHPUnit/Util/Report/Template/snow.png \
+ PHPUnit/Util/Report/Template/style.css \
+ PHPUnit/Util/Report/Template/testsuite.html \
+ PHPUnit/Util/Report/Template/testsuite_item.html \
+ PHPUnit/Util/Report/Test/Node/Test.php \
+ PHPUnit/Util/Report/Test/Node/TestSuite.php \
+ PHPUnit/Util/Report/Test/Factory.php \
+ PHPUnit/Util/Report/Test/Node.php \
+ PHPUnit/Util/Report/GraphViz.php \
+ PHPUnit/Util/Skeleton/IncompleteTestMethod.tpl \
+ PHPUnit/Util/Skeleton/TestClass.tpl \
+ PHPUnit/Util/Skeleton/TestMethod.tpl \
+ PHPUnit/Util/TestDox/ResultPrinter/HTML.php \
+ PHPUnit/Util/TestDox/ResultPrinter/Text.php \
+ PHPUnit/Util/TestDox/NamePrettifier.php \
+ PHPUnit/Util/TestDox/ResultPrinter.php \
+ PHPUnit/Util/Array.php \
+ PHPUnit/Util/ErrorHandler.php \
+ PHPUnit/Util/Fileloader.php \
+ PHPUnit/Util/Filesystem.php \
+ PHPUnit/Util/Filter.php \
+ PHPUnit/Util/FilterIterator.php \
+ PHPUnit/Util/Getopt.php \
+ PHPUnit/Util/Printer.php \
+ PHPUnit/Util/Report.php \
+ PHPUnit/Util/Skeleton.php \
+ PHPUnit/Util/Template.php \
+ PHPUnit/Util/Test.php \
+ PHPUnit/Util/Timer.php \
+ PHPUnit/Util/Type.php \
+ PHPUnit/Framework.php
+EXAMPLES= BankAccount/BankAccount.php \
+ BankAccount/BankAccountTest.php \
+ Money/IMoney.php \
+ Money/Money.php \
+ Money/MoneyBag.php \
+ Money/MoneyTest.php \
+ FailureTest.php
+TESTS= Extensions/AllTests.php \
Extensions/ExceptionTestCaseTest.php \
Extensions/ExtensionTest.php \
+ Extensions/OutputTestCaseTest.php \
Extensions/PerformanceTestCaseTest.php \
- Extensions/RepeatedTestTest.php Runner/AllTests.php \
- Runner/BaseTestRunnerTest.php Util/TestDox/AllTests.php \
- Util/TestDox/NamePrettifierTest.php AllTests.php \
- DoubleTestCase.php Error.php Failure.php InheritedTestCase.php \
- MockRunner.php NoArgTestCaseTest.php NonStatic.php \
- NoTestCaseClass.php NoTestCases.php NotPublicTestCase.php \
- NotVoidTestCase.php OneTestCase.php OverrideTestCase.php \
- SetupFailure.php Sleep.php Success.php TearDownFailure.php \
- TestIterator.php ThrowExceptionTestCase.php \
- ThrowNoExceptionTestCase.php TornDown.php TornDown2.php \
- TornDown3.php TornDown4.php TornDown5.php TornDown6.php \
- WasRun.php Util/AllTests.php
+ Extensions/RepeatedTestTest.php \
+ Extensions/SeleniumTestCaseTest.php \
+ Framework/AllTests.php \
+ Framework/AssertTest.php \
+ Framework/ComparisonFailureTest.php \
+ Framework/ConstraintTest.php \
+ Framework/MockObjectTest.php \
+ Framework/SuiteTest.php \
+ Framework/TestCaseTest.php \
+ Framework/TestImplementorTest.php \
+ Framework/TestListenerTest.php \
+ Runner/AllTests.php \
+ Runner/BaseTestRunnerTest.php \
+ Util/TestDox/AllTests.php \
+ Util/TestDox/NamePrettifierTest.php \
+ Util/AllTests.php \
+ _files/AnInterface.php \
+ _files/ClassWithNonPublicAttributes.php \
+ _files/DoubleTestCase.php \
+ _files/Error.php \
+ _files/Failure.php \
+ _files/InheritedTestCase.php \
+ _files/MockRunner.php \
+ _files/NoArgTestCaseTest.php \
+ _files/NoTestCaseClass.php \
+ _files/NoTestCases.php \
+ _files/NonStatic.php \
+ _files/NotPublicTestCase.php \
+ _files/NotVoidTestCase.php \
+ _files/OneTestCase.php \
+ _files/OutputTestCase.php \
+ _files/OverrideTestCase.php \
+ _files/SampleClass.php \
+ _files/SetupFailure.php \
+ _files/Sleep.php \
+ _files/Struct.php \
+ _files/Success.php \
+ _files/TearDownFailure.php \
+ _files/TestIterator.php \
+ _files/ThrowExceptionTestCase.php \
+ _files/ThrowNoExceptionTestCase.php \
+ _files/TornDown.php \
+ _files/TornDown2.php \
+ _files/TornDown3.php \
+ _files/TornDown4.php \
+ _files/TornDown5.php \
+ _files/TornDown6.php \
+ _files/WasRun.php \
+ AllTests.php \
+ TestConfiguration.php.dist
SCRIPTFILES= phpunit
-_EXAMPLESDIR= Samples
-_TESTSDIR= Tests
-
-post-extract:
- @${CP} ${WRKSRC}/${_TESTSDIR}/AllTests.php ${WRKSRC}/${_TESTSDIR}/Util
-
-post-patch:
-. for FILE in ${FILES}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/${FILE}
-. endfor
-. for FILE in ${EXAMPLES}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/${_EXAMPLESDIR}/${FILE}
-. endfor
-. for FILE in ${TESTS}
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/${_TESTSDIR}/${FILE}
-. endfor
- @${REINPLACE_CMD} -e "s|@package_version@|${PORTVERSION}|g" ${WRKSRC}/pear-${SCRIPTFILES}
+_EXAMPLESDIR= PHPUnit/Samples
+_TESTSDIR= PHPUnit/Tests
.include <bsd.port.pre.mk>
@@ -93,5 +262,9 @@ post-patch:
RUN_DEPENDS+= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
.endif
+.if defined(WITH_JSON)
+USE_PHP+= json
+.endif
+
.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.post.mk>
diff --git a/devel/pear-PHPUnit3/distinfo b/devel/pear-PHPUnit3/distinfo
index 59b940f434e9..526eb1cfd0fa 100644
--- a/devel/pear-PHPUnit3/distinfo
+++ b/devel/pear-PHPUnit3/distinfo
@@ -1,3 +1,3 @@
-MD5 (PEAR/PHPUnit2-2.3.4.tgz) = 19adb85d809f007a040bb6a727306411
-SHA256 (PEAR/PHPUnit2-2.3.4.tgz) = 410857ced2839b2a8e6904587156259ad52a5699d78bc65f779090bd53361720
-SIZE (PEAR/PHPUnit2-2.3.4.tgz) = 43190
+MD5 (PEAR/PHPUnit-3.0.6.tgz) = cf8365f8b8e86412e6c1590d6d4e872f
+SHA256 (PEAR/PHPUnit-3.0.6.tgz) = 5f2a4092dcb0606a5eaaaaffdd2ac6e05b392a76f5627ee8e52900db877706a3
+SIZE (PEAR/PHPUnit-3.0.6.tgz) = 100140
diff --git a/devel/pear-PHPUnit3/pkg-descr b/devel/pear-PHPUnit3/pkg-descr
index 2cd6120a72d6..9f3f58e72d9e 100644
--- a/devel/pear-PHPUnit3/pkg-descr
+++ b/devel/pear-PHPUnit3/pkg-descr
@@ -2,4 +2,4 @@ PHPUnit is a regression testing framework used by the developer
who implements unit tests in PHP. It is based upon JUnit, which
can be found at http://www.junit.org/.
-WWW: http://pear.php.net/package/PHPUnit2/
+WWW: http://www.phpunit.de/