aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-PHP_Beautifier
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-01-19 10:31:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-01-19 10:31:05 +0000
commit7b2c7700405826a382f2d24ecc1bb12a32a878a8 (patch)
treee1341596eb3b379851f59f8d9bc3e0ab50bdca4f /devel/pear-PHP_Beautifier
parent8590d330ca1f87944a5a1439c38bc478e9cb3c09 (diff)
Notes
Diffstat (limited to 'devel/pear-PHP_Beautifier')
-rw-r--r--devel/pear-PHP_Beautifier/Makefile58
-rw-r--r--devel/pear-PHP_Beautifier/distinfo2
-rw-r--r--devel/pear-PHP_Beautifier/pkg-descr6
3 files changed, 66 insertions, 0 deletions
diff --git a/devel/pear-PHP_Beautifier/Makefile b/devel/pear-PHP_Beautifier/Makefile
new file mode 100644
index 000000000000..2bdea7cc528d
--- /dev/null
+++ b/devel/pear-PHP_Beautifier/Makefile
@@ -0,0 +1,58 @@
+# Ports collection makefile for: pear-PHP_Beautifier
+# Date created: 13 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= PHP_Beautifier
+PORTVERSION= 0.1.0
+CATEGORIES= devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR beautifier for PHP
+
+BUILD_DEPENDS= ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PHP= yes
+USE_REINPLACE= yes
+DEFAULT_PHP_VER=5
+
+CATEGORY= PHP
+FILES= Beautifier.php Beautifier/Filter.php \
+ Beautifier/Decorator.php Beautifier/Batch.php \
+ Beautifier/Common.php Beautifier/Exception.php \
+ Beautifier/StreamWrapper.php Beautifier/Tokenizer.php \
+ Beautifier/Filter/ArrayNested.filter.php \
+ Beautifier/Filter/Default.filter.php \
+ Beautifier/Filter/ListClassFunction.filter.php \
+ Beautifier/Filter/Pear.filter.php \
+ Beautifier/Filter/IndentStyles.filter.php \
+ Beautifier/Batch/Output.php \
+ Beautifier/Batch/Output/Directory.php \
+ Beautifier/Batch/Output/DirectoryBz2.php \
+ Beautifier/Batch/Output/DirectoryGz.php \
+ Beautifier/Batch/Output/DirectoryTar.php \
+ Beautifier/Batch/Output/Files.php \
+ Beautifier/Batch/Output/FilesBz2.php \
+ Beautifier/Batch/Output/FilesGz.php \
+ Beautifier/Batch/Output/FilesTar.php \
+ Beautifier/StreamWrapper/Tarz.php
+EXAMPLES= run_me.php example_main.php example_pear.php example_array.php \
+ example_comments.php example_html.php
+TESTS= Beautifier.phpt Beautifier_Common.phpt Beautifier_Bugs.phpt \
+ Beautifier_StreamWrapper.phpt
+DATA= licenses/apache.txt licenses/bsd.txt licenses/lgpl.txt \
+ licenses/php.txt
+_DATADIR= .
+SCRIPTFILES= php_beautifier
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${SED} 's|"@php_bin@"|@php_bin@|g' \
+ ${WRKSRC}/scripts/${SCRIPTFILES} > ${WRKSRC}/pear-${SCRIPTFILES}
+
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-PHP_Beautifier/distinfo b/devel/pear-PHP_Beautifier/distinfo
new file mode 100644
index 000000000000..a391a7715e53
--- /dev/null
+++ b/devel/pear-PHP_Beautifier/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/PHP_Beautifier-0.1.0.tgz) = f4d51a6b964cc31bf908b8b8fc072246
+SIZE (PEAR/PHP_Beautifier-0.1.0.tgz) = 38047
diff --git a/devel/pear-PHP_Beautifier/pkg-descr b/devel/pear-PHP_Beautifier/pkg-descr
new file mode 100644
index 000000000000..7191b424940b
--- /dev/null
+++ b/devel/pear-PHP_Beautifier/pkg-descr
@@ -0,0 +1,6 @@
+This program reformat and beautify PHP source code files automatically.
+
+The program is Open Source and distributed under the terms of PHP Licence. It
+is written in PHP 5 and has a command line tool.
+
+WWW: http://pear.php.net/package/PHP_Beautifier/