aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-System_Command
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-27 23:03:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-27 23:03:23 +0000
commit0d858a07c6dedf16e32c66d89715c72f13c61686 (patch)
tree0e9c9786c40aef6d407041ca70c80277f1c6e204 /devel/pear-System_Command
parent9fb4769a6a6743ea0bb10e87d33c8d0acc45f1df (diff)
Notes
Diffstat (limited to 'devel/pear-System_Command')
-rw-r--r--devel/pear-System_Command/Makefile23
-rw-r--r--devel/pear-System_Command/distinfo2
-rw-r--r--devel/pear-System_Command/pkg-descr12
3 files changed, 37 insertions, 0 deletions
diff --git a/devel/pear-System_Command/Makefile b/devel/pear-System_Command/Makefile
new file mode 100644
index 000000000000..e03166251f1e
--- /dev/null
+++ b/devel/pear-System_Command/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: pear-System_Command
+# Date created: 27 January 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= System_Command
+PORTVERSION= 1.0.1
+CATEGORIES= devel pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR command line execution interface
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= System
+FILES= Command.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-System_Command/distinfo b/devel/pear-System_Command/distinfo
new file mode 100644
index 000000000000..f256f0156162
--- /dev/null
+++ b/devel/pear-System_Command/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/System_Command-1.0.1.tgz) = 1cdc6c0797c719cf5c0cc4d21f1be058
+SIZE (PEAR/System_Command-1.0.1.tgz) = 5324
diff --git a/devel/pear-System_Command/pkg-descr b/devel/pear-System_Command/pkg-descr
new file mode 100644
index 000000000000..17cd68cd797f
--- /dev/null
+++ b/devel/pear-System_Command/pkg-descr
@@ -0,0 +1,12 @@
+System_Command is a command line execution interface.
+
+Running functions from the command line can be risky if the proper precautions
+are not taken to escape the shell arguments and reaping the exit status
+properly. This class provides a formal interface to both, so that you can run a
+system command as comfortably as you would run a php function, with full pear
+error handling as results on failure. It is important to note that this class,
+unlike other implementations, distinguishes between output to stderr and output
+to stdout. It also reports the exit status of the command. So in every sense of
+the word, it gives php shell capabilities.
+
+WWW: http://pear.php.net/package/System_Command/