aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-Testing_Selenium
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-15 21:49:01 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-15 21:49:01 +0000
commit7cdd6ba49d4971e2e4e4518a93e30b21b4f84d38 (patch)
treeb1d63e1895e094c54b3ebd0ee7faa8c275cac4d7 /devel/pear-Testing_Selenium
parenteec57da399eb1dce1a9c781a1033f78971590d47 (diff)
downloadports-7cdd6ba49d4971e2e4e4518a93e30b21b4f84d38.tar.gz
ports-7cdd6ba49d4971e2e4e4518a93e30b21b4f84d38.zip
Notes
Diffstat (limited to 'devel/pear-Testing_Selenium')
-rw-r--r--devel/pear-Testing_Selenium/Makefile35
-rw-r--r--devel/pear-Testing_Selenium/distinfo3
-rw-r--r--devel/pear-Testing_Selenium/pkg-descr13
3 files changed, 51 insertions, 0 deletions
diff --git a/devel/pear-Testing_Selenium/Makefile b/devel/pear-Testing_Selenium/Makefile
new file mode 100644
index 000000000000..d2a42b0d07ad
--- /dev/null
+++ b/devel/pear-Testing_Selenium/Makefile
@@ -0,0 +1,35 @@
+# Ports collection makefile for: pear-Testing_Selenium
+# Date created: 15 December 2007
+# Whom: Martin Wilke (miwi@FreeBSD.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= Testing_Selenium
+PORTVERSION= 0.4.1
+CATEGORIES= devel pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PEAR Binding - Once more unto the breach
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+
+FILES= Selenium/Exception.php \
+ ChangeLog \
+ Selenium.php \
+ README \
+ TODO
+EXAMPLES= example.php
+TESTS= html/bug8893.html \
+ html/bug9119.html \
+ html/bug9189.html \
+ AllTests.php \
+ BugTest.php \
+ GoogleTest.php \
+ SeleniumTest.php
+_TESTSDIR= tests
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-Testing_Selenium/distinfo b/devel/pear-Testing_Selenium/distinfo
new file mode 100644
index 000000000000..7120ea583916
--- /dev/null
+++ b/devel/pear-Testing_Selenium/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/Testing_Selenium-0.4.1.tgz) = 8732b7cde32b5fba8e9fee1fd46fc1bb
+SHA256 (PEAR/Testing_Selenium-0.4.1.tgz) = 301431266c431d6b68d626292788a3c829a00ef1e5a14e3aad97bdc5758a0746
+SIZE (PEAR/Testing_Selenium-0.4.1.tgz) = 25533
diff --git a/devel/pear-Testing_Selenium/pkg-descr b/devel/pear-Testing_Selenium/pkg-descr
new file mode 100644
index 000000000000..53984fe6d8b8
--- /dev/null
+++ b/devel/pear-Testing_Selenium/pkg-descr
@@ -0,0 +1,13 @@
+PHP Client for the Selenium Remote Control test tool
+
+Selenium Remote Control (SRC) is a test tool that allows you to write
+automated web application UI tests in any programming language against
+any HTTP website using any mainstream JavaScript-enabled browser. SRC
+provides a Selenium Server, which can automatically start/stop/control
+any supported browser. It works by using Selenium Core, a pure-HTML+JS
+library that performs automated tasks in JavaScript; the Selenium
+Server communicates directly with the browser using AJAX
+(XmlHttpRequest).
+
+
+WWW: http://pear.php.net/package/Testing_Selenium