aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-XML_XPath/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 02:28:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 02:28:24 +0000
commitf0b2ff48eb725052c7e1f214b55803bcc4c11206 (patch)
treee894f8cd6b8a3a35a1427eca442f5d331f60cd38 /devel/pear-XML_XPath/Makefile
parent039227639a33be8b076d087225df8015af47b703 (diff)
downloadports-f0b2ff48eb725052c7e1f214b55803bcc4c11206.tar.gz
ports-f0b2ff48eb725052c7e1f214b55803bcc4c11206.zip
Notes
Diffstat (limited to 'devel/pear-XML_XPath/Makefile')
-rw-r--r--devel/pear-XML_XPath/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/devel/pear-XML_XPath/Makefile b/devel/pear-XML_XPath/Makefile
new file mode 100644
index 000000000000..c5eaeec4d1a3
--- /dev/null
+++ b/devel/pear-XML_XPath/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-XML_XPath
+# Date created: 04 September 2003
+# Whom: Alex Miller (<asm@asm.kiev.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_XPath
+PORTVERSION= 1.2
+CATEGORIES= devel www
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR class provided an XPath/DOM XML manipulation
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+MANIFEST= common.php error.php result.php
+
+do-install:
+ @${MKDIR} ${PEARDIR}/XPath
+ @${CP} -p ${WRKSRC}/XPath.php ${PEARDIR}
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/XPath/${FILE} ${PEARDIR}/XPath
+.endfor
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/XPath.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/XPath
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -p ${WRKSRC}/docs/XML_XPath_example.php ${DOCSDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>