aboutsummaryrefslogtreecommitdiff
path: root/devel/pear-XML_XPath
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 02:28:24 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-09-08 02:28:24 +0000
commitf0b2ff48eb725052c7e1f214b55803bcc4c11206 (patch)
treee894f8cd6b8a3a35a1427eca442f5d331f60cd38 /devel/pear-XML_XPath
parent039227639a33be8b076d087225df8015af47b703 (diff)
downloadports-f0b2ff48eb725052c7e1f214b55803bcc4c11206.tar.gz
ports-f0b2ff48eb725052c7e1f214b55803bcc4c11206.zip
Notes
Diffstat (limited to 'devel/pear-XML_XPath')
-rw-r--r--devel/pear-XML_XPath/Makefile37
-rw-r--r--devel/pear-XML_XPath/distinfo1
-rw-r--r--devel/pear-XML_XPath/pkg-descr7
-rw-r--r--devel/pear-XML_XPath/pkg-plist9
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/pear-XML_XPath/Makefile b/devel/pear-XML_XPath/Makefile
new file mode 100644
index 000000000000..c5eaeec4d1a3
--- /dev/null
+++ b/devel/pear-XML_XPath/Makefile
@@ -0,0 +1,37 @@
+# Ports collection makefile for: pear-XML_XPath
+# Date created: 04 September 2003
+# Whom: Alex Miller (<asm@asm.kiev.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= XML_XPath
+PORTVERSION= 1.2
+CATEGORIES= devel www
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= PEAR class provided an XPath/DOM XML manipulation
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
+
+MANIFEST= common.php error.php result.php
+
+do-install:
+ @${MKDIR} ${PEARDIR}/XPath
+ @${CP} -p ${WRKSRC}/XPath.php ${PEARDIR}
+.for FILE in ${MANIFEST}
+ @${CP} -p ${WRKSRC}/XPath/${FILE} ${PEARDIR}/XPath
+.endfor
+ @${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/XPath.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/XPath
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -p ${WRKSRC}/docs/XML_XPath_example.php ${DOCSDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear-XML_XPath/distinfo b/devel/pear-XML_XPath/distinfo
new file mode 100644
index 000000000000..b2d4a043c49d
--- /dev/null
+++ b/devel/pear-XML_XPath/distinfo
@@ -0,0 +1 @@
+MD5 (PEAR/XML_XPath-1.2.tgz) = 71362e0ef17bfd56c63c3955d5ce91b8
diff --git a/devel/pear-XML_XPath/pkg-descr b/devel/pear-XML_XPath/pkg-descr
new file mode 100644
index 000000000000..c789151c4d83
--- /dev/null
+++ b/devel/pear-XML_XPath/pkg-descr
@@ -0,0 +1,7 @@
+This is an XML parser based on PHP's built-in xml extension. It
+supports two basic modes of operation: "func" and "event". In "func"
+mode, it will look for a function named after each element
+(xmltag_ELEMENT for start tags and xmltag_ELEMENT_ for end tags), and
+in "event" mode it uses a set of generic callbacks.
+
+WWW: http://pear.php.net/package-info.php?package=XML_Parser
diff --git a/devel/pear-XML_XPath/pkg-plist b/devel/pear-XML_XPath/pkg-plist
new file mode 100644
index 000000000000..1cfe7c12589b
--- /dev/null
+++ b/devel/pear-XML_XPath/pkg-plist
@@ -0,0 +1,9 @@
+%%PEARDIR%%/XPath.php
+%%PEARDIR%%/XPath/common.php
+%%PEARDIR%%/XPath/error.php
+%%PEARDIR%%/XPath/result.php
+%%PKGREGDIR%%/package.xml
+%%PORTDOCS%%%%PEARDIR%%/docs/XML_XPath/XML_XPath_example.php
+@dirrm %%PEARDIR%%/XPath
+@dirrm %%PKGREGDIR%%
+%%PORTDOCS%%@dirrm %%PEARDIR%%/docs/XML_XPath