aboutsummaryrefslogtreecommitdiff
path: root/devel/pear
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-17 05:03:54 +0000
commit050dd1b1031022b49cd1623dd3892f3c4be3a1ae (patch)
tree0876fb5cc1d38a316c0fbaf87137d69775f5dad0 /devel/pear
parentcf19879c06b65241c187f1b0663a0db0270be14f (diff)
downloadports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.tar.gz
ports-050dd1b1031022b49cd1623dd3892f3c4be3a1ae.zip
Notes
Diffstat (limited to 'devel/pear')
-rw-r--r--devel/pear/Makefile42
-rw-r--r--devel/pear/pkg-comment1
-rw-r--r--devel/pear/pkg-descr20
-rw-r--r--devel/pear/pkg-plist1
4 files changed, 64 insertions, 0 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
new file mode 100644
index 000000000000..aa371d67c6ff
--- /dev/null
+++ b/devel/pear/Makefile
@@ -0,0 +1,42 @@
+# Ports collection makefile for: pear
+# Date created: Sat Nov 10, 2001
+# Whom: Thierry Thomas (<thierry@pompo.net>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear
+PORTVERSION= ${PHP_VERSION}
+CATEGORIES= devel www
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= thierry@pompo.net
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/php-config:${PORTSDIR}/www/mod_php4
+RUN_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR \
+ ${PEARDIR}/Console/Getopt.php.dist:${PORTSDIR}/devel/pear-Console_Getopt \
+ ${PEARDIR}/File.php:${PORTSDIR}/sysutils/pear-File \
+ ${PEARDIR}/Log.php:${PORTSDIR}/sysutils/pear-Log \
+ ${PEARDIR}/Mail/mime.php:${PORTSDIR}/mail/pear-Mail_Mime \
+ ${PEARDIR}/Net/Sieve.php:${PORTSDIR}/net/pear-Net_Sieve
+
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_VERSION!= ${LOCALBASE}/bin/php-config --version
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_VERSION= 4.2.3
+PHP_BASE= ${LOCALBASE}
+.endif
+LPHP_LIB= lib/php
+PEARDIR= ${PHP_BASE}/${LPHP_LIB}
+
+do-install: # empty
+ ${DO_NADA}
+
+.include <bsd.port.post.mk>
diff --git a/devel/pear/pkg-comment b/devel/pear/pkg-comment
new file mode 100644
index 000000000000..bccf091e076a
--- /dev/null
+++ b/devel/pear/pkg-comment
@@ -0,0 +1 @@
+A framework and distribution system for reusable PHP components
diff --git a/devel/pear/pkg-descr b/devel/pear/pkg-descr
new file mode 100644
index 000000000000..5e107e566a81
--- /dev/null
+++ b/devel/pear/pkg-descr
@@ -0,0 +1,20 @@
+PEAR is a code repository for PHP extensions and PHP library code
+inspired by TeX's CTAN and Perl's CPAN.
+
+The purpose of PEAR is:
+
+ * to provide a consistent means for library code authors to
+ share their code with other developers;
+
+ * to give the PHP community an infrastructure for sharing code;
+
+ * to define standards that help developers write portable and
+ reusable code;
+
+ * to provide tools for code maintenance and distribution.
+
+PEAR comes bundled with PHP4. However, since it is a rapidly evolving
+target, not everyone who has a workable version of PHP4 has a recent
+enough PEAR installation.
+
+WWW: http://pear.php.net/
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
new file mode 100644
index 000000000000..549a621fec0c
--- /dev/null
+++ b/devel/pear/pkg-plist
@@ -0,0 +1 @@
+@comment this plist intentionally left empty