aboutsummaryrefslogtreecommitdiff
path: root/devel/pear
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2005-12-09 18:58:03 +0000
committerAlex Dupre <ale@FreeBSD.org>2005-12-09 18:58:03 +0000
commit4e6ebc04cb2ecb570b58d17b068cbf5ef58196bd (patch)
treeea0367a13d5f5542a8d3f5670605f4abe782bd3d /devel/pear
parentecf3acdd70fa67786fe88ee97f1c6c71cc9264d7 (diff)
downloadports-4e6ebc04cb2ecb570b58d17b068cbf5ef58196bd.tar.gz
ports-4e6ebc04cb2ecb570b58d17b068cbf5ef58196bd.zip
Notes
Diffstat (limited to 'devel/pear')
-rw-r--r--devel/pear/Makefile35
-rw-r--r--devel/pear/bsd.pear.mk239
-rw-r--r--devel/pear/distinfo3
-rw-r--r--devel/pear/files/patch-go-pear134
-rw-r--r--devel/pear/files/pkg-message.in8
-rw-r--r--devel/pear/pear-deinstall15
-rw-r--r--devel/pear/pear-install14
-rw-r--r--devel/pear/pkg-descr13
-rw-r--r--devel/pear/pkg-plist169
9 files changed, 630 insertions, 0 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
new file mode 100644
index 000000000000..4d6fdd75fddf
--- /dev/null
+++ b/devel/pear/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pear
+# Date created: 25 Nov 2005
+# Whom: Alex Dupre <ale@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pear
+PORTVERSION= 1.4.5
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= ale
+
+MAINTAINER= ale@FreeBSD.org
+COMMENT= PEAR framework for PHP
+
+USE_BZIP2= yes
+NO_BUILD= yes
+
+WANT_PHP_SCR= yes
+USE_PHP= pcre xml
+
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+USE_REINPLACE= yes
+
+post-patch:
+ @${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/go-pear
+
+do-install:
+ @${LOCALBASE}/bin/php -q ${WRKSRC}/go-pear
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/devel/pear/bsd.pear.mk b/devel/pear/bsd.pear.mk
new file mode 100644
index 000000000000..f633c9b0199b
--- /dev/null
+++ b/devel/pear/bsd.pear.mk
@@ -0,0 +1,239 @@
+# $FreeBSD$
+
+# Common code for pear- ports.
+
+MASTER_SITES= http://pear.php.net/get/
+PKGNAMEPREFIX= pear-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PEAR
+
+USE_REINPLACE= yes
+
+.if !defined(USE_PHPIZE)
+NO_BUILD= yes
+.endif
+
+.if exists(${LOCALBASE}/bin/php-config)
+PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
+.else
+PHP_BASE= ${LOCALBASE}
+.endif
+LPEARDIR= share/pear
+LPKGREGDIR= ${LPEARDIR}/packages/${PKGNAME}
+LDATADIR= ${LPEARDIR}/data/${PORTNAME}
+LDOCSDIR= share/doc/pear/${PORTNAME}
+LEXAMPLESDIR= share/examples/pear/${PORTNAME}
+LSQLSDIR= ${LPEARDIR}/sql/${PORTNAME}
+LSCRIPTSDIR= bin
+LTESTSDIR= ${LPEARDIR}/tests/${PORTNAME}
+PEARDIR= ${PHP_BASE}/${LPEARDIR}
+PKGREGDIR= ${PHP_BASE}/${LPKGREGDIR}
+DATADIR= ${PHP_BASE}/${LDATADIR}
+DOCSDIR= ${PHP_BASE}/${LDOCSDIR}
+EXAMPLESDIR= ${PHP_BASE}/${LEXAMPLESDIR}
+SQLSDIR= ${PHP_BASE}/${LSQLSDIR}
+SCRIPTFILESDIR= ${LOCALBASE}/bin
+TESTSDIR= ${PHP_BASE}/${LTESTSDIR}
+.if defined(CATEGORY) && !empty(CATEGORY)
+LINSTDIR= ${LPEARDIR}/${CATEGORY}
+.else
+LINSTDIR= ${LPEARDIR}
+.endif
+INSTDIR= ${PHP_BASE}/${LINSTDIR}
+
+.if !defined(USE_PHPIZE) && !exists(${.CURDIR}/pkg-plist)
+PLIST= ${WRKDIR}/PLIST
+.endif
+PLIST_SUB= PEARDIR=${LPEARDIR} PKGREGDIR=${LPKGREGDIR} \
+ TESTSDIR=${LTESTSDIR} INSTDIR=${LINSTDIR} SQLSDIR=${LSQLSDIR} \
+ SCRIPTFILESDIR=${LCRIPTSDIR}
+
+PKGINSTALL= ${PORTSDIR}/devel/pear/pear-install
+PKGDEINSTALL= ${PORTSDIR}/devel/pear/pear-deinstall
+
+FILES?=
+DATA?=
+DOCS?=
+EXAMPLES?=
+SQLS?=
+SCRIPTFILES?=
+TESTS?=
+_DATADIR?= data
+_DOCSDIR?= docs
+_EXAMPLESDIR?= examples
+_SQLSDIR?= sql
+_TESTSDIR?= tests
+
+# this is an easy way to eliminate duplicate entries in a variable :)
+# if someone knows how to achieve the result without this terrible
+# hack, please tell me!
+.for v in FILES DOCS TESTS EXAMPLES SQLS SCRIPTFILES DATA
+X${v}DIRS= ${${v}:M*/*:C;/[^/]+$;;}
+. for XD in ${X${v}DIRS}
+ALREADYTHERE= 0
+. for D in ${${v}DIRS}
+DD= ${D}
+. if ${DD} == ${XD}
+ALREADYTHERE= 1
+. endif
+. endfor
+. if ${ALREADYTHERE} == 0
+${v}DIRS+= ${XD}
+. endif
+. endfor
+.endfor
+
+pre-install:
+.if exists(${LOCALBASE}/lib/php.DIST_PHP) \
+ || exists(${PHP_BASE}/lib/php.DIST_PHP) \
+ || exists(${LOCALBASE}/.PEAR.pkg) \
+ || exists(${PHP_BASE}/.PEAR.pkg)
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Sorry, the PEAR structure has been modified;"
+ @${ECHO_MSG} " Please deinstall your installed pear- ports."
+ @${ECHO_MSG} ""
+ @${FALSE}
+.endif
+
+DIRFILTER= ${SED} -En '\:^.*/[^/]*$$:s:^(.+)/[^/]*$$:\1:p' | ${SORT} -ru
+
+.if !defined(USE_PHPIZE)
+do-generate-plist:
+. if !exists(${.CURDIR}/pkg-plist)
+ @${ECHO_MSG} "===> Generating packing list"; \
+ (for file in ${FILES}; do echo "${LINSTDIR}/$${file}"; done; \
+ for file in ${TESTS}; do echo "${LTESTSDIR}/$${file}"; done; \
+ for file in ${DATA}; do echo "${LDATADIR}/$${file}"; done; \
+ for file in ${SQLS}; do echo "${LSQLSDIR}/$${file}"; done; \
+ for file in ${SCRIPTFILES}; do echo "${LSCRIPTSDIR}/$${file}"; done; \
+ for file in ${DOCS}; do echo "%%PORTDOCS%%${LDOCSDIR}/$${file}"; done; \
+ for file in ${EXAMPLES}; do echo "%%PORTDOCS%%${LEXAMPLESDIR}/$${file}"; done; \
+ echo "${LPKGREGDIR}/package.xml"; \
+ for d in ${FILES} ${FILES:H}; do echo $${d}; done | ${DIRFILTER} | \
+ while read dir; do echo "@dirrm ${LINSTDIR}/$${dir}"; done; \
+ for d in ${TESTS}; do echo $${d}; done | ${DIRFILTER} | \
+ while read dir; do echo "@dirrm ${LTESTSDIR}/$${dir}"; done; \
+ for d in ${DATA}; do echo $${d}; done | ${DIRFILTER} | \
+ while read dir; do echo "@dirrm ${LDATADIR}/$${dir}"; done; \
+ for d in ${SQLS}; do echo $${d}; done | ${DIRFILTER} | \
+ while read dir; do echo "@dirrm ${LSQLSDIR}/$${dir}"; done; \
+ for d in ${DOCS}; do echo $${d}; done | ${DIRFILTER} | \
+ while read dir; do echo "%%PORTDOCS%%@dirrm ${LDOCSDIR}/$${dir}"; done; \
+ for d in ${EXAMPLES}; do echo $${d}; done | ${DIRFILTER} | \
+ while read dir; do echo "%%PORTDOCS%%@dirrm ${LEXAMPLESDIR}/$${dir}"; done; \
+ if [ -n "${TESTS}" ]; then echo "@dirrm ${LTESTSDIR}"; fi; \
+ if [ -n "${DATA}" ]; then echo "@dirrm ${LDATADIR}"; fi; \
+ if [ -n "${SQLS}" ]; then echo "@dirrm ${LSQLSDIR}"; fi; \
+ if [ -n "${DOCS}" ]; then echo "%%PORTDOCS%%@dirrm ${LDOCSDIR}"; fi; \
+ if [ -n "${EXAMPLES}" ]; then echo "%%PORTDOCS%%@dirrm ${LEXAMPLESDIR}"; fi; \
+ echo "@dirrm ${LPKGREGDIR}"; \
+ echo "@unexec rmdir %D/${LINSTDIR} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LINSTDIR:H} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LPEARDIR}/.registry 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LPEARDIR}/packages 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LPEARDIR} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LDOCSDIR:H} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LEXAMPLESDIR:H} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LTESTSDIR:H} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LDATADIR:H} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LSCRIPTSDIR:H} 2> /dev/null || true"; \
+ echo "@unexec rmdir %D/${LSQLSDIR:H} 2> /dev/null || true") > ${PLIST}
+. endif
+
+. for t in files docs tests sqls scriptfiles examples data
+. if !target(do-install-${t}-msg)
+do-install-${t}-msg: .USE
+. endif
+. endfor
+
+pre-install: do-generate-plist
+do-install: do-install-files do-install-docs do-install-tests do-install-sqls \
+ do-install-scriptfiles do-install-examples do-install-data
+
+do-install-files: do-install-files-msg
+ @${MKDIR} ${INSTDIR}
+. for dir in ${FILESDIRS}
+ @${MKDIR} ${INSTDIR}/${dir}
+. endfor
+. for file in ${FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${INSTDIR}/${file}
+. endfor
+
+do-install-docs: do-install-docs-msg
+. if !defined(NOPORTDOCS) && !empty(DOCS)
+ @${ECHO_MSG} "===> Installing documentation in ${DOCSDIR}."
+ @${MKDIR} ${DOCSDIR}
+. for dir in ${DOCSDIRS}
+ @${MKDIR} ${DOCSDIR}/${dir}
+. endfor
+. for file in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${_DOCSDIR}/${file} ${DOCSDIR}/${file}
+. endfor
+. endif
+
+do-install-tests: do-install-tests-msg
+. if !empty(TESTS)
+ @${ECHO_MSG} "===> Installing tests in ${TESTSDIR}."
+ @${MKDIR} ${TESTSDIR}
+. for dir in ${TESTSDIRS}
+ @${MKDIR} ${TESTSDIR}/${dir}
+. endfor
+. for file in ${TESTS}
+ @${INSTALL_DATA} ${WRKSRC}/${_TESTSDIR}/${file} ${TESTSDIR}/${file}
+. endfor
+. endif
+
+do-install-data: do-install-data-msg
+. if !empty(DATA)
+ @${ECHO_MSG} "===> Installing data in ${DATADIR}."
+ @${MKDIR} ${DATADIR}
+. for dir in ${DATADIRS}
+ @${MKDIR} ${DATADIR}/${dir}
+. endfor
+. for file in ${DATA}
+ @${INSTALL_DATA} ${WRKSRC}/${_DATADIR}/${file} ${DATADIR}/${file}
+. endfor
+. endif
+
+do-install-sqls: do-install-sqls-msg
+. if !empty(SQLS)
+ @${ECHO_MSG} "===> Installing sqls in ${SQLSDIR}."
+ @${MKDIR} ${SQLSDIR}
+. for dir in ${SQLSDIRS}
+ @${MKDIR} ${SQLSDIR}/${dir}
+. endfor
+. for file in ${SQLS}
+ @${INSTALL_DATA} ${WRKSRC}/${_SQLSDIR}/${file} ${SQLSDIR}/${file}
+. endfor
+. endif
+
+do-install-scriptfiles: do-install-scriptfiles-msg
+. if !empty(SCRIPTFILES)
+ @${ECHO_MSG} "===> Installing scripts in ${SCRIPTFILESDIR}."
+. for file in ${SCRIPTFILES}
+ @${CP} ${WRKSRC}/pear-${file} ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|@php_bin@|${SCRIPTFILESDIR}/php|g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|@php_dir@|${PREFIX}/lib/php|g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s|@include_path@|${PREFIX}/${LPEARDIR}|g" ${WRKSRC}/${file}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${file} ${SCRIPTFILESDIR}/${file}
+. endfor
+. endif
+
+do-install-examples: do-install-examples-msg
+. if !defined(NOPORTDOCS) && !empty(EXAMPLES)
+ @${ECHO_MSG} "===> Installing examples in ${EXAMPLESDIR}."
+ @${MKDIR} ${EXAMPLESDIR}
+. for dir in ${EXAMPLESDIRS}
+ @${MKDIR} ${EXAMPLESDIR}/${dir}
+. endfor
+. for file in ${EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${_EXAMPLESDIR}/${file} ${EXAMPLESDIR}/${file}
+. endfor
+. endif
+.endif
+
+post-install:
+ @${MKDIR} ${PKGREGDIR}
+ @${INSTALL_DATA} ${WRKDIR}/package.xml ${PKGREGDIR}
+ @${SETENV} PKG_PREFIX=${PREFIX} \
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
diff --git a/devel/pear/distinfo b/devel/pear/distinfo
new file mode 100644
index 000000000000..2f62e822edf0
--- /dev/null
+++ b/devel/pear/distinfo
@@ -0,0 +1,3 @@
+MD5 (pear-1.4.5.tar.bz2) = 34d8096b4fb989fb9a412acf61c23bcc
+SHA256 (pear-1.4.5.tar.bz2) = 314dd7e1e5d3e42fd0d7086728562890f2354ab6fd55dbdf6fd5e2ea2c991774
+SIZE (pear-1.4.5.tar.bz2) = 272688
diff --git a/devel/pear/files/patch-go-pear b/devel/pear/files/patch-go-pear
new file mode 100644
index 000000000000..f228c055b3f4
--- /dev/null
+++ b/devel/pear/files/patch-go-pear
@@ -0,0 +1,134 @@
+--- go-pear.orig Mon Dec 5 07:50:50 2005
++++ go-pear Thu Dec 8 10:04:09 2005
+@@ -278,6 +278,7 @@
+ $install_pfc = $_SESSION['go-pear']['install_pfc'];
+ }
+
++/*
+ if (!WEBINSTALLER) {
+ $tty = WINDOWS ? @fopen('\con', 'r') : @fopen('/dev/tty', 'r');
+
+@@ -321,6 +322,7 @@
+ $http_proxy = $tmp;
+ }
+ }
++*/
+
+ $origpwd = getcwd();
+
+@@ -415,6 +417,7 @@
+ mkdir_p($ptmp, 0700);
+ $ok = @chdir($ptmp);
+
++/*
+ while (!WEBINSTALLER) {
+ print "
+ Below is a suggested file layout for your new PEAR installation. To
+@@ -495,6 +498,7 @@
+ }
+ }
+ }
++*/
+
+ foreach ($config_vars as $n => $var) {
+ for ($m = 1; $m <= count($config_vars); $m++) {
+@@ -519,6 +523,7 @@
+ }
+ }
+
++/*
+ if (!WEBINSTALLER) {
+ $msg = "The following PEAR packages are bundled with PHP: " .
+ implode(', ', $pfc_packages);
+@@ -527,6 +532,7 @@
+ $install_pfc = !stristr(fgets($tty, 1024), "n");
+ print "\n";
+ }
++*/
+
+ ####
+ # Download
+@@ -534,6 +540,7 @@
+
+ ini_set("include_path", $ptmp);
+
++/*
+ if (!extension_loaded('zlib') && !WEBINSTALLER) { // In Web context we could be in multithread env which makes dl() end up with a fatal error.
+ if (WINDOWS) {
+ @dl('php_zlib.dll');
+@@ -556,6 +563,7 @@
+ if (!$have_gzip) {
+ print "Downloading uncompressed packages\n";
+ };
++*/
+
+ if ($install_pfc) {
+ $to_install = array_merge($installer_packages, $pfc_packages);
+@@ -580,7 +588,7 @@
+
+ foreach ($installer_packages as $pkg) {
+ foreach($local_dir as $file) {
+- if (substr($file, 0, strlen(str_replace('-stable', '', $pkg))) == str_replace('-stable', '', $pkg)) {
++ if (substr($file, 0, strlen(str_replace('stable', '', $pkg))) == str_replace('stable', '', $pkg)) {
+ $pkg = str_replace('-stable', '', $pkg);
+ echo str_pad("Using local package: $pkg", max(38,21+strlen($pkg)+4), '.');
+ copy(dirname(__FILE__).'/go-pear-bundle/'.$file, $file);
+@@ -688,7 +696,7 @@
+ if (WEBINSTALLER || isset($_SERVER['argv'][1]) && $_SERVER['argv'][1] == 'local') {
+ $config = &PEAR_Config::singleton($prefix."/pear.conf", '');
+ } else {
+- $config = &PEAR_Config::singleton();
++ $config = &PEAR_Config::singleton($prefix."/etc/pear.conf", '');
+ };
+ $config->set('preferred_state', 'stable');
+ foreach ($config_vars as $var) {
+@@ -719,6 +727,7 @@
+
+ // Base installation finished
+
++/*
+ ini_restore("include_path");
+
+ if (!WEBINSTALLER) {
+@@ -876,6 +885,7 @@
+ if (WINDOWS && !WEBINSTALLER) {
+ win32CreateRegEnv();
+ }
++*/
+ // Set of functions following
+
+ // {{{ download_url()
+@@ -1248,15 +1258,16 @@
+ }
+ } else {
+ if ($_prefix === null) {
+- $prefix = dirname(PHP_BINDIR);
++ $prefix = "%%PREFIX%%";
+ } else {
+ $prefix = $_prefix;
+ }
+ $bin_dir = '$prefix/bin';
+ $php_dir = '$prefix/share/pear';
+- $doc_dir = '$php_dir/docs';
++ $doc_dir = '$prefix/share/doc/pear';
+ $data_dir = '$php_dir/data';
+ $test_dir = '$php_dir/tests';
++/*
+ // check if the user has installed PHP with PHP or GNU layout
+ if (@is_dir("$prefix/lib/php/.registry")) {
+ $php_dir = '$prefix/lib/php';
+@@ -1268,6 +1279,7 @@
+ } elseif (@is_dir("$prefix/share/php/.registry")) {
+ $php_dir = '$prefix/share/php';
+ }
++*/
+ }
+ }
+
+@@ -2373,4 +2385,4 @@
+ }
+ return true;
+ }
+-?>
+\ No newline at end of file
++?>
diff --git a/devel/pear/files/pkg-message.in b/devel/pear/files/pkg-message.in
new file mode 100644
index 000000000000..f15828832865
--- /dev/null
+++ b/devel/pear/files/pkg-message.in
@@ -0,0 +1,8 @@
+*********************************************************
+
+To use PEAR you have to add the correct include path into
+your ${LOCALBASE}/etc/php.ini configuration file, like:
+
+include_path = ".:%%PREFIX%%/share/pear"
+
+*********************************************************
diff --git a/devel/pear/pear-deinstall b/devel/pear/pear-deinstall
new file mode 100644
index 000000000000..39672a7cb577
--- /dev/null
+++ b/devel/pear/pear-deinstall
@@ -0,0 +1,15 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Remove package declaration from PEAR's registry.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+PKG_NAME=${1%%-[0-9._]*}
+PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
+
+PEAR=${PKG_PREFIX}/bin/pear
+
+${PEAR} uninstall -r -n ${PACKAGE} || true
diff --git a/devel/pear/pear-install b/devel/pear/pear-install
new file mode 100644
index 000000000000..2bf50d301095
--- /dev/null
+++ b/devel/pear/pear-install
@@ -0,0 +1,14 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Register the package $1 in the port registry
+
+PREFIX=${PKG_PREFIX:=%%PREFIX%%}
+PEAR=${PREFIX}/bin/pear
+PKGREGDIR=${PREFIX}/share/pear/packages/$1
+
+[ "x$1" = "x" ] && exit 1
+if [ "x$2" = "xPOST-INSTALL" ]; then
+ ${PEAR} install -r -n -f ${PKGREGDIR}/package.xml
+fi
diff --git a/devel/pear/pkg-descr b/devel/pear/pkg-descr
new file mode 100644
index 000000000000..e371f2cc0a22
--- /dev/null
+++ b/devel/pear/pkg-descr
@@ -0,0 +1,13 @@
+PEAR is a framework and distribution system for reusable PHP components.
+
+PEAR is short for "PHP Extension and Application Repository" and is
+pronounced just like the fruit. The purpose of PEAR is to provide:
+ - A structured library of open-sourced code for PHP users
+ - A system for code distribution and package maintenance
+ - A standard style for code written in PHP
+ - The PHP Extension Community Library (PECL)
+
+WWW: http://pear.php.net/
+
+- Alex Dupre
+ale@FreeBSD.org
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
new file mode 100644
index 000000000000..d93ec06a6900
--- /dev/null
+++ b/devel/pear/pkg-plist
@@ -0,0 +1,169 @@
+bin/pear
+bin/peardev
+bin/pecl
+etc/pear.conf
+%%DOCSDIR%%/Archive_Tar/docs/Archive_Tar.txt
+@exec mkdir -p %D/share/pear/.channels/.alias
+@exec mkdir -p %D/share/pear/.registry/.channel.__uri
+@exec mkdir -p %D/share/pear/.registry/.channel.pecl.php.net
+@exec touch %D/share/pear/.channels/.alias/pear.txt
+@exec touch %D/share/pear/.channels/.alias/pecl.txt
+@exec touch %D/share/pear/.channels/__uri.reg
+@exec touch %D/share/pear/.channels/pear.php.net.reg
+@exec touch %D/share/pear/.channels/pecl.php.net.reg
+@exec touch %D/share/pear/.depdb
+@exec touch %D/share/pear/.depdblock
+@exec touch %D/share/pear/.filemap
+@exec touch %D/share/pear/.lock
+%%DATADIR%%/.registry/archive_tar.reg
+%%DATADIR%%/.registry/console_getopt.reg
+%%DATADIR%%/.registry/pear.reg
+%%DATADIR%%/.registry/xml_rpc.reg
+%%DATADIR%%/Archive/Tar.php
+%%DATADIR%%/Console/Getopt.php
+%%DATADIR%%/OS/Guess.php
+%%DATADIR%%/PEAR/Autoloader.php
+%%DATADIR%%/PEAR/Builder.php
+%%DATADIR%%/PEAR/ChannelFile/Parser.php
+%%DATADIR%%/PEAR/ChannelFile.php
+%%DATADIR%%/PEAR/Command/Auth.php
+%%DATADIR%%/PEAR/Command/Auth.xml
+%%DATADIR%%/PEAR/Command/Build.php
+%%DATADIR%%/PEAR/Command/Build.xml
+%%DATADIR%%/PEAR/Command/Channels.php
+%%DATADIR%%/PEAR/Command/Channels.xml
+%%DATADIR%%/PEAR/Command/Common.php
+%%DATADIR%%/PEAR/Command/Config.php
+%%DATADIR%%/PEAR/Command/Config.xml
+%%DATADIR%%/PEAR/Command/Install.php
+%%DATADIR%%/PEAR/Command/Install.xml
+%%DATADIR%%/PEAR/Command/Mirror.php
+%%DATADIR%%/PEAR/Command/Mirror.xml
+%%DATADIR%%/PEAR/Command/Package.php
+%%DATADIR%%/PEAR/Command/Package.xml
+%%DATADIR%%/PEAR/Command/Pickle.php
+%%DATADIR%%/PEAR/Command/Pickle.xml
+%%DATADIR%%/PEAR/Command/Registry.php
+%%DATADIR%%/PEAR/Command/Registry.xml
+%%DATADIR%%/PEAR/Command/Remote.php
+%%DATADIR%%/PEAR/Command/Remote.xml
+%%DATADIR%%/PEAR/Command/Test.php
+%%DATADIR%%/PEAR/Command/Test.xml
+%%DATADIR%%/PEAR/Command.php
+%%DATADIR%%/PEAR/Common.php
+%%DATADIR%%/PEAR/Config.php
+%%DATADIR%%/PEAR/Dependency.php
+%%DATADIR%%/PEAR/Dependency2.php
+%%DATADIR%%/PEAR/DependencyDB.php
+%%DATADIR%%/PEAR/Downloader/Package.php
+%%DATADIR%%/PEAR/Downloader.php
+%%DATADIR%%/PEAR/ErrorStack.php
+%%DATADIR%%/PEAR/Exception.php
+%%DATADIR%%/PEAR/Frontend/CLI.php
+%%DATADIR%%/PEAR/Frontend.php
+%%DATADIR%%/PEAR/Installer/Role/Common.php
+%%DATADIR%%/PEAR/Installer/Role/Data.php
+%%DATADIR%%/PEAR/Installer/Role/Data.xml
+%%DATADIR%%/PEAR/Installer/Role/Doc.php
+%%DATADIR%%/PEAR/Installer/Role/Doc.xml
+%%DATADIR%%/PEAR/Installer/Role/Ext.php
+%%DATADIR%%/PEAR/Installer/Role/Ext.xml
+%%DATADIR%%/PEAR/Installer/Role/Php.php
+%%DATADIR%%/PEAR/Installer/Role/Php.xml
+%%DATADIR%%/PEAR/Installer/Role/Script.php
+%%DATADIR%%/PEAR/Installer/Role/Script.xml
+%%DATADIR%%/PEAR/Installer/Role/Src.php
+%%DATADIR%%/PEAR/Installer/Role/Src.xml
+%%DATADIR%%/PEAR/Installer/Role/Test.php
+%%DATADIR%%/PEAR/Installer/Role/Test.xml
+%%DATADIR%%/PEAR/Installer/Role.php
+%%DATADIR%%/PEAR/Installer.php
+%%DATADIR%%/PEAR/PackageFile/Generator/v1.php
+%%DATADIR%%/PEAR/PackageFile/Generator/v2.php
+%%DATADIR%%/PEAR/PackageFile/Parser/v1.php
+%%DATADIR%%/PEAR/PackageFile/Parser/v2.php
+%%DATADIR%%/PEAR/PackageFile/v1.php
+%%DATADIR%%/PEAR/PackageFile/v2/Validator.php
+%%DATADIR%%/PEAR/PackageFile/v2/rw.php
+%%DATADIR%%/PEAR/PackageFile/v2.php
+%%DATADIR%%/PEAR/PackageFile.php
+%%DATADIR%%/PEAR/Packager.php
+%%DATADIR%%/PEAR/REST/10.php
+%%DATADIR%%/PEAR/REST/11.php
+%%DATADIR%%/PEAR/REST.php
+%%DATADIR%%/PEAR/Registry.php
+%%DATADIR%%/PEAR/Remote.php
+%%DATADIR%%/PEAR/RunTest.php
+%%DATADIR%%/PEAR/Task/Common.php
+%%DATADIR%%/PEAR/Task/Postinstallscript/rw.php
+%%DATADIR%%/PEAR/Task/Postinstallscript.php
+%%DATADIR%%/PEAR/Task/Replace/rw.php
+%%DATADIR%%/PEAR/Task/Replace.php
+%%DATADIR%%/PEAR/Task/Unixeol/rw.php
+%%DATADIR%%/PEAR/Task/Unixeol.php
+%%DATADIR%%/PEAR/Task/Windowseol/rw.php
+%%DATADIR%%/PEAR/Task/Windowseol.php
+%%DATADIR%%/PEAR/Validate.php
+%%DATADIR%%/PEAR/Validator/PECL.php
+%%DATADIR%%/PEAR/XMLParser.php
+%%DATADIR%%/PEAR.php
+%%DATADIR%%/System.php
+%%DATADIR%%/XML/RPC/Dump.php
+%%DATADIR%%/XML/RPC/Server.php
+%%DATADIR%%/XML/RPC.php
+%%DATADIR%%/data/PEAR/package.dtd
+%%DATADIR%%/data/PEAR/template.spec
+%%DATADIR%%/pearcmd.php
+%%DATADIR%%/peclcmd.php
+%%DATADIR%%/tests/XML_RPC/tests/allgot.inc
+%%DATADIR%%/tests/XML_RPC/tests/empty-value-struct.php
+%%DATADIR%%/tests/XML_RPC/tests/empty-value.php
+%%DATADIR%%/tests/XML_RPC/tests/protoport.php
+%%DATADIR%%/tests/XML_RPC/tests/test_Dump.php
+%%DATADIR%%/tests/XML_RPC/tests/types.php
+@dirrm %%DOCSDIR%%/Archive_Tar/docs
+@dirrm %%DOCSDIR%%/Archive_Tar
+@unexec rmdir %D/share/doc/pear 2> /dev/null || true
+@unexec rm %D/share/pear/.channels/.alias/pear.txt 2> /dev/null || true
+@unexec rm %D/share/pear/.channels/.alias/pecl.txt 2> /dev/null || true
+@unexec rm %D/share/pear/.channels/__uri.reg 2> /dev/null || true
+@unexec rm %D/share/pear/.channels/pear.php.net.reg 2> /dev/null || true
+@unexec rm %D/share/pear/.channels/pecl.php.net.reg 2> /dev/null || true
+@unexec rm %D/share/pear/.depdb 2> /dev/null || true
+@unexec rm %D/share/pear/.depdblock 2> /dev/null || true
+@unexec rm %D/share/pear/.filemap 2> /dev/null || true
+@unexec rm %D/share/pear/.lock 2> /dev/null || true
+@unexec rmdir %D/share/pear/.channels/.alias 2> /dev/null || true
+@unexec rmdir %D/share/pear/.channels 2> /dev/null || true
+@unexec rmdir %D/share/pear/.registry/.channel.__uri 2> /dev/null || true
+@unexec rmdir %D/share/pear/.registry/.channel.pecl.php.net 2> /dev/null || true
+@unexec rmdir %D/share/pear/.registry 2> /dev/null || true
+@dirrm %%DATADIR%%/Archive
+@dirrm %%DATADIR%%/Console
+@dirrm %%DATADIR%%/OS
+@dirrm %%DATADIR%%/PEAR/ChannelFile
+@dirrm %%DATADIR%%/PEAR/Command
+@dirrm %%DATADIR%%/PEAR/Downloader
+@dirrm %%DATADIR%%/PEAR/Frontend
+@dirrm %%DATADIR%%/PEAR/Installer/Role
+@dirrm %%DATADIR%%/PEAR/Installer
+@dirrm %%DATADIR%%/PEAR/PackageFile/Generator
+@dirrm %%DATADIR%%/PEAR/PackageFile/Parser
+@dirrm %%DATADIR%%/PEAR/PackageFile/v2
+@dirrm %%DATADIR%%/PEAR/PackageFile
+@dirrm %%DATADIR%%/PEAR/REST
+@dirrm %%DATADIR%%/PEAR/Task/Postinstallscript
+@dirrm %%DATADIR%%/PEAR/Task/Replace
+@dirrm %%DATADIR%%/PEAR/Task/Unixeol
+@dirrm %%DATADIR%%/PEAR/Task/Windowseol
+@dirrm %%DATADIR%%/PEAR/Task
+@dirrm %%DATADIR%%/PEAR/Validator
+@dirrm %%DATADIR%%/PEAR
+@dirrm %%DATADIR%%/XML/RPC
+@unexec rmdir %D/share/pear/XML 2> /dev/null || true
+@dirrm %%DATADIR%%/data/PEAR
+@unexec rmdir %D/share/pear/data 2> /dev/null || true
+@dirrm %%DATADIR%%/tests/XML_RPC/tests
+@dirrm %%DATADIR%%/tests/XML_RPC
+@unexec rmdir %D/share/pear/tests 2> /dev/null || true
+@unexec rmdir %D/share/pear 2> /dev/null || true