aboutsummaryrefslogtreecommitdiff
path: root/devel/pear
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2010-08-25 08:38:44 +0000
committerMartin Matuska <mm@FreeBSD.org>2010-08-25 08:38:44 +0000
commitd0f6b75a0a5a620cb27e414a19db99de0d81de1a (patch)
treef0406c6939724ae843a85bcf139bf41ed523ac02 /devel/pear
parent5e78c3b937160f5b938427e81884188b39f9db9c (diff)
downloadports-d0f6b75a0a5a620cb27e414a19db99de0d81de1a.tar.gz
ports-d0f6b75a0a5a620cb27e414a19db99de0d81de1a.zip
Notes
Diffstat (limited to 'devel/pear')
-rw-r--r--devel/pear/Makefile12
-rw-r--r--devel/pear/distinfo6
-rw-r--r--devel/pear/files/patch-go-pear28
-rw-r--r--devel/pear/pkg-plist6
4 files changed, 34 insertions, 18 deletions
diff --git a/devel/pear/Makefile b/devel/pear/Makefile
index 0c44f1c7fea0..bd761dbe7336 100644
--- a/devel/pear/Makefile
+++ b/devel/pear/Makefile
@@ -6,9 +6,10 @@
#
PORTNAME= pear
-PORTVERSION= 1.9.0
+PORTVERSION= 1.9.1
CATEGORIES= devel
-MASTER_SITES= http://freebsd.unixfreunde.de/sources/
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= mm
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR framework for PHP
@@ -22,10 +23,13 @@ USE_PHP= pcre xml
PEARDIR= ${PREFIX}/share/pear
post-patch:
- @${REINPLACE_CMD} "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/go-pear
+ @${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" \
+ -e "s|%%BUNDLEDIR%%|${WRKSRC}/go-pear-bundle|" \
+ -e "s|%%TMPDIR%%|${TMPDIR}/go-pear|" \
+ ${WRKSRC}/go-pear
do-install:
- @${LOCALBASE}/bin/php -q ${WRKSRC}/go-pear
+ @cd ${WRKSRC} && ${LOCALBASE}/bin/php -q ./go-pear
@${SED} -i "" "s|<?php|<?php dl('pcre.so'); dl('xml.so');|" \
${PEARDIR}/peclcmd.php
diff --git a/devel/pear/distinfo b/devel/pear/distinfo
index 761a98a0e992..5179fa4b351e 100644
--- a/devel/pear/distinfo
+++ b/devel/pear/distinfo
@@ -1,3 +1,3 @@
-MD5 (pear-1.9.0.tar.bz2) = 669de1c6558d9ece26747acba248dd22
-SHA256 (pear-1.9.0.tar.bz2) = 71302e423ca215d8881fcda4e4640b1e0289a8716a4c3a6e99679260710b5b69
-SIZE (pear-1.9.0.tar.bz2) = 310681
+MD5 (pear-1.9.1.tar.bz2) = d057053f4f3cb9380593c17b85feab91
+SHA256 (pear-1.9.1.tar.bz2) = f1ee28f797ba02ad688e362488efdf7f8993c06b251cab896ecf510cae0e6cec
+SIZE (pear-1.9.1.tar.bz2) = 325597
diff --git a/devel/pear/files/patch-go-pear b/devel/pear/files/patch-go-pear
index ee0cd5100d60..3e33a11a2e8c 100644
--- a/devel/pear/files/patch-go-pear
+++ b/devel/pear/files/patch-go-pear
@@ -1,5 +1,5 @@
---- go-pear.orig 2009-04-08 12:20:28.000000000 +0200
-+++ go-pear 2009-04-26 20:51:39.000000000 +0200
+--- go-pear.orig 2010-08-05 23:26:55.000000000 +0200
++++ go-pear 2010-08-13 15:05:29.753811744 +0200
@@ -116,7 +116,7 @@
);
@@ -54,7 +54,7 @@
if (!WEBINSTALLER) {
$msg = "The following PEAR packages are bundled with PHP: " .
implode(', ', array_keys($pfc_packages));
-@@ -571,7 +571,7 @@
+@@ -571,17 +571,17 @@
$install_optional_packages = array();
print "\n";
}
@@ -63,9 +63,13 @@
####
# Download
####
-@@ -581,7 +581,7 @@
+
+ if (function_exists('set_include_path')) {
+- set_include_path($ptmp);
++ set_include_path($ptmp . PATH_SEPARATOR . "%%BUNDLEDIR%%");
} else {
- ini_set('include_path', $ptmp);
+- ini_set('include_path', $ptmp);
++ ini_set('include_path', $ptmp . PATH_SEPARATOR . "%%BUNDLEDIR%%");
}
-
+/*
@@ -94,6 +98,18 @@
}
// gopear_bundle usage
+@@ -655,9 +656,9 @@
+ if ($nobootstrap) {
+ print('Using previously install ... ');
+ if (function_exists('set_include_path')) {
+- set_include_path($php_dir);
++ set_include_path($php_dir . PATH_SEPARATOR . "%%BUNDLEDIR%%");
+ } else {
+- ini_set('include_path', $php_dir);
++ ini_set('include_path', $php_dir . PATH_SEPARATOR . "%%BUNDLEDIR%%");
+ }
+ include_once 'PEAR.php';
+ print "ok\n";
@@ -750,7 +751,7 @@
if (WEBINSTALLER || isset($_SERVER['argv'][1]) && $_SERVER['argv'][1] == 'local') {
$config = &PEAR_Config::singleton($prefix."/pear.conf", '');
@@ -140,7 +156,7 @@
$test_dir = '$php_dir/tests';
- $temp_dir = '$prefix/temp';
-
-+ $temp_dir = '/tmp/go-pear';
++ $temp_dir = '%%TMPDIR%%';
+/*
// check if the user has installed PHP with PHP or GNU layout
if (@is_dir("$prefix/lib/php/.registry")) {
diff --git a/devel/pear/pkg-plist b/devel/pear/pkg-plist
index 9da5a80692ee..2d493a9b2bbd 100644
--- a/devel/pear/pkg-plist
+++ b/devel/pear/pkg-plist
@@ -143,13 +143,9 @@ etc/pear.conf
%%DATADIR%%/data/PEAR/package.dtd
%%DATADIR%%/data/PEAR/template.spec
%%DATADIR%%/data/Structures_Graph/LICENSE
-%%DATADIR%%/data/Structures_Graph/genpackage.xml.pl
-%%DATADIR%%/data/Structures_Graph/package.sh
-%%DATADIR%%/data/Structures_Graph/publish.sh
%%DATADIR%%/pearcmd.php
%%DATADIR%%/peclcmd.php
-%%DATADIR%%/tests/Structures_Graph/tests/README
-%%DATADIR%%/tests/Structures_Graph/tests/all-tests.php
+%%DATADIR%%/tests/Structures_Graph/tests/AllTests.php
%%DATADIR%%/tests/Structures_Graph/tests/testCase/BasicGraph.php
@dirrm %%DOCSDIR%%/Archive_Tar/docs
@dirrm %%DOCSDIR%%/Archive_Tar