aboutsummaryrefslogtreecommitdiff
path: root/devel/pecl-bbcode/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-08-23 14:44:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-08-23 14:44:05 +0000
commit1f974718b688af1a299067b79c650f4645a7c4fb (patch)
tree8365be66a34c5d367188d660e4fc87851702be12 /devel/pecl-bbcode/Makefile
parentb29e1e3c4a39c165e90092c606dea1f82ab8884e (diff)
downloadports-1f974718b688af1a299067b79c650f4645a7c4fb.tar.gz
ports-1f974718b688af1a299067b79c650f4645a7c4fb.zip
Notes
Diffstat (limited to 'devel/pecl-bbcode/Makefile')
-rw-r--r--devel/pecl-bbcode/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/pecl-bbcode/Makefile b/devel/pecl-bbcode/Makefile
new file mode 100644
index 000000000000..cc9f93a91a42
--- /dev/null
+++ b/devel/pecl-bbcode/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pecl-bbcode
+# Date created: 6 Aug 2007
+# Whom: Ditesh Shashikant Gathani <ditesh@gathani.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bbcode
+PORTVERSION= 0.9.1
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= ditesh@gathani.org
+COMMENT= A PECL extension which allows quick and efficient BBCode Parsing
+
+USE_PHP= yes
+USE_PHP_BUILD= yes
+USE_PHPEXT= yes
+
+CONFIGURE_ARGS= --enable-bbcode
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/#include <malloc.h>/\/\/#include <malloc.h>/g' ${WRKSRC}/lib/stacklib.c
+ @${REINPLACE_CMD} -e 's/#include <malloc.h>/\/\/#include <malloc.h>/g' ${WRKSRC}/lib/bbcode.c
+
+.include <bsd.port.mk>