aboutsummaryrefslogtreecommitdiff
path: root/devel/pecl-operator
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-01-31 16:16:41 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-01-31 16:16:41 +0000
commit512cfafdf3470826a247bd1dd05c832995c9e1a7 (patch)
treeb87894368d0f13d1092657bf04bda060e50ada27 /devel/pecl-operator
parent0fb6df4d57cfec1db762de8bf7be963a260843ec (diff)
downloadports-512cfafdf3470826a247bd1dd05c832995c9e1a7.tar.gz
ports-512cfafdf3470826a247bd1dd05c832995c9e1a7.zip
Notes
Diffstat (limited to 'devel/pecl-operator')
-rw-r--r--devel/pecl-operator/Makefile26
-rw-r--r--devel/pecl-operator/distinfo3
-rw-r--r--devel/pecl-operator/pkg-descr5
3 files changed, 34 insertions, 0 deletions
diff --git a/devel/pecl-operator/Makefile b/devel/pecl-operator/Makefile
new file mode 100644
index 000000000000..012319bc4a6b
--- /dev/null
+++ b/devel/pecl-operator/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-operator
+# Date created: 2006-01-31
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= operator
+PORTVERSION= 0.2
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= operator-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= PHP extension that provides operator overloading for PHP objects
+
+USE_PHP= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER= 5
+BROKEN_WITH_PHP= 4
+PHP_MODNAME= ${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-operator/distinfo b/devel/pecl-operator/distinfo
new file mode 100644
index 000000000000..dbf1c2c14d5a
--- /dev/null
+++ b/devel/pecl-operator/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/operator-0.2.tgz) = 301ee9558ad86c2d37fffddb1a1697f2
+SHA256 (PECL/operator-0.2.tgz) = 3ea5aba5ad9e0d81e670dfdb73cc429c8a456a4d73f33e3a9c6ce29593dd58c0
+SIZE (PECL/operator-0.2.tgz) = 6325
diff --git a/devel/pecl-operator/pkg-descr b/devel/pecl-operator/pkg-descr
new file mode 100644
index 000000000000..cf8538c07f1b
--- /dev/null
+++ b/devel/pecl-operator/pkg-descr
@@ -0,0 +1,5 @@
+PHP PECL extension provides possibility to overload operators for PHP objects.
+At the moment it allows overloading of the following operators:
++ - * / % << >> . | & ^ ~ ! ++ -- += -= *= /= %= <<= >>= .= |= &= ^= and ~=
+
+WWW: http://pecl.php.net/package/operator