aboutsummaryrefslogtreecommitdiff
path: root/devel/php-Net_Gearman
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2008-01-24 02:19:01 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2008-01-24 02:19:01 +0000
commitcf573ca6cb1404eb1c4ac264032519c242a51be9 (patch)
tree476cf32fff9a2755d854ec9276454e6cb3062bb7 /devel/php-Net_Gearman
parent3f97fd9e66cd67e742614af564765896a096ff30 (diff)
downloadports-cf573ca6cb1404eb1c4ac264032519c242a51be9.tar.gz
ports-cf573ca6cb1404eb1c4ac264032519c242a51be9.zip
Notes
Diffstat (limited to 'devel/php-Net_Gearman')
-rw-r--r--devel/php-Net_Gearman/Makefile29
-rw-r--r--devel/php-Net_Gearman/distinfo3
-rw-r--r--devel/php-Net_Gearman/pkg-descr3
-rw-r--r--devel/php-Net_Gearman/pkg-plist19
4 files changed, 54 insertions, 0 deletions
diff --git a/devel/php-Net_Gearman/Makefile b/devel/php-Net_Gearman/Makefile
new file mode 100644
index 000000000000..b56b64327297
--- /dev/null
+++ b/devel/php-Net_Gearman/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: php-Net_Gearman
+# Date created: 2008-01-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net_Gearman
+PORTVERSION= 0.0.4
+CATEGORIES= devel
+MASTER_SITES= http://bugs.joestump.net/code/Net_Gearman/
+PKGNAMEPREFIX= php-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Gearman client libraray for PHP
+
+RUN_DEPENDS= ${LOCALBASE}/share/pear/PEAR.php:${PORTSDIR}/devel/pear
+
+NO_BUILD= yes
+USE_PHP= yes
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${CP} -R ${WRKSRC}/Net ${DATADIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/php-Net_Gearman/distinfo b/devel/php-Net_Gearman/distinfo
new file mode 100644
index 000000000000..480afd7ec7e0
--- /dev/null
+++ b/devel/php-Net_Gearman/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net_Gearman-0.0.4.tgz) = 9fc7b44f73de44b565ac70bf7cfb3fc5
+SHA256 (Net_Gearman-0.0.4.tgz) = 446adc1152241afd62f4baaf9aa686657a277c010114f9a459bfabef3d94c5d1
+SIZE (Net_Gearman-0.0.4.tgz) = 12508
diff --git a/devel/php-Net_Gearman/pkg-descr b/devel/php-Net_Gearman/pkg-descr
new file mode 100644
index 000000000000..21326eee050f
--- /dev/null
+++ b/devel/php-Net_Gearman/pkg-descr
@@ -0,0 +1,3 @@
+Gearman client libraray for PHP.
+
+WWW: http://bugs.joestump.net/code/Net_Gearman/
diff --git a/devel/php-Net_Gearman/pkg-plist b/devel/php-Net_Gearman/pkg-plist
new file mode 100644
index 000000000000..a321a5a61f86
--- /dev/null
+++ b/devel/php-Net_Gearman/pkg-plist
@@ -0,0 +1,19 @@
+@comment $FreeBSD$
+%%DATADIR%%/Net/Gearman/Client.php
+%%DATADIR%%/Net/Gearman/Connection.php
+%%DATADIR%%/Net/Gearman/Exception.php
+%%DATADIR%%/Net/Gearman/Job.php
+%%DATADIR%%/Net/Gearman/Job/Common.php
+%%DATADIR%%/Net/Gearman/Job/Exception.php
+%%DATADIR%%/Net/Gearman/Set.php
+%%DATADIR%%/Net/Gearman/Task.php
+%%DATADIR%%/Net/Gearman/Worker.php
+%%EXAMPLESDIR%%/SQL.php
+%%EXAMPLESDIR%%/Sum.php
+%%EXAMPLESDIR%%/tasks.php
+%%EXAMPLESDIR%%/worker.php
+@dirrmtry %%EXAMPLESDIR%%
+@dirrmtry %%DATADIR%%/Net/Gearman/Job
+@dirrmtry %%DATADIR%%/Net/Gearman
+@dirrmtry %%DATADIR%%/Net
+@dirrmtry %%DATADIR%%