aboutsummaryrefslogtreecommitdiff
path: root/devel/php5-thrift
diff options
context:
space:
mode:
authorDaichi GOTO <daichi@FreeBSD.org>2010-10-07 15:45:18 +0000
committerDaichi GOTO <daichi@FreeBSD.org>2010-10-07 15:45:18 +0000
commit200e8f4b865ec4118600660c190b221a4e8b5e04 (patch)
treeed68949f6bd682d7d1b79679d1ea06dbaa8fff87 /devel/php5-thrift
parent7bef8b9e2669fd956764d849c15b632cbe8f631e (diff)
Notes
Diffstat (limited to 'devel/php5-thrift')
-rw-r--r--devel/php5-thrift/Makefile29
-rw-r--r--devel/php5-thrift/files/patch-php_thrift_protocol.cpp20
-rw-r--r--devel/php5-thrift/pkg-descr3
3 files changed, 52 insertions, 0 deletions
diff --git a/devel/php5-thrift/Makefile b/devel/php5-thrift/Makefile
new file mode 100644
index 000000000000..87ccad8ea7bf
--- /dev/null
+++ b/devel/php5-thrift/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: thrift
+# Date created: Sat May 8 12:33:05 MSD 2010
+# Whom: Ilya Bakulin <webmaster@kibab.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= thrift
+PORTVERSION= 0.2.0
+CATEGORIES= devel
+PKGNAMEPREFIX= php5-
+DISTFILES=
+
+MAINTAINER= webmaster@kibab.com
+COMMENT= PHP interface to Thrift
+
+EXTRACT_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/devel/thrift:extract
+
+USE_PHP=yes
+USE_PHPIZE=yes
+USE_PHPEXT=yes
+PHP_MODNAME=thrift_protocol
+
+WRKSRC=${WRKDIR}/php/src/ext/thrift_protocol
+
+post-extract:
+ ${LN} -sfh \
+ `cd ${PORTSDIR}/devel/thrift && ${MAKE} -V WRKSRC`/lib/php ${WRKDIR}
+.include <bsd.port.mk>
diff --git a/devel/php5-thrift/files/patch-php_thrift_protocol.cpp b/devel/php5-thrift/files/patch-php_thrift_protocol.cpp
new file mode 100644
index 000000000000..fe2070718774
--- /dev/null
+++ b/devel/php5-thrift/files/patch-php_thrift_protocol.cpp
@@ -0,0 +1,20 @@
+--- php_thrift_protocol.cpp 2010-04-23 17:28:32.000000000 +0400
++++ php_thrift_protocol.cpp 2010-04-23 17:29:32.000000000 +0400
+@@ -24,8 +24,7 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <unistd.h>
+-#include <endian.h>
+-#include <byteswap.h>
++#include <machine/endian.h>
+ #include <stdexcept>
+
+ #if __BYTE_ORDER == __LITTLE_ENDIAN
+@@ -36,6 +35,7 @@
+ #define ntohll(x) x
+ #endif
+
++#define bswap_64 __bswap64
+ enum TType {
+ T_STOP = 0,
+ T_VOID = 1,
diff --git a/devel/php5-thrift/pkg-descr b/devel/php5-thrift/pkg-descr
new file mode 100644
index 000000000000..4ac1606c6ef2
--- /dev/null
+++ b/devel/php5-thrift/pkg-descr
@@ -0,0 +1,3 @@
+PHP interface to Thrift.
+
+WWW: http://developers.facebook.com/thrift/