aboutsummaryrefslogtreecommitdiff
path: root/devel/php52-pcre
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2010-04-23 15:21:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2010-04-23 15:21:26 +0000
commit90dfbebfc83fb5b22bf9b6d32f81055d2b55aa2e (patch)
treefedfd024d2cf153b431fd840577805ec90d70c08 /devel/php52-pcre
parent3acf4c24e29e32e82f673183e1acb3f78d002d62 (diff)
- PHP 5.2 slave port
PR: 145772 Submitted by: Alex Keda
Notes
Notes: svn path=/head/; revision=253097
Diffstat (limited to 'devel/php52-pcre')
-rw-r--r--devel/php52-pcre/Makefile14
-rw-r--r--devel/php52-pcre/files/patch-php_pcre.c13
2 files changed, 27 insertions, 0 deletions
diff --git a/devel/php52-pcre/Makefile b/devel/php52-pcre/Makefile
new file mode 100644
index 000000000000..8f7de55fe7bc
--- /dev/null
+++ b/devel/php52-pcre/Makefile
@@ -0,0 +1,14 @@
+# New ports collection makefile for: php52-pcre
+# Date created: 17 Apr 2010
+# Whom: Alex Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+CATEGORIES= devel
+
+MASTERDIR= ${.CURDIR}/../../lang/php52
+
+PKGNAMESUFFIX= -pcre
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/php52-pcre/files/patch-php_pcre.c b/devel/php52-pcre/files/patch-php_pcre.c
new file mode 100644
index 000000000000..4cab8e3aefaf
--- /dev/null
+++ b/devel/php52-pcre/files/patch-php_pcre.c
@@ -0,0 +1,13 @@
+--- php_pcre.c.orig 2009-03-06 10:58:43.000000000 +0100
++++ php_pcre.c 2009-03-06 10:58:56.000000000 +0100
+@@ -18,6 +18,10 @@
+
+ /* $Id: php_pcre.c,v 1.168.2.9.2.30 2009/01/13 19:23:31 andrei Exp $ */
+
++#ifdef HAVE_CONFIG_H
++#include "config.h"
++#endif
++
+ #include "php.h"
+ #include "php_ini.h"
+ #include "php_globals.h"