aboutsummaryrefslogtreecommitdiff
path: root/devel/physfs-devel/Makefile
diff options
context:
space:
mode:
authorOliver Lehmann <oliver@FreeBSD.org>2007-04-05 04:44:24 +0000
committerOliver Lehmann <oliver@FreeBSD.org>2007-04-05 04:44:24 +0000
commitfbea64084cfbba2de674b3a504cff6df51c9abd4 (patch)
tree9c793e8bc34e2a9adc57e94f5eb2f4738e4a0702 /devel/physfs-devel/Makefile
parentd63ccd4d3e1b3d40390078802716e47c3598055c (diff)
downloadports-fbea64084cfbba2de674b3a504cff6df51c9abd4.tar.gz
ports-fbea64084cfbba2de674b3a504cff6df51c9abd4.zip
Notes
Diffstat (limited to 'devel/physfs-devel/Makefile')
-rw-r--r--devel/physfs-devel/Makefile36
1 files changed, 28 insertions, 8 deletions
diff --git a/devel/physfs-devel/Makefile b/devel/physfs-devel/Makefile
index 4c1ba99c9b17..fac9e730acd5 100644
--- a/devel/physfs-devel/Makefile
+++ b/devel/physfs-devel/Makefile
@@ -6,22 +6,42 @@
#
PORTNAME= physfs
-PORTVERSION= 1.1.0
-PORTREVISION= 1
+PORTVERSION= 1.1.1
+PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= http://offload1.icculus.org/${PORTNAME}/downloads/
MAINTAINER= oliver@FreeBSD.org
COMMENT= A library to provide abstract access to various archives
-USE_GNOME= gnometarget
-#GNU_CONFIGURE= yes
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING=Release \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX}
+
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
NO_LATEST_LINK= yes
+patch-autotools:
+ @${DO_NADA}
+
post-patch:
- @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g ; \
- s|-D_REENTRANT -D_THREAD_SAFE|${PTHREAD_CFLAGS}|g' \
- ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|CHECK_INCLUDE_FILE(sys/ucred.h HAVE_UCRED_H|& "-include sys/param.h"|g; \
+ s|CHECK_INCLUDE_FILE(readline/readline.h HAVE_READLINE_H|& "-include stdio.h"|g; \
+ s|CHECK_INCLUDE_FILE(readline/history.h HAVE_HISTORY_H|& "-include stdio.h"|g; \
+ s|CHECK_LIBRARY_EXISTS("readline" "history.*|SET(HAVE_LIBHISTORY TRUE)|g; \
+ s|" " \(readline curses\)|\1|' ${WRKSRC}/CMakeLists.txt
+
+ @${REINPLACE_CMD} -e 's|define SIZEOF_INT |&9999|g' \
+ ${WRKSRC}/platform/unix.c
+
+do-configure::
+ @(cd ${WRKSRC}; \
+ ${LOCALBASE}/bin/cmake ${CMAKE_ARGS} ${PATCH_WRKSRC})
+
.include <bsd.port.mk>