aboutsummaryrefslogtreecommitdiff
path: root/devel/picp/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-12 01:39:37 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-12 01:39:37 +0000
commit40b5b64326bd109abdc45b2ef806cfc2658c4533 (patch)
tree113a67d6029fecc00197af071a79f72d5529c38c /devel/picp/Makefile
parentd0a2eae9385dcd9b41dca440a4b617c9a45e08ba (diff)
downloadports-40b5b64326bd109abdc45b2ef806cfc2658c4533.tar.gz
ports-40b5b64326bd109abdc45b2ef806cfc2658c4533.zip
Notes
Diffstat (limited to 'devel/picp/Makefile')
-rw-r--r--devel/picp/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/devel/picp/Makefile b/devel/picp/Makefile
new file mode 100644
index 000000000000..0a33494b022a
--- /dev/null
+++ b/devel/picp/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: picp
+# Date created: 25 October 2002
+# Whom: Bruce M Simpson <bms@spc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= picp
+PORTVERSION= 0.4
+CATEGORIES= devel
+MASTER_SITES= http://bofh.stabilis.ru/
+DISTNAME= ${PORTNAME}_fbsd
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= bms@spc.org
+COMMENT= Driver for the Microchip Picstart Plus development programmer
+
+USE_REINPLACE= yes
+NO_WRKSUBDIR= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,CC=,CC?=,' -e 's,-O2,,' \
+ -e 's,CFLAGS=,CFLAGS+=,' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKDIR}/picp ${PREFIX}/bin
+
+.include <bsd.port.mk>