aboutsummaryrefslogtreecommitdiff
path: root/devel/piklab/Makefile
diff options
context:
space:
mode:
authorSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-24 23:46:49 +0000
committerSylvio Cesar Teixeira <sylvio@FreeBSD.org>2012-06-24 23:46:49 +0000
commit918fae7abbac7655bdeb4f226518ed3655e25c19 (patch)
treeeec41c4e08783b77601f6f8fdd78b926dc65d6f8 /devel/piklab/Makefile
parentb9873c0bcfb9f6d3036808c022cb7151d242018f (diff)
downloadports-918fae7abbac7655bdeb4f226518ed3655e25c19.tar.gz
ports-918fae7abbac7655bdeb4f226518ed3655e25c19.zip
Notes
Diffstat (limited to 'devel/piklab/Makefile')
-rw-r--r--devel/piklab/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/devel/piklab/Makefile b/devel/piklab/Makefile
index 217d5fb987b5..fba1b3b92942 100644
--- a/devel/piklab/Makefile
+++ b/devel/piklab/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= piklab
-PORTVERSION= 0.15.10
-PORTREVISION= 2
+PORTVERSION= 0.16.0
CATEGORIES= devel
-MASTER_SITES= SF/${PORTNAME}/newest%20release/${PORTVERSION}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= KDE IDE for microcontroller development
@@ -18,7 +17,9 @@ LICENSE= GPLv2 # (or later)
LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
-USE_KDELIBS_VER=3
+USE_QT4= corelib gui qt3support qtestlib xml \
+ moc_build qmake_build rcc_build uic_build
+USE_KDE4= automoc4 kdehier kdelibs kdeprefix sharedmime
USE_GETTEXT= yes
USE_CMAKE= yes
INSTALLS_ICONS= yes
@@ -40,6 +41,9 @@ post-patch:
@${REINPLACE_CMD} -e \
'/install/s|^|#|' ${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e \
+ '/CMAKE_BUILD_TYPE/s|^|#| ; \
+ /KDE4/s|INCLUDE_DIRS|INCLUDES|' ${WRKSRC}/cmake/Piklab.cmake
+ @${REINPLACE_CMD} -e \
'/install/s|share/man|man|' ${WRKSRC}/man/CMakeLists.txt
.include <bsd.port.post.mk>