aboutsummaryrefslogtreecommitdiff
path: root/devel/pipestatus/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2008-01-26 01:55:53 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2008-01-26 01:55:53 +0000
commit8ac065d74ddca7c55d5d6a05e912e84a4face90c (patch)
tree3e7880e03a9bc7270f6346068a20be0e860d4de1 /devel/pipestatus/Makefile
parentc51999e38243e4697e2dbebcf06c627999c3398d (diff)
Notes
Diffstat (limited to 'devel/pipestatus/Makefile')
-rw-r--r--devel/pipestatus/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/pipestatus/Makefile b/devel/pipestatus/Makefile
new file mode 100644
index 000000000000..3ba8676d50b3
--- /dev/null
+++ b/devel/pipestatus/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pipestatus
+# Date created: 2008/01/26
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= pipestatus
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+MASTER_SITES= SF
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= UNIX/POSIX shell helper for running pipes safely
+
+NO_BUILD= yes
+
+PLIST_FILES= bin/pipestatus
+.if !defined(NOPORTDOCS)
+PLIST_DIRS= ${DOCSDIR_REL}
+PLIST_FILES+= ${DOCSDIR_REL}/README \
+ ${DOCSDIR_REL}/NEWS
+.endif
+DOCS= README NEWS
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/pipestatus ${DESTDIR}${PREFIX}/bin/
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for doc in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>