aboutsummaryrefslogtreecommitdiff
path: root/devel/pkg-config
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2008-03-24 03:52:36 +0000
commit6f32add9a75efb180e462ffbdb0b080bc88088e3 (patch)
tree0fc7af36e22fc0dc7c1dc8aacabf6fe117e881da /devel/pkg-config
parentb8d245fedd5842fb6d68d0bdc6539885555a84e3 (diff)
downloadports-6f32add9a75efb180e462ffbdb0b080bc88088e3.tar.gz
ports-6f32add9a75efb180e462ffbdb0b080bc88088e3.zip
Notes
Diffstat (limited to 'devel/pkg-config')
-rw-r--r--devel/pkg-config/Makefile4
-rw-r--r--devel/pkg-config/distinfo6
-rw-r--r--devel/pkg-config/files/patch-glib-1.2.10_Makefile.in (renamed from devel/pkg-config/files/patch-glib-1.2.8::Makefile.in)4
-rw-r--r--devel/pkg-config/files/patch-pkg.c14
-rw-r--r--devel/pkg-config/files/patch-pkg_conflicts29
5 files changed, 21 insertions, 36 deletions
diff --git a/devel/pkg-config/Makefile b/devel/pkg-config/Makefile
index b3cff746a453..e883ac0d75cf 100644
--- a/devel/pkg-config/Makefile
+++ b/devel/pkg-config/Makefile
@@ -3,11 +3,11 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/pkg-config/Makefile,v 1.9 2007/07/01 20:46:42 mezz Exp $
+# $MCom: ports/devel/pkg-config/Makefile,v 1.12 2008/02/04 19:22:00 mezz Exp $
#
PORTNAME= pkg-config
-PORTVERSION= 0.22
+PORTVERSION= 0.23
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://pkgconfig.freedesktop.org/releases/
diff --git a/devel/pkg-config/distinfo b/devel/pkg-config/distinfo
index 9e0e9994a30e..459710f196c9 100644
--- a/devel/pkg-config/distinfo
+++ b/devel/pkg-config/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/pkg-config-0.22.tar.gz) = fd5c547e9d66ba49bc735ccb8c791f2a
-SHA256 (gnome2/pkg-config-0.22.tar.gz) = 7e0761b47d604847006e7c6caa9b9cf044530a516ff84395450edcfa3c2febe6
-SIZE (gnome2/pkg-config-0.22.tar.gz) = 1006425
+MD5 (gnome2/pkg-config-0.23.tar.gz) = d922a88782b64441d06547632fd85744
+SHA256 (gnome2/pkg-config-0.23.tar.gz) = 08a0e072d6a05419a58124db864f0685e6ac96e71b2875bf15ac12714e983b53
+SIZE (gnome2/pkg-config-0.23.tar.gz) = 1032839
diff --git a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in b/devel/pkg-config/files/patch-glib-1.2.10_Makefile.in
index 330415ed6f92..0031087c84c1 100644
--- a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
+++ b/devel/pkg-config/files/patch-glib-1.2.10_Makefile.in
@@ -1,5 +1,5 @@
---- glib-1.2.8/Makefile.in.orig Tue Apr 12 13:51:56 2005
-+++ glib-1.2.8/Makefile.in Tue Apr 12 13:52:41 2005
+--- glib-1.2.10/Makefile.in.orig Tue Apr 12 13:51:56 2005
++++ glib-1.2.10/Makefile.in Tue Apr 12 13:52:41 2005
@@ -727,7 +727,6 @@
installdirs-am:
diff --git a/devel/pkg-config/files/patch-pkg.c b/devel/pkg-config/files/patch-pkg.c
new file mode 100644
index 000000000000..48315feb9589
--- /dev/null
+++ b/devel/pkg-config/files/patch-pkg.c
@@ -0,0 +1,14 @@
+diff -Naur pkg-config-0.23-old/pkg.c pkg-config-0.23-new/pkg.c
+--- pkg-config-0.23-old/pkg.c 2008-01-16 13:59:49.000000000 -0800
++++ pkg.c 2008-01-22 15:00:55.000000000 -0800
+@@ -483,6 +483,10 @@
+ g_string_append (str, pcsysrootdir);
+ g_string_append (str, tmpstr+2);
+ }
++ else
++ {
++ g_string_append (str, tmpstr);
++ }
+ }
+ else
+ {
diff --git a/devel/pkg-config/files/patch-pkg_conflicts b/devel/pkg-config/files/patch-pkg_conflicts
deleted file mode 100644
index 471fd02b24bc..000000000000
--- a/devel/pkg-config/files/patch-pkg_conflicts
+++ /dev/null
@@ -1,29 +0,0 @@
-diff -up pkg-config-0.22/pkg.c.conflicts pkg-config-0.22/pkg.c
---- pkg.c.conflicts 2007-11-15 23:56:26.000000000 -0500
-+++ pkg.c 2007-11-15 23:57:26.000000000 -0500
-@@ -821,7 +821,7 @@ verify_package (Package *pkg)
- */
-
- recursive_fill_list (pkg, get_requires_private, &requires);
-- recursive_fill_list (pkg, get_conflicts, &conflicts);
-+ conflicts = get_conflicts (pkg);
-
- requires_iter = requires;
- while (requires_iter != NULL)
-@@ -843,7 +843,7 @@ verify_package (Package *pkg)
- req->version, req->name,
- ver->name,
- comparison_to_str (ver->comparison),
-- ver->version,
-+ ver->version ? ver->version : "(any)",
- ver->owner->name,
- ver->owner->version);
-
-@@ -857,7 +857,6 @@ verify_package (Package *pkg)
- }
-
- g_slist_free (requires);
-- g_slist_free (conflicts);
-
- /* We make a list of system directories that gcc expects so we can remove
- * them.