aboutsummaryrefslogtreecommitdiff
path: root/devel/pkg-config
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2005-04-12 18:12:12 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2005-04-12 18:12:12 +0000
commit1cb9690b6f33cb20d3f7e4cc29f825c03a44db38 (patch)
tree9f5c0b64480c89554d4685309360c907b6f9a248 /devel/pkg-config
parentaef053e11b6f43794b5d2768304fc3e9fb98e99c (diff)
downloadports-1cb9690b6f33cb20d3f7e4cc29f825c03a44db38.tar.gz
ports-1cb9690b6f33cb20d3f7e4cc29f825c03a44db38.zip
Notes
Diffstat (limited to 'devel/pkg-config')
-rw-r--r--devel/pkg-config/Makefile20
-rw-r--r--devel/pkg-config/distinfo4
-rw-r--r--devel/pkg-config/files/patch-Makefile.in22
-rw-r--r--devel/pkg-config/files/patch-glib-1.2.8::Makefile.in20
-rw-r--r--devel/pkg-config/files/patch-ltmain.sh28
-rw-r--r--devel/pkg-config/files/patch-pkg.c21
6 files changed, 30 insertions, 85 deletions
diff --git a/devel/pkg-config/Makefile b/devel/pkg-config/Makefile
index 67d682b91141..140a0a6d183c 100644
--- a/devel/pkg-config/Makefile
+++ b/devel/pkg-config/Makefile
@@ -6,28 +6,28 @@
#
PORTNAME= pkgconfig
-PORTVERSION= 0.15.0
-PORTREVISION= 1
+PORTVERSION= 0.17
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.15
+MASTER_SITES= http://pkgconfig.freedesktop.org/releases/
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A utility used to retrieve information about installed libraries
+COMMENT= A utility to retrieve information about installed libraries
-USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 13
+USE_LIBTOOL_VER=15
LIBTOOLFILES= glib-1.2.8/configure
LIBTOOLFLAGS= --disable-ltlibs \
--disable-shared
-CONFIGURE_ARGS= --disable-threads
-MAKE_ENV= PKGCONF_BUILD=yes
MAN1= pkg-config.1
+.include <bsd.port.pre.mk>
+
+CONFIGURE_ARGS= --disable-threads \
+ --with-pc-path="${PREFIX}/libdata/pkgconfig:${LOCALBASE}/libdata/pkgconfig:${X11BASE}/libdata/pkgconfig"
+
post-install:
${MKDIR} ${PREFIX}/libdata/pkgconfig
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/pkg-config/distinfo b/devel/pkg-config/distinfo
index 3bb73d9ed973..40381c4b0b0e 100644
--- a/devel/pkg-config/distinfo
+++ b/devel/pkg-config/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/pkgconfig-0.15.0.tar.bz2) = 8e3f44717a76069fcc8fdae9c252369b
-SIZE (gnome2/pkgconfig-0.15.0.tar.bz2) = 490351
+MD5 (gnome2/pkgconfig-0.17.tar.gz) = a7d9844b3d89af68388f9fa996634322
+SIZE (gnome2/pkgconfig-0.17.tar.gz) = 964339
diff --git a/devel/pkg-config/files/patch-Makefile.in b/devel/pkg-config/files/patch-Makefile.in
index c0e58c620757..2e7c1f405751 100644
--- a/devel/pkg-config/files/patch-Makefile.in
+++ b/devel/pkg-config/files/patch-Makefile.in
@@ -1,23 +1,11 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Sun Feb 3 20:23:27 2002
-+++ Makefile.in Thu Feb 7 11:46:04 2002
-@@ -35,7 +35,7 @@
- DESTDIR =
-
+--- Makefile.in.orig Tue Apr 12 13:47:14 2005
++++ Makefile.in Tue Apr 12 13:48:21 2005
+@@ -18,7 +18,7 @@
+ top_srcdir = @top_srcdir@
+ VPATH = @srcdir@
pkgdatadir = $(datadir)/@PACKAGE@
-pkglibdir = $(libdir)/@PACKAGE@
+pkglibdir = $(prefix)/libdata/@PACKAGE@
pkgincludedir = $(includedir)/@PACKAGE@
-
top_builddir = .
-@@ -91,7 +91,7 @@
-
- bin_PROGRAMS = pkg-config
-
--INCLUDES = -DPKGLIBDIR="\"$(pkglibdir)\"" $(included_glib_includes)
-+INCLUDES = -DPKGLIBDIR="\"$(pkglibdir)\"" -DXPKGLIBDIR="\"$(X11BASE)/libdata/@PACKAGE@\"" -DLPKGLIBDIR="\"$(LOCALBASE)/libdata/@PACKAGE@\"" $(included_glib_includes)
- pkg_config_SOURCES = \
- pkg.h \
diff --git a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in b/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
index f789c923658a..330415ed6f92 100644
--- a/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
+++ b/devel/pkg-config/files/patch-glib-1.2.8::Makefile.in
@@ -1,14 +1,10 @@
-
-$FreeBSD$
-
---- glib-1.2.8/Makefile.in.orig Thu Jul 12 03:45:31 2001
-+++ glib-1.2.8/Makefile.in Wed Aug 1 10:42:44 2001
-@@ -501,7 +501,7 @@
+--- glib-1.2.8/Makefile.in.orig Tue Apr 12 13:51:56 2005
++++ glib-1.2.8/Makefile.in Tue Apr 12 13:52:41 2005
+@@ -727,7 +727,6 @@
+ installdirs-am:
- install-am: all-am
- @$(MAKE) $(AM_MAKEFLAGS) install-exec-am install-data-am
--install: install-recursive
-+install:
- uninstall-am:
+ install: $(BUILT_SOURCES)
+- $(MAKE) $(AM_MAKEFLAGS) install-recursive
+ install-exec: install-exec-recursive
+ install-data: install-data-recursive
uninstall: uninstall-recursive
- all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS) $(DATA) \
diff --git a/devel/pkg-config/files/patch-ltmain.sh b/devel/pkg-config/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/devel/pkg-config/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/pkg-config/files/patch-pkg.c b/devel/pkg-config/files/patch-pkg.c
index f928ebc29910..79606e24f0a8 100644
--- a/devel/pkg-config/files/patch-pkg.c
+++ b/devel/pkg-config/files/patch-pkg.c
@@ -1,6 +1,6 @@
---- pkg.c.orig Thu Jan 16 16:07:09 2003
-+++ pkg.c Wed Jan 22 18:11:41 2003
-@@ -113,7 +113,7 @@
+--- pkg.c.orig Tue Apr 12 07:08:13 2005
++++ pkg.c Tue Apr 12 13:55:42 2005
+@@ -128,7 +128,7 @@ name_ends_in_uninstalled (const char *st
* locations, ignoring duplicates
*/
static void
@@ -9,24 +9,13 @@
{
DIR *dir;
struct dirent *dent;
-@@ -133,7 +133,8 @@
+@@ -148,7 +148,8 @@ scan_dir (const char *dirname)
free (dirname_copy);
if (!dir)
{
- debug_spew ("Cannot open directory '%s' in package search path: %s\n",
+ if (!quiet)
-+ debug_spew ("Cannot open directory '%s' in package search path: %s\n",
++ debug_spew ("Cannot open directory '%s' in package search path: %s\n",
dirname, g_strerror (errno));
return;
}
-@@ -202,7 +203,9 @@
- path_positions = g_hash_table_new (g_str_hash, g_str_equal);
-
- g_slist_foreach (search_dirs, (GFunc)scan_dir, NULL);
-- scan_dir (pkglibdir);
-+ scan_dir (pkglibdir, (void *)0);
-+ scan_dir (XPKGLIBDIR, (void *)1);
-+ scan_dir (LPKGLIBDIR, (void *)1);
- }
- }
-