aboutsummaryrefslogtreecommitdiff
path: root/devel/pkgconf/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-07-26 05:40:22 +0000
commit9346b215f04cc84bbb7125ff2fcf03978f859a21 (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /devel/pkgconf/Makefile
parent49ac3accb4fc378c681317849f4ae94655a61423 (diff)
downloadports-9346b215f04cc84bbb7125ff2fcf03978f859a21.tar.gz
ports-9346b215f04cc84bbb7125ff2fcf03978f859a21.zip
Notes
Diffstat (limited to 'devel/pkgconf/Makefile')
-rw-r--r--devel/pkgconf/Makefile58
1 files changed, 58 insertions, 0 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
new file mode 100644
index 000000000000..9326504b1ec9
--- /dev/null
+++ b/devel/pkgconf/Makefile
@@ -0,0 +1,58 @@
+# New ports collection makefile for: pkgconf
+# Date created: 2012-07-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkgconf
+PORTVERSION= 0.8.3
+CATEGORIES= devel
+MASTER_SITES= http://nenolod.net/~nenolod/distfiles/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= pkg-config compatible utility which does not depend on glib
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pkg-config-dir=${PREFIX}/libdata/pkgconfig \
+ --with-system-libdir=/usr/lib \
+ --with-system-includedir=/usr/include
+USE_BZIP2= yes
+
+CONFLICTS_INSTALL= pkg-config-*
+
+post-install:
+ ${LN} -sf ${PREFIX}/bin/pkgconf ${PREFIX}/bin/pkg-config
+
+.include <bsd.port.mk>
+# New ports collection makefile for: pkgconf
+# Date created: 2012-07-22
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkgconf
+PORTVERSION= 0.8.3
+CATEGORIES= devel
+MASTER_SITES= http://nenolod.net/~nenolod/distfiles/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= pkg-config compatible utility which does not depend on glib
+
+LICENSE= BSD
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-pkg-config-dir=${PREFIX}/libdata/pkgconfig \
+ --with-system-libdir=/usr/lib \
+ --with-system-includedir=/usr/include
+USE_BZIP2= yes
+
+CONFLICTS_INSTALL= pkg-config-*
+
+post-install:
+ ${LN} -sf ${PREFIX}/bin/pkgconf ${PREFIX}/bin/pkg-config
+
+.include <bsd.port.mk>