aboutsummaryrefslogtreecommitdiff
path: root/devel/pkgconfig/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-04-29 11:23:21 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-04-29 11:23:21 +0000
commit4edf9758c2c887fe40cfffab645a734f20fa088f (patch)
treeb90a2506f5fdfaec5f9e9cbd9b9c61c709398398 /devel/pkgconfig/Makefile
parent0526b467be26e4e80fa04c9939abd6127b7a704f (diff)
Notes
Diffstat (limited to 'devel/pkgconfig/Makefile')
-rw-r--r--devel/pkgconfig/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/devel/pkgconfig/Makefile b/devel/pkgconfig/Makefile
new file mode 100644
index 000000000000..7a3607f78e09
--- /dev/null
+++ b/devel/pkgconfig/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: pkgconfig
+# Date created: 30 April 2001
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkgconfig
+PORTVERSION= 0.5.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= /nonexistent:${PORTSDIR}/devel/glib12:patch
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure glib-1.2.8/configure
+LIBTOOLFLAGS= --disable-ltlibs \
+ --disable-shared
+
+MAN1= pkg-config.1
+
+post-extract:
+ @${RM} -rf ${WRKSRC}/glib-1.2.8
+ @${LN} -sf ${WRKDIRPREFIX}${.CURDIR}/../../devel/glib12/work/glib-1.2* \
+ ${WRKSRC}/glib-1.2.8
+
+post-install:
+ ${MKDIR} ${PREFIX}/libdata/pkgconfig
+ ${INSTALL_MAN} ${WRKSRC}/pkg-config.1 ${PREFIX}/man/man1
+
+.include <bsd.port.mk>