aboutsummaryrefslogtreecommitdiff
path: root/devel/plan9port/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-03-07 12:49:21 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-03-07 12:49:21 +0000
commit7ee7afcb1a45132e9fdee2622dfde890e5975f5c (patch)
tree286f16d195608c7841a9a1d285e92f4eda9a9c4f /devel/plan9port/Makefile
parent1b58b62b4398ae4f3b665c858e0003119abf1958 (diff)
downloadports-7ee7afcb1a45132e9fdee2622dfde890e5975f5c.tar.gz
ports-7ee7afcb1a45132e9fdee2622dfde890e5975f5c.zip
Notes
Diffstat (limited to 'devel/plan9port/Makefile')
-rw-r--r--devel/plan9port/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index 81d347e55754..c83c692e6527 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -94,7 +94,9 @@ EMPTY_DIRS= plan9/log \
post-patch:
@${FIND} ${WRKSRC}/man -type f -regex ".*\.[0-9?]$\" \
- | ${XARGS} ${REINPLACE_CMD} -e 's|\\\*9|${PREFIX}/plan9|'
+ | ${XARGS} ${REINPLACE_CMD} -e 's|\\\*9|${PLAN9}|'
+ @${REINPLACE_CMD} -e 's|X11=/usr/X11R6|X11=${X11BASE}|' ${WRKSRC}/bin/9l \
+ ${WRKSRC}/src/cmd/devdraw/mkwsysrules.sh
do-build:
cd ${WRKSRC} && ./INSTALL
@@ -106,14 +108,14 @@ post-build:
${FIND} plan9 -type f \
-a ! -path "plan9/man/man[0-9]/*.[0-9]*"; \
for D in ${EMPTY_DIRS}; do \
- ${ECHO_CMD} "@exec ${MKDIR} ${PREFIX}/$${D}"; \
+ ${ECHO_CMD} "@exec ${MKDIR} ${TARGETDIR}/$${D}"; \
done; \
${FIND} plan9 -type d | ${SORT} -r \
| ${SED} -e 's|^|@dirrm |'; \
) > ${PLIST}
do-install:
- ${CP} -rp ${WRKSRC} ${PREFIX}
+ ${CP} -rp ${WRKSRC} ${TARGETDIR}
post-install:
cd ${PLAN9} && \