aboutsummaryrefslogtreecommitdiff
path: root/devel/ply/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-31 09:56:58 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-31 09:56:58 +0000
commit21eb89848bef16449057c7a933824648fc4566ac (patch)
tree77dc54e9d02ff258373fdbf7eaf4ac26514a42a7 /devel/ply/Makefile
parent91c0d28e69f236a3cd750a0328da79431514ddef (diff)
Notes
Diffstat (limited to 'devel/ply/Makefile')
-rw-r--r--devel/ply/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/devel/ply/Makefile b/devel/ply/Makefile
new file mode 100644
index 000000000000..5e42658d458d
--- /dev/null
+++ b/devel/ply/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# New ports collection makefile for: ply
+# Date created: Jul 31, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ply
+PORTVERSION= 1.0
+CATEGORIES= devel python
+MASTER_SITES= http://systems.cs.uchicago.edu/ply/
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/lex.py ${PYTHON_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/yacc.py ${PYTHON_SITELIBDIR}
+
+.if !defined(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/ply.html ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/example ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>