aboutsummaryrefslogtreecommitdiff
path: root/devel/pmake
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-11-11 16:52:58 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-11-11 16:52:58 +0000
commit821a697733cd87a78aa2bd19f6b0554418cf7d45 (patch)
tree02ca7cea8bbf165843c59741083cec3ee76bba65 /devel/pmake
parent7b3e74add8fe6cdda2bbcb26894be74b718c987c (diff)
downloadports-821a697733cd87a78aa2bd19f6b0554418cf7d45.tar.gz
ports-821a697733cd87a78aa2bd19f6b0554418cf7d45.zip
Notes
Diffstat (limited to 'devel/pmake')
-rw-r--r--devel/pmake/Makefile14
-rw-r--r--devel/pmake/files/patch-ae3
2 files changed, 8 insertions, 9 deletions
diff --git a/devel/pmake/Makefile b/devel/pmake/Makefile
index 5933c58a168b..6e38acc02758 100644
--- a/devel/pmake/Makefile
+++ b/devel/pmake/Makefile
@@ -22,8 +22,12 @@ WRKSRC= ${WRKDIR}/pmake
MAKEFILE= makefile
ALL_TARGET= pmake
PMAKE_ENV= ${MAKE_ENV} MAKE=${PREFIX}/bin/pmake
+USE_REINPLACE= yes
MAN1= pmake.1
+post-patch:
+ @${REINPLACE_CMD} '/memmove/d' ${WRKSRC}/lib/include/sprite.h
+
#
# Define this if you want to build and install with the 'customs'
# server support and the pmake to match. Note, you'll still get
@@ -31,12 +35,6 @@ MAN1= pmake.1
#
#WANT_CUSTOMS= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 502126
-BROKEN= "Broken by changes to make(1) on FreeBSD >= 5.x"
-.endif
-
do-install::
@(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} install)
@@ -53,8 +51,8 @@ do-install::
@${ECHO_CMD} -e 'customs\t\t8231/udp\t# pmake customs server'>>/etc/services
.else
do-install::
- @(cd ${WRKSRC}/doc; ${SETENV} ${PMAKE_ENV} ${PREFIX}/bin/pmake)
+ @(cd ${WRKSRC}/doc; ${SETENV} ${PMAKE_ENV} ${MAKE})
${INSTALL_MAN} ${WRKSRC}/doc/pmake.1 ${PREFIX}/man/man1
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pmake/files/patch-ae b/devel/pmake/files/patch-ae
index 4b4918a3c5bf..545771c69d82 100644
--- a/devel/pmake/files/patch-ae
+++ b/devel/pmake/files/patch-ae
@@ -3,7 +3,8 @@
@@ -19,7 +19,7 @@
# most of the stuff here is machine independent
.EXPORT:
-
+-
++.NOEXPORT:
-MANDIR = /usr/local/man
+MANDIR = $(PREFIX)/man
MANEXT1 = 1