aboutsummaryrefslogtreecommitdiff
path: root/devel/popt/Makefile
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-08-18 22:59:35 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-08-18 22:59:35 +0000
commit8a28463f99c253302bc820365a8011108898626c (patch)
tree04d4702ce9cc174613248447c2d46da765099104 /devel/popt/Makefile
parent845d64c66765d34b1a0f75707ce59bbd1035d5d9 (diff)
- make gettext a build dependency
- add a WITHOUT_NLS knob Requested by: many
Notes
Notes: svn path=/head/; revision=116634
Diffstat (limited to 'devel/popt/Makefile')
-rw-r--r--devel/popt/Makefile36
1 files changed, 24 insertions, 12 deletions
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
index 608a29fbcb88..74bc83dcd003 100644
--- a/devel/popt/Makefile
+++ b/devel/popt/Makefile
@@ -8,27 +8,39 @@
PORTNAME= popt
PORTVERSION= 1.7
CATEGORIES= devel
-MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/ \
- ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
+MASTER_SITES= ftp://ftp.rpm.org/pub/rpm/dist/%SUBDIR%/ \
+ http://rpmfind.net/linux/rpm.org/rpm/dist/%SUBDIR%/ \
+ ftp://ftp.mirror.ac.uk/sites/ftp.rpm.org/pub/rpm/dist/%SUBDIR%/ \
+ http://gd.tuwien.ac.at/utils/rpm.org/dist/%SUBDIR%/ \
+ ftp://sunsite.cnlab-switch.ch/mirror/rpm/dist/%SUBDIR%/ \
+ ftp://ftp.sunfreeware.com/pub/freeware/SOURCES/
+MASTER_SITE_SUBDIR= rpm-4.1.x
MAINTAINER= eik@FreeBSD.org
COMMENT= A getopt(3) like library with a number of enhancements, from Redhat
-USE_GETTEXT= yes
-USE_INC_LIBTOOL_VER= 13
+BUILD_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
+
+USE_LIBTOOL_VER= 15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
+
+MAN3= popt.3
+
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--program-prefix=""
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-MAN3= popt.3
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
-post-patch:
-# avoid installing both charset.alias and locale.alias which conflict
-# with libiconv
- @${REINPLACE_CMD} -E -e 's|(SUBDIRS[[:space:]]+=.*)intl|\1|' \
- ${WRKSRC}/Makefile.in
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>