aboutsummaryrefslogtreecommitdiff
path: root/devel/popt/Makefile
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-30 12:31:24 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>1999-12-30 12:31:24 +0000
commit281777db42bdcdd69aba1f62656b96da5491222f (patch)
tree936fc8a152c95a7d50534b9d6baf1c568dd00fb0 /devel/popt/Makefile
parent08e2ce737b4e8af2862add7db6af81ff4e3cf1eb (diff)
Notes
Diffstat (limited to 'devel/popt/Makefile')
-rw-r--r--devel/popt/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/devel/popt/Makefile b/devel/popt/Makefile
new file mode 100644
index 000000000000..d69bee600f09
--- /dev/null
+++ b/devel/popt/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: popt
+# Version required: 1.4
+# Date Created: 29 Dec 1999
+# Whom: Yuan-Chen Cheng <ycheng@sinica.edu.tw>
+#
+# $FreeBSD$
+#
+
+DISTNAME= popt-1.4
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.redhat.com/pub/redhat/current/SRPMS/SRPMS/ \
+ ftp://ftp.cdrom.com/pub/linux/redhat/current/SRPMS/SRPMS/
+EXTRACT_SUFX= -1.src.rpm
+
+MAINTAINER= ycheng@sinica.edu.tw
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/rpm2cpio:${PORTSDIR}/misc/rpm
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+MAN3= popt.3
+MANCOMPRESSED= no
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${LOCALBASE}/bin/rpm2cpio ${_DISTDIR}${DISTFILES} | (cd ${WRKDIR}; cpio -i)
+ @tar -xzf ${WRKDIR}/${DISTNAME}.tar.gz -C ${WRKDIR}
+
+.include <bsd.port.mk>